summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Väth <martin@mvath.de>2013-05-28 09:17:47 +0200
committerMartin Väth <martin@mvath.de>2015-10-11 10:48:44 +0200
commit065592923effc11c0cd397c2662b8f32bee9cb27 (patch)
treec4010f4149b35ab3bebb0b1a0e0df0afc7f464c5 /media-video/video-mv/video-mv-5.15.ebuild
parentUpdate zsh-completion (diff)
downloadmv-065592923effc11c0cd397c2662b8f32bee9cb27.tar.gz
mv-065592923effc11c0cd397c2662b8f32bee9cb27.tar.bz2
mv-065592923effc11c0cd397c2662b8f32bee9cb27.zip
Bump less, video-mv
Diffstat (limited to 'media-video/video-mv/video-mv-5.15.ebuild')
-rw-r--r--media-video/video-mv/video-mv-5.15.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/media-video/video-mv/video-mv-5.15.ebuild b/media-video/video-mv/video-mv-5.15.ebuild
new file mode 100644
index 00000000..95932971
--- /dev/null
+++ b/media-video/video-mv/video-mv-5.15.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+RESTRICT="mirror"
+inherit eutils vcs-snapshot
+
+DESCRIPTION="A frontend for using mplayer and mencoder as a video recorder"
+HOMEPAGE="https://github.com/vaeth/video-mv/"
+SRC_URI="http://github.com/vaeth/${PN}/tarball/release-${PV} -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+title zsh-completion"
+RDEPEND="app-shells/push
+ title? ( >=app-shells/runtitle-2.3[zsh-completion?] )
+ media-sound/alsautils
+ || ( media-video/mplayer[encode] virtual/ffmpeg )"
+DEPEND=""
+
+src_prepare() {
+ epatch_user
+}
+
+src_install() {
+ local i
+ insinto /usr/bin
+ for i in bin/*
+ do if test -h "${i}" || ! test -x "${i}"
+ then doins "${i}"
+ else dobin "${i}"
+ fi
+ done
+ insinto /etc
+ doins etc/*
+ if use zsh-completion
+ then insinto /usr/share/zsh/site-functions
+ doins zsh/*
+ fi
+ dodoc README
+}