summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Väth <martin@mvath.de>2015-03-15 22:28:09 +0100
committerMartin Väth <martin@mvath.de>2015-10-11 10:49:21 +0200
commit83961f4c76a0de435f074a1173367e1eda97dbf5 (patch)
treebc87aef66e3222a856d7a2f73adf13ad62892666 /media-video
parentBump less, sundtek-tv, noscript (diff)
downloadmv-83961f4c76a0de435f074a1173367e1eda97dbf5.tar.gz
mv-83961f4c76a0de435f074a1173367e1eda97dbf5.tar.bz2
mv-83961f4c76a0de435f074a1173367e1eda97dbf5.zip
bump squashmount, noscript. video-mv: deprecate mplayer2
Diffstat (limited to 'media-video')
-rw-r--r--media-video/video-mv/ChangeLog5
-rw-r--r--media-video/video-mv/video-mv-7.17-r1.ebuild64
2 files changed, 69 insertions, 0 deletions
diff --git a/media-video/video-mv/ChangeLog b/media-video/video-mv/ChangeLog
index 50aad2e8..d52d9127 100644
--- a/media-video/video-mv/ChangeLog
+++ b/media-video/video-mv/ChangeLog
@@ -2,6 +2,11 @@
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+*video-mv-7.17-r1 (15 Mar 2015)
+
+ 15 Mar 2014; Martin Väth <martin@mvath.de>:
+ Remove *mplayer2, since its support is deprecated in gentoo
+
*video-mv-7.17 (18 Aug 2014)
18 Aug 2014; Martin Väth <martin@mvath.de>:
diff --git a/media-video/video-mv/video-mv-7.17-r1.ebuild b/media-video/video-mv/video-mv-7.17-r1.ebuild
new file mode 100644
index 00000000..081fa933
--- /dev/null
+++ b/media-video/video-mv/video-mv-7.17-r1.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+RESTRICT="mirror"
+inherit eutils readme.gentoo
+
+DESCRIPTION="Frontends for using mplayer/mencoder, ffmpeg/libav, or tzap as video recorder"
+HOMEPAGE="https://github.com/vaeth/video-mv/"
+SRC_URI="https://github.com/vaeth/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+RDEPEND="app-shells/push
+ >=app-shells/runtitle-2.3
+ || ( ( media-sound/alsa-utils
+ || ( media-video/mplayer[encode] virtual/ffmpeg ) )
+ media-tv/linuxtv-dvb-apps )"
+DEPEND=""
+
+DISABLE_AUTOFORMATTING="true"
+DOC_CONTENTS="If you use dvb-t with zsh completion, you might want to put
+zstyle ':completion:*' matcher-list '' 'm:{a-zA-Z}={A-Za-z}'
+into your ~/.zshrc or /etc/zshrc for case-insensitive matching."
+
+src_prepare() {
+ local i
+ use prefix || for i in bin/*
+ do test -h "${i}" || sed -i \
+ -e '1s"^#!/usr/bin/env sh$"#!'"${EPREFIX}/bin/sh"'"' \
+ -e 's"^\. _videoscript\.sh$". '"${EPREFIX}/usr/share/video-mv/_videoscript.sh"'"' \
+ -- "${i}" || die
+ done
+ rm bin/*mplayer2*
+ epatch_user
+}
+
+src_install() {
+ local i
+ insinto /usr/bin
+ for i in bin/*
+ do if test -h "${i}"
+ then doins "${i}"
+ elif [ "${i#*/}" != '_videoscript.sh' ]
+ then dobin "${i}"
+ fi
+ done
+ insinto /usr/share/video-mv
+ doins bin/_videoscript.sh
+ insinto /etc
+ doins etc/*
+ insinto /usr/share/zsh/site-functions
+ doins zsh/*
+ dodoc README
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ optfeature "status bar support" app-shells/runtitle
+ readme.gentoo_pkg_postinst
+}