summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Väth <martin@mvath.de>2015-10-11 11:26:48 +0200
committerMartin Väth <martin@mvath.de>2015-10-11 11:32:18 +0200
commit109d6b4f673a249aea4deeb0cdb5b54a21592410 (patch)
treeec3589a50dac5be54ef6248d1e0ff3a9fd3b41b4 /net-firewall/firewall-mv
downloadmv-109d6b4f673a249aea4deeb0cdb5b54a21592410.tar.gz
mv-109d6b4f673a249aea4deeb0cdb5b54a21592410.tar.bz2
mv-109d6b4f673a249aea4deeb0cdb5b54a21592410.zip
Clear history for egencache --repo=mv --update-changelogs
Diffstat (limited to 'net-firewall/firewall-mv')
-rw-r--r--net-firewall/firewall-mv/Manifest1
-rw-r--r--net-firewall/firewall-mv/firewall-mv-8.13.ebuild47
-rw-r--r--net-firewall/firewall-mv/metadata.xml16
3 files changed, 64 insertions, 0 deletions
diff --git a/net-firewall/firewall-mv/Manifest b/net-firewall/firewall-mv/Manifest
new file mode 100644
index 00000000..9a138a03
--- /dev/null
+++ b/net-firewall/firewall-mv/Manifest
@@ -0,0 +1 @@
+DIST firewall-mv-8.13.tar.gz 15578 SHA256 784a49c7ee50432f6d9666406978d2b1a283be72d7eb6e4fd36543c5552f98a0 SHA512 4ad7e0686078254683a49ee0956c37a6bda80ece5c806f792a4cafb773fd74fda86c901e1ef1cb4ecae52fa67bd149a84c303aacc98f44b3973da600c0667cee WHIRLPOOL a721a4fd824cf10325d9cb716fb2d8843d48c9667c38c700f8fa99a4d78a81a9ad3f0999aaf2fea0b20cca8ae611164fe58a5d4b5f16429ede54fcf93000c3a7
diff --git a/net-firewall/firewall-mv/firewall-mv-8.13.ebuild b/net-firewall/firewall-mv/firewall-mv-8.13.ebuild
new file mode 100644
index 00000000..4584ba78
--- /dev/null
+++ b/net-firewall/firewall-mv/firewall-mv-8.13.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+RESTRICT="mirror"
+inherit eutils systemd
+
+DESCRIPTION="Initialize iptables and net-related sysctl variables"
+HOMEPAGE="https://github.com/vaeth/firewall-mv/"
+SRC_URI="https://github.com/vaeth/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+RDEPEND="!<sys-apps/openrc-0.13
+ app-shells/push"
+DEPEND=""
+
+src_prepare() {
+ if use prefix
+ then sed -i \
+ -e "s!/etc/!${EPREFIX}/etc/!g" \
+ -e "s!/usr/!${EPREFIX}/usr/!g" \
+ -- sbin/* etc/* systemd/* || die
+ else sed -i \
+ -e '1s"^#!/usr/bin/env sh$"#!'"${EPREFIX}/bin/sh"'"' \
+ -- sbin/* || die
+ fi
+ epatch_user
+}
+
+src_install() {
+ into /
+ dosbin sbin/*
+ insinto /etc
+ doins -r etc/*
+ insinto /usr/lib/modules-load.d
+ doins modules-load.d/*
+ insinto /usr/share/zsh/site-functions
+ doins zsh/*
+ doconfd openrc/conf.d/*
+ doinitd openrc/init.d/*
+ dodoc README
+ systemd_dounit systemd/*
+}
diff --git a/net-firewall/firewall-mv/metadata.xml b/net-firewall/firewall-mv/metadata.xml
new file mode 100644
index 00000000..3f9b1748
--- /dev/null
+++ b/net-firewall/firewall-mv/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>martin@mvath.de</email>
+ <name>Martin Väth</name>
+ </maintainer>
+ <upstream>
+ <maintainer>
+ <email>martin@mvath.de</email>
+ <name>Martin Väth</name>
+ </maintainer>
+ <bugs-to>mailto:martin@mvath.de</bugs-to>
+ <remote-id type="github">vaeth/firewall-mv</remote-id>
+ </upstream>
+</pkgmetadata>