summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Väth <martin@mvath.de>2012-04-15 21:00:18 +0200
committerMartin Väth <martin@mvath.de>2015-10-11 10:47:36 +0200
commitbd582bfb4b4f1b38ed7effb0e65353f9bae30f9c (patch)
tree27fca8ca6840a4fc125774621d98490fead6f32f /net-print
parentAdd requestpolicy ebuild (diff)
downloadmv-bd582bfb4b4f1b38ed7effb0e65353f9bae30f9c.tar.gz
mv-bd582bfb4b4f1b38ed7effb0e65353f9bae30f9c.tar.bz2
mv-bd582bfb4b4f1b38ed7effb0e65353f9bae30f9c.zip
Add base. Fix stardict compilation
Diffstat (limited to 'net-print')
-rw-r--r--net-print/foo2zjs/ChangeLog5
-rw-r--r--net-print/foo2zjs/foo2zjs-20081129-r1.ebuild20
2 files changed, 14 insertions, 11 deletions
diff --git a/net-print/foo2zjs/ChangeLog b/net-print/foo2zjs/ChangeLog
index 197c9e58..362fd8b2 100644
--- a/net-print/foo2zjs/ChangeLog
+++ b/net-print/foo2zjs/ChangeLog
@@ -1,7 +1,10 @@
# ChangeLog for net-print/foo2zjs
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
# $Header $
+ 15 Apr 2012; Martin Väth <martin@mvath.de>
+ Inherit base
+
03 Jan 2011; Martin Väth <martin@mvath.de>
Bump to EAPI=4.
diff --git a/net-print/foo2zjs/foo2zjs-20081129-r1.ebuild b/net-print/foo2zjs/foo2zjs-20081129-r1.ebuild
index eb27709e..e301be87 100644
--- a/net-print/foo2zjs/foo2zjs-20081129-r1.ebuild
+++ b/net-print/foo2zjs/foo2zjs-20081129-r1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header $
EAPI="4"
-inherit eutils
+inherit base
DESCRIPTION="Support for printing to ZjStream-based printers. Fixes bug 271079"
HOMEPAGE="http://foo2zjs.rkkda.com/"
@@ -80,23 +80,23 @@ RDEPEND="cups? ( net-print/cups )
net-print/foomatic-filters
sys-fs/udev"
KEYWORDS="~x86 ~amd64 ~ppc"
-S=${WORKDIR}/${PN}
+S="${WORKDIR}/${PN}"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-Makefile.patch
+ "${FILESDIR}"/${P}-udevfwld.patch
+)
src_unpack() {
unpack ${P}.tar.gz
# link getweb files in ${S} to get unpacked
+ local i
for i in ${A}
- do
- ln -s "${DISTDIR}"/${i} "${S}"
+ do ln -s "${DISTDIR}"/${i} "${S}"
done
}
-src_prepare() {
- epatch "${FILESDIR}"/${P}-Makefile.patch
- epatch "${FILESDIR}"/${P}-udevfwld.patch
-}
-
src_compile() {
emake getweb || die "Failed building getweb script"