summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Väth <martin@mvath.de>2020-08-09 08:32:20 +0200
committerMartin Väth <martin@mvath.de>2020-08-09 08:32:20 +0200
commitba109bca28a9afdc466580d857b8a45095bf8121 (patch)
tree9a823417c5e5d28a4e5041748a2435538a28a3d7 /sci-geosciences/googleearth
parentgames-rpg/m5figur-mv: Version bump (diff)
downloadmv-ba109bca28a9afdc466580d857b8a45095bf8121.tar.gz
mv-ba109bca28a9afdc466580d857b8a45095bf8121.tar.bz2
mv-ba109bca28a9afdc466580d857b8a45095bf8121.zip
www-plugins squashfs-tool googleearth sundtek-tv schily-tools: Version bumps
Signed-off-by: Martin Väth <martin@mvath.de>
Diffstat (limited to 'sci-geosciences/googleearth')
-rw-r--r--sci-geosciences/googleearth/Manifest1
-rw-r--r--sci-geosciences/googleearth/googleearth-7.3.2.ebuild (renamed from sci-geosciences/googleearth/googleearth-7.3.2-r2.ebuild)0
-rw-r--r--sci-geosciences/googleearth/googleearth-7.3.3.ebuild156
3 files changed, 157 insertions, 0 deletions
diff --git a/sci-geosciences/googleearth/Manifest b/sci-geosciences/googleearth/Manifest
index 71656314..201593e2 100644
--- a/sci-geosciences/googleearth/Manifest
+++ b/sci-geosciences/googleearth/Manifest
@@ -3,3 +3,4 @@ DIST google-earth-pro-stable_7.1.8.3036-r0_i386.deb 44460270 SHA512 74176fd389bc
DIST google-earth-pro-stable_7.3.0.3832-r0_amd64.deb 57842874 SHA512 af75d6dc223983aba7f84685c8f12bb06b4972fe0a50a883c5ee3321c37b16cd25ac7c60da3c80f4bf7cec41011827fab9f66ba2c9c3f404cd7270f610815251
DIST google-earth-pro-stable_7.3.0.3832-r0_i386.deb 56685312 SHA512 7bdf9cdf5d431b55ccc02e15e9f58bb9b3ed6590a6f53afe7202ba2d8fd38be333e9bfe273ea64502a78fb4263021da15b16cf474ea48a3742f0ce622eb8d151
DIST google-earth-pro-stable_7.3.2_amd64.deb 56455100 SHA512 f17427796d01ea01e5cd8ac357121fff0a72815bb3a01fc9a4a531d3aa49e9850ec54cf59d8c2383e46214861f5f2de9a90fbe157d53dccdb39437e55c006f29
+DIST google-earth-pro-stable_7.3.3_amd64.deb 56057072 SHA512 51f3fd8d3aeaab91a662c4c825f9c1a59fde00a07574441b3b4b29799cfde19c8fb42f348b98480cce7ba28116bf714ebed250fe9029dbd6127dc8f6fec3aa72
diff --git a/sci-geosciences/googleearth/googleearth-7.3.2-r2.ebuild b/sci-geosciences/googleearth/googleearth-7.3.2.ebuild
index 6ea761ee..6ea761ee 100644
--- a/sci-geosciences/googleearth/googleearth-7.3.2-r2.ebuild
+++ b/sci-geosciences/googleearth/googleearth-7.3.2.ebuild
diff --git a/sci-geosciences/googleearth/googleearth-7.3.3.ebuild b/sci-geosciences/googleearth/googleearth-7.3.3.ebuild
new file mode 100644
index 00000000..6ea761ee
--- /dev/null
+++ b/sci-geosciences/googleearth/googleearth-7.3.3.ebuild
@@ -0,0 +1,156 @@
+# Copyright 1999-2019 Martin V\"ath and others
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit desktop eutils pax-utils unpacker xdg-utils
+
+DESCRIPTION="A 3D interface to the planet"
+HOMEPAGE="https://www.google.com/earth/desktop/"
+SRC_URI="https://dl.google.com/dl/linux/direct/google-earth-pro-stable_${PV}_amd64.deb"
+LICENSE="googleearth GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+RESTRICT="mirror splitdebug"
+IUSE="+bundled-qt"
+
+QA_PREBUILT="*"
+
+RDEPEND="
+ dev-libs/glib:2
+ dev-libs/nspr
+ media-libs/fontconfig
+ media-libs/freetype
+ media-libs/gstreamer:1.0=
+ media-libs/gst-plugins-base:1.0=
+ net-libs/libproxy
+ net-misc/curl
+ sys-devel/gcc[cxx]
+ sys-libs/zlib
+ virtual/glu
+ virtual/opengl
+ virtual/ttf-fonts
+ x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/libX11
+ x11-libs/libXi
+ x11-libs/libXext
+ x11-libs/libXrender
+ x11-libs/libXau
+ x11-libs/libXdmcp
+ !bundled-qt? (
+ dev-qt/qtcore:5
+ dev-qt/qtdbus:5
+ dev-qt/qtdeclarative:5
+ dev-qt/qtgui:5
+ dev-qt/qtmultimedia:5[widgets]
+ dev-qt/qtnetwork:5
+ dev-qt/qtopengl:5
+ dev-qt/qtpositioning:5
+ dev-qt/qtprintsupport:5
+ dev-qt/qtsensors:5
+ dev-qt/qtscript:5[scripttools]
+ dev-qt/qtwebchannel:5
+ dev-qt/qtwebkit:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtx11extras:5
+ )"
+# sci-libs/gdal-1*
+BDEPEND="dev-util/patchelf"
+
+S=${WORKDIR}/opt/google/earth/pro
+
+src_unpack() {
+ # default src_unpack fails with deb2targz installed, also this unpacks the data.tar.lzma as well
+ unpack_deb ${A}
+
+ cd opt/google/earth/pro || die
+ if ! use bundled-qt ; then
+ einfo "removing bundled qt"
+ rm -v libQt5{Core,DBus,Gui,Multimedia,MultimediaWidgets,Network,OpenGL,Positioning,PrintSupport,Qml,Quick,Script,ScriptTools,Sensors,Sql,WebChannel,WebKit,WebKitWidgets,Widgets,X11Extras,XcbQpa}.so.5 || die
+ fi
+}
+
+src_prepare() {
+
+ # we have no ld-lsb.so.3 symlink
+ # thanks to Nathan Phillip Brink <ohnobinki@ohnopublishing.net> for suggesting patchelf
+ einfo "running patchelf"
+ patchelf --set-interpreter /$(get_libdir)/ld-linux$(usex amd64 "-x86-64" "").so.2 ${PN}-bin || die "patchelf failed"
+
+ # Set RPATH for preserve-libs handling (bug #265372).
+ local x
+ for x in * ; do
+ # Use \x7fELF header to separate ELF executables and libraries
+ [[ -f ${x} && $(od -t x1 -N 4 "${x}") == *"7f 45 4c 46"* ]] || continue
+ chmod u+w "${x}" || die
+ patchelf --set-rpath '$ORIGIN' "${x}" || \
+ die "patchelf failed on ${x}"
+ done
+ for x in plugins/*.so ; do
+ [[ -f ${x} ]] || continue
+ chmod u+w "${x}" || die
+ patchelf --set-rpath '$ORIGIN/..' "${x}" || \
+ die "patchelf failed on ${x}"
+ done
+ for x in plugins/imageformats/*.so ; do
+ [[ -f ${x} ]] || continue
+ chmod u+w "${x}" || die
+ patchelf --set-rpath '$ORIGIN/../..' "${x}" || \
+ die "patchelf failed on ${x}"
+ done
+
+ eapply -p0 "${FILESDIR}"/${PN}-${PV%%.*}-pro-desktopfile.patch
+ default
+}
+
+src_install() {
+ make_wrapper ${PN} ./${PN} /opt/${PN} .
+
+ insinto /usr/share/mime/packages
+ doins "${FILESDIR}/${PN}-mimetypes.xml" || die
+
+ domenu google-earth-pro.desktop
+
+ local size
+ for size in 16 22 24 32 48 64 128 256 ; do
+ newicon -s ${size} product_logo_${size}.png google-earth-pro.png
+ done
+
+ rm -rf xdg-mime xdg-settings google-earth-pro google-earth-pro.desktop product_logo_*
+
+ insinto /opt/${PN}
+ doins -r *
+
+ chmod +x "${ED}"/opt/${PN}/{${PN}{,-bin},repair_tool,gpsbabel} || die
+ find "${ED}" -type f '(' -name '*.so.*' -o -name '*.so' ')' -exec chmod +x '{}' + || die
+
+ pax-mark -m "${ED%/}"/opt/${PN}/${PN}-bin
+}
+
+pkg_postinst() {
+ elog "When you get a crash starting Google Earth, try adding a file ~./.config/Google/GoogleEarthPlus.conf"
+ elog "with the following options:"
+ elog "lastTip = 4"
+ elog "enableTips = false"
+ elog ""
+ elog "In addition, the use of free video drivers may cause problems associated with using the Mesa"
+ elog "library. In this case, Google Earth 6x likely only works with the Gallium3D variant."
+ elog "To select the 32bit graphic library use the command:"
+ elog " eselect mesa list"
+ elog "For example, for Radeon R300 (x86):"
+ elog " eselect mesa set r300 2"
+ elog "For Intel Q33 (amd64):"
+ elog " eselect mesa set 32bit i965 2"
+ elog "You may need to restart X afterwards"
+
+ xdg_desktop_database_update
+ xdg_mimeinfo_database_update
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ xdg_mimeinfo_database_update
+ xdg_icon_cache_update
+}