summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Väth <mvath@google.com>2019-03-02 08:30:14 +0100
committerMartin Väth <mvath@google.com>2019-03-02 08:30:14 +0100
commit35b757eec0b8965af5d833ac494fa8927b9f3050 (patch)
tree4f4b603e0628a14c07fa4b25362edac42d37d4e3 /sci-geosciences
parentapp-portage/eix: Version bump (diff)
downloadmv-35b757eec0b8965af5d833ac494fa8927b9f3050.tar.gz
mv-35b757eec0b8965af5d833ac494fa8927b9f3050.tar.bz2
mv-35b757eec0b8965af5d833ac494fa8927b9f3050.zip
EAPI version bumps
Signed-off-by: Martin Väth <mvath@google.com>
Diffstat (limited to 'sci-geosciences')
-rw-r--r--sci-geosciences/googleearth/googleearth-7.1.8.3036-r2.ebuild (renamed from sci-geosciences/googleearth/googleearth-7.1.8.3036-r1.ebuild)29
-rw-r--r--sci-geosciences/googleearth/googleearth-7.3.0.3832-r2.ebuild (renamed from sci-geosciences/googleearth/googleearth-7.3.0.3832-r1.ebuild)29
-rw-r--r--sci-geosciences/googleearth/googleearth-7.3.2-r1.ebuild (renamed from sci-geosciences/googleearth/googleearth-7.3.2.ebuild)27
3 files changed, 41 insertions, 44 deletions
diff --git a/sci-geosciences/googleearth/googleearth-7.1.8.3036-r1.ebuild b/sci-geosciences/googleearth/googleearth-7.1.8.3036-r2.ebuild
index ef1204f7..9af756fc 100644
--- a/sci-geosciences/googleearth/googleearth-7.1.8.3036-r1.ebuild
+++ b/sci-geosciences/googleearth/googleearth-7.1.8.3036-r2.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2018 Martin V\"ath and others
+# Copyright 1999-2019 Martin V\"ath and others
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-inherit eapi7-ver desktop eutils gnome2-utils pax-utils unpacker xdg-utils
+inherit desktop eutils gnome2-utils pax-utils unpacker xdg-utils
DESCRIPTION="A 3D interface to the planet"
HOMEPAGE="https://www.google.com/earth/desktop/"
@@ -47,7 +47,7 @@ RDEPEND="
=sci-libs/proj-4.8.0*
)"
# sci-libs/gdal-1*
-DEPEND="dev-util/patchelf"
+BDEPEND="dev-util/patchelf"
S=${WORKDIR}/opt/google/earth/pro
@@ -88,20 +88,20 @@ src_prepare() {
for x in * ; do
# Use \x7fELF header to separate ELF executables and libraries
[[ -f ${x} && $(od -t x1 -N 4 "${x}") == *"7f 45 4c 46"* ]] || continue
- fperms u+w "${x}"
- patchelf --set-rpath '$ORIGIN' "${x}" ||
+ chmod u+w "${x}" || die
+ patchelf --set-rpath '$ORIGIN' "${x}" || \
die "patchelf failed on ${x}"
done
- # prepare file permissions so that >patchelf-0.8 can work on the files
- fperms u+w plugins/*.so plugins/imageformats/*.so
for x in plugins/*.so ; do
[[ -f ${x} ]] || continue
- patchelf --set-rpath '$ORIGIN/..' "${x}" ||
+ chmod u+w "${x}" || die
+ patchelf --set-rpath '$ORIGIN/..' "${x}" || \
die "patchelf failed on ${x}"
done
for x in plugins/imageformats/*.so ; do
[[ -f ${x} ]] || continue
- patchelf --set-rpath '$ORIGIN/../..' "${x}" ||
+ chmod u+w "${x}" || die
+ patchelf --set-rpath '$ORIGIN/../..' "${x}" || \
die "patchelf failed on ${x}"
done
@@ -127,9 +127,8 @@ src_install() {
insinto /opt/${PN}
doins -r *
- fperms +x /opt/${PN}/${PN}{,-bin}
- cd "${ED}" || die
- find . -type f -name "*.so.*" -exec fperms +x '{}' +
+ chmod +x /opt/${PN}/${PN}{,-bin} || die
+ find "${ED}" -type f -name "*.so.*" -exec chmod +x '{}' +
pax-mark -m "${ED%/}"/opt/${PN}/${PN}-bin
}
@@ -156,11 +155,11 @@ pkg_postinst() {
xdg_desktop_database_update
xdg_mimeinfo_database_update
- gnome2_icon_cache_update
+ xdg_icon_cache_update
}
pkg_postrm() {
xdg_desktop_database_update
xdg_mimeinfo_database_update
- gnome2_icon_cache_update
+ xdg_icon_cache_update
}
diff --git a/sci-geosciences/googleearth/googleearth-7.3.0.3832-r1.ebuild b/sci-geosciences/googleearth/googleearth-7.3.0.3832-r2.ebuild
index 5c960d54..3e60bb91 100644
--- a/sci-geosciences/googleearth/googleearth-7.3.0.3832-r1.ebuild
+++ b/sci-geosciences/googleearth/googleearth-7.3.0.3832-r2.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2018 Martin V\"ath and others
+# Copyright 1999-2019 Martin V\"ath and others
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-inherit eapi7-ver desktop eutils gnome2-utils pax-utils unpacker xdg-utils
+inherit desktop eutils gnome2-utils pax-utils unpacker xdg-utils
DESCRIPTION="A 3D interface to the planet"
HOMEPAGE="https://www.google.com/earth/desktop/"
@@ -59,7 +59,7 @@ RDEPEND="
dev-qt/qtx11extras:5
)"
# sci-libs/gdal-1*
-DEPEND="dev-util/patchelf"
+BDEPEND="dev-util/patchelf"
S=${WORKDIR}/opt/google/earth/pro
@@ -96,20 +96,20 @@ src_prepare() {
for x in * ; do
# Use \x7fELF header to separate ELF executables and libraries
[[ -f ${x} && $(od -t x1 -N 4 "${x}") == *"7f 45 4c 46"* ]] || continue
- fperms u+w "${x}"
- patchelf --set-rpath '$ORIGIN' "${x}" ||
+ chmod u+w "${x}" || die
+ patchelf --set-rpath '$ORIGIN' "${x}" || \
die "patchelf failed on ${x}"
done
- # prepare file permissions so that >patchelf-0.8 can work on the files
- fperms u+w plugins/*.so plugins/imageformats/*.so
for x in plugins/*.so ; do
[[ -f ${x} ]] || continue
- patchelf --set-rpath '$ORIGIN/..' "${x}" ||
+ chmod u+w "${x}" || die
+ patchelf --set-rpath '$ORIGIN/..' "${x}" || \
die "patchelf failed on ${x}"
done
for x in plugins/imageformats/*.so ; do
[[ -f ${x} ]] || continue
- patchelf --set-rpath '$ORIGIN/../..' "${x}" ||
+ chmod u+w "${x}" || die
+ patchelf --set-rpath '$ORIGIN/../..' "${x}" || \
die "patchelf failed on ${x}"
done
@@ -135,9 +135,8 @@ src_install() {
insinto /opt/${PN}
doins -r *
- fperms +x /opt/${PN}/${PN}{,-bin}
- cd "${ED}" || die
- find . -type f -name "*.so.*" -exec fperms +x '{}' +
+ chmod +x /opt/${PN}/${PN}{,-bin} || die
+ find "${ED}" -type f -name "*.so.*" -exec chmod +x '{}' +
pax-mark -m "${ED%/}"/opt/${PN}/${PN}-bin
}
@@ -164,11 +163,11 @@ pkg_postinst() {
xdg_desktop_database_update
xdg_mimeinfo_database_update
- gnome2_icon_cache_update
+ xdg_icon_cache_update
}
pkg_postrm() {
xdg_desktop_database_update
xdg_mimeinfo_database_update
- gnome2_icon_cache_update
+ xdg_icon_cache_update
}
diff --git a/sci-geosciences/googleearth/googleearth-7.3.2.ebuild b/sci-geosciences/googleearth/googleearth-7.3.2-r1.ebuild
index 3bbc54df..866b3d7c 100644
--- a/sci-geosciences/googleearth/googleearth-7.3.2.ebuild
+++ b/sci-geosciences/googleearth/googleearth-7.3.2-r1.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2018 Martin V\"ath and others
+# Copyright 1999-2019 Martin V\"ath and others
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
inherit desktop eutils gnome2-utils pax-utils unpacker xdg-utils
@@ -56,7 +56,7 @@ RDEPEND="
dev-qt/qtx11extras:5
)"
# sci-libs/gdal-1*
-DEPEND="dev-util/patchelf"
+BDEPEND="dev-util/patchelf"
S=${WORKDIR}/opt/google/earth/pro
@@ -83,20 +83,20 @@ src_prepare() {
for x in * ; do
# Use \x7fELF header to separate ELF executables and libraries
[[ -f ${x} && $(od -t x1 -N 4 "${x}") == *"7f 45 4c 46"* ]] || continue
- fperms u+w "${x}"
- patchelf --set-rpath '$ORIGIN' "${x}" ||
+ chmod u+w "${x}" || die
+ patchelf --set-rpath '$ORIGIN' "${x}" || \
die "patchelf failed on ${x}"
done
- # prepare file permissions so that >patchelf-0.8 can work on the files
- fperms u+w plugins/*.so plugins/imageformats/*.so
for x in plugins/*.so ; do
[[ -f ${x} ]] || continue
- patchelf --set-rpath '$ORIGIN/..' "${x}" ||
+ chmod u+w "${x}" || die
+ patchelf --set-rpath '$ORIGIN/..' "${x}" || \
die "patchelf failed on ${x}"
done
for x in plugins/imageformats/*.so ; do
[[ -f ${x} ]] || continue
- patchelf --set-rpath '$ORIGIN/../..' "${x}" ||
+ chmod u+w "${x}" || die
+ patchelf --set-rpath '$ORIGIN/../..' "${x}" || \
die "patchelf failed on ${x}"
done
@@ -122,9 +122,8 @@ src_install() {
insinto /opt/${PN}
doins -r *
- fperms +x /opt/${PN}/${PN}{,-bin}
- cd "${ED}" || die
- find . -type f -name "*.so.*" -exec fperms +x '{}' +
+ chmod +x /opt/${PN}/${PN}{,-bin} || die
+ find "${ED}" -type f -name "*.so.*" -exec chmod +x '{}' +
pax-mark -m "${ED%/}"/opt/${PN}/${PN}-bin
}
@@ -151,11 +150,11 @@ pkg_postinst() {
xdg_desktop_database_update
xdg_mimeinfo_database_update
- gnome2_icon_cache_update
+ xdg_icon_cache_update
}
pkg_postrm() {
xdg_desktop_database_update
xdg_mimeinfo_database_update
- gnome2_icon_cache_update
+ xdg_icon_cache_update
}