summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Väth <martin@mvath.de>2013-05-31 11:07:33 +0200
committerMartin Väth <martin@mvath.de>2015-10-11 10:48:44 +0200
commitcedf3168d132acf7f5f8b2ffee80848a42165ff5 (patch)
treeb59491390227c47cc06869bf4a799bdb21f76f1a /sci-mathematics/genius
parentAdd zsh live ebuild (diff)
downloadmv-cedf3168d132acf7f5f8b2ffee80848a42165ff5.tar.gz
mv-cedf3168d132acf7f5f8b2ffee80848a42165ff5.tar.bz2
mv-cedf3168d132acf7f5f8b2ffee80848a42165ff5.zip
Add genius to make gnome-doc-utils optional. Fix stardict linking
Diffstat (limited to 'sci-mathematics/genius')
-rw-r--r--sci-mathematics/genius/ChangeLog6
-rw-r--r--sci-mathematics/genius/Manifest2
-rw-r--r--sci-mathematics/genius/genius-1.0.16.ebuild68
-rw-r--r--sci-mathematics/genius/metadata.xml19
4 files changed, 95 insertions, 0 deletions
diff --git a/sci-mathematics/genius/ChangeLog b/sci-mathematics/genius/ChangeLog
new file mode 100644
index 00000000..1115c86c
--- /dev/null
+++ b/sci-mathematics/genius/ChangeLog
@@ -0,0 +1,6 @@
+# ChangeLog for sci-mathematics/genius
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+ 31 May 2013; Martin Väth <martin@mvath.de>:
+ Copy from tree to make gnome-doc-utils optional. Clean old ChangeLog.
diff --git a/sci-mathematics/genius/Manifest b/sci-mathematics/genius/Manifest
new file mode 100644
index 00000000..d3d38129
--- /dev/null
+++ b/sci-mathematics/genius/Manifest
@@ -0,0 +1,2 @@
+DIST genius-1.0.16.tar.xz 2254836 SHA256 45ce3e0b02c109588ff9a4c74e7c3541b3de89ea93f20ab08178c51c6ab4fb78 SHA512 130528fb92acb7829444086b0614368ca781838e97da6691d63d16652f8f7cdff2a171200f17331667395122f939be8f82cc9b2595717249edaa622e40a7ba28 WHIRLPOOL 1ec1d2e714b4e08419f86ccedbbba89fc5b5f220238bf3ae4fd12ab9b64249716d7ca087700d4707f6c597b8d08ececf12fff013410934abd4470ee88f104c3b
+DIST genius-reference.pdf 1024944 SHA256 79011ae33ff781507185898ba76b156699061eda78ed16e15aa02195c896ee4b SHA512 04af3870104d2320b1d4b345d74d713a0dfcdf8a228002506508f437659b3ef6037ead0b1f6b37cc335692150750b58c4007fdaaddd9540233474ccd10dac285 WHIRLPOOL 301302145d43843ddd749ab33612438d360462c9d3daa12d7050d9ca6da82bdea3ef53b917989d0c518327780b147a9f74e407f555a62dcdbe0f0c2ef864fa88
diff --git a/sci-mathematics/genius/genius-1.0.16.ebuild b/sci-mathematics/genius/genius-1.0.16.ebuild
new file mode 100644
index 00000000..3cef4197
--- /dev/null
+++ b/sci-mathematics/genius/genius-1.0.16.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/genius/genius-1.0.16.ebuild,v 1.2 2013/01/02 08:35:45 grozin Exp $
+
+EAPI=4
+inherit autotools eutils gnome2
+
+DESCRIPTION="Genius Mathematics Tool and the GEL Language"
+HOMEPAGE="http://www.jirka.org/genius.html"
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc gnome nls"
+SRC_URI="http://ftp.gnome.org/pub/GNOME/sources/${PN}/1.0/${P}.tar.xz
+ doc? ( http://www.jirka.org/${PN}-reference.pdf )"
+
+RDEPEND="
+ dev-libs/glib:2
+ dev-libs/gmp
+ dev-libs/mpfr
+ dev-libs/popt
+ sys-libs/ncurses
+ sys-libs/readline
+ gnome? (
+ app-text/scrollkeeper
+ app-text/gnome-doc-utils
+ x11-libs/gtk+:2
+ gnome-base/libgnome
+ gnome-base/libgnomeui
+ gnome-base/libglade:2.0
+ x11-libs/gtksourceview:2.0
+ x11-libs/vte:0 )"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ || ( sys-devel/bison
+ dev-util/yacc )
+ sys-devel/flex
+ nls? ( sys-devel/gettext )"
+
+G2CONF="${G2CONF} $(use_enable gnome) $(use_enable nls) \
+ --disable-update-mimedb --disable-scrollkeeper \
+ --disable-extra-gcc-optimization"
+# gnome2.eclass adds --disable-gtk-doc or --enable-gtk-doc to G2CONF
+# if there is the USE flag doc, thus leading to QA warnings
+GCONF_DEBUG="no"
+DOCS="AUTHORS ChangeLog NEWS README TODO"
+USE_DESTDIR="1"
+
+src_prepare() {
+ if ! use gnome
+ then sed -i \
+ -e "/GNOME_DOC_INIT/d" \
+ configure.in
+ sed -i \
+ -e '/gnome-doc-utils\.make/d' \
+ help/Makefile.am
+ eautoreconf
+ fi
+ gnome2_src_prepare
+}
+
+src_install() {
+ gnome2_src_install
+ if use doc; then
+ insinto /usr/share/doc/${PF}
+ doins "${DISTDIR}"/${PN}-reference.pdf
+ fi
+}
diff --git a/sci-mathematics/genius/metadata.xml b/sci-mathematics/genius/metadata.xml
new file mode 100644
index 00000000..cbdd7f0a
--- /dev/null
+++ b/sci-mathematics/genius/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci</herd>
+ <maintainer>
+ <email>grozin@gentoo.org</email>
+ <name>Andrey Grozin</name>
+ </maintainer>
+ <longdescription>Genius is a calculator program which can work
+ with arbitrary precision integers, multiple precision floats,
+ rational numbers, complex numbers, linear algebra, number theory,
+ numerical calculus, statistics, numerical equation solving,
+ combinatorics, elementary functions, modular arithmetic.
+ It has a programming language with automatic typing.
+ It can do various 2D and 3D plots, with possibility
+ to export to eps or png. Genius has a GUI IDE.
+ It can output matrices in LaTeX, Troff (eqn) or MathML.
+ </longdescription>
+</pkgmetadata>