summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Väth <martin@mvath.de>2015-10-11 11:26:48 +0200
committerMartin Väth <martin@mvath.de>2015-10-11 11:32:18 +0200
commit109d6b4f673a249aea4deeb0cdb5b54a21592410 (patch)
treeec3589a50dac5be54ef6248d1e0ff3a9fd3b41b4 /sci-mathematics
downloadmv-109d6b4f673a249aea4deeb0cdb5b54a21592410.tar.gz
mv-109d6b4f673a249aea4deeb0cdb5b54a21592410.tar.bz2
mv-109d6b4f673a249aea4deeb0cdb5b54a21592410.zip
Clear history for egencache --repo=mv --update-changelogs
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/genius/Manifest2
-rw-r--r--sci-mathematics/genius/genius-1.0.19.ebuild65
-rw-r--r--sci-mathematics/genius/metadata.xml19
-rw-r--r--sci-mathematics/reduce/Manifest1
-rw-r--r--sci-mathematics/reduce/files/64reduce-gentoo.el4
-rwxr-xr-xsci-mathematics/reduce/files/csl2
-rwxr-xr-xsci-mathematics/reduce/files/redcsl2
-rw-r--r--sci-mathematics/reduce/metadata.xml13
-rw-r--r--sci-mathematics/reduce/reduce-20141130-r1.ebuild105
9 files changed, 213 insertions, 0 deletions
diff --git a/sci-mathematics/genius/Manifest b/sci-mathematics/genius/Manifest
new file mode 100644
index 00000000..b4116bf5
--- /dev/null
+++ b/sci-mathematics/genius/Manifest
@@ -0,0 +1,2 @@
+DIST genius-1.0.19.tar.xz 2447724 SHA256 e5a979d13ae39fb1ae176078dbb301222e6c7a1c2cda8d999bac3ff6a4a7e6c2 SHA512 84ec48c0e13af088f61674e170c23cbc06e081bea43babe3460b88fd2e256c9fc44b891afa3270d5117ccd91ec6d2c25b022dde3d468635df9d1c6e573c4ef05 WHIRLPOOL 772637bd2c2333a08115397781773b1aa74cb195b9731b1b07ddf689fef47790aad79d2f2a6c7e45fe5c6738eb8bda56e0cebe3802c01cd5c1a99bfb3b00b0d5
+DIST genius-reference.pdf 1024944 SHA256 79011ae33ff781507185898ba76b156699061eda78ed16e15aa02195c896ee4b SHA512 04af3870104d2320b1d4b345d74d713a0dfcdf8a228002506508f437659b3ef6037ead0b1f6b37cc335692150750b58c4007fdaaddd9540233474ccd10dac285 WHIRLPOOL 301302145d43843ddd749ab33612438d360462c9d3daa12d7050d9ca6da82bdea3ef53b917989d0c518327780b147a9f74e407f555a62dcdbe0f0c2ef864fa88
diff --git a/sci-mathematics/genius/genius-1.0.19.ebuild b/sci-mathematics/genius/genius-1.0.19.ebuild
new file mode 100644
index 00000000..49955d39
--- /dev/null
+++ b/sci-mathematics/genius/genius-1.0.19.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit autotools eutils gnome2
+
+DESCRIPTION="Genius Mathematics Tool and the GEL Language"
+HOMEPAGE="http://www.jirka.org/genius.html"
+SRC_URI="
+ mirror://gnome/sources/${PN}/1.0/${P}.tar.xz
+ doc? ( http://www.jirka.org/${PN}-reference.pdf )"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc gnome nls"
+
+RDEPEND="
+ dev-libs/glib:2
+ dev-libs/gmp
+ dev-libs/mpfr
+ dev-libs/popt
+ sys-libs/ncurses
+ sys-libs/readline
+ gnome? (
+ app-text/scrollkeeper
+ app-text/gnome-doc-utils
+ x11-libs/gtk+:2
+ gnome-base/libgnome
+ gnome-base/libgnomeui
+ gnome-base/libglade:2.0
+ x11-libs/gtksourceview:2.0
+ x11-libs/vte:0 )"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ || ( sys-devel/bison dev-util/yacc )
+ sys-devel/flex
+ nls? ( sys-devel/gettext )"
+
+src_prepare() {
+ if ! use gnome
+ then sed -i \
+ -e "/GNOME_DOC_INIT/d" \
+ configure.in
+ sed -i \
+ -e '/gnome-doc-utils\.make/d' \
+ help/Makefile.am
+ eautoreconf
+ fi
+ G2CONF="${G2CONF} $(use_enable gnome) $(use_enable nls) \
+ --disable-update-mimedb --disable-scrollkeeper \
+ --disable-extra-gcc-optimization"
+ # gnome2.eclass adds --disable-gtk-doc or --enable-gtk-doc to G2CONF
+ # if there is the USE flag doc, thus leading to QA warnings
+ GCONF_DEBUG="no"
+ DOCS="AUTHORS ChangeLog NEWS README TODO"
+ USE_DESTDIR="1"
+ gnome2_src_prepare
+}
+
+src_install() {
+ use doc && DOCS+=" ${DISTDIR}/${PN}-reference.pdf"
+ gnome2_src_install
+}
diff --git a/sci-mathematics/genius/metadata.xml b/sci-mathematics/genius/metadata.xml
new file mode 100644
index 00000000..cbdd7f0a
--- /dev/null
+++ b/sci-mathematics/genius/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci</herd>
+ <maintainer>
+ <email>grozin@gentoo.org</email>
+ <name>Andrey Grozin</name>
+ </maintainer>
+ <longdescription>Genius is a calculator program which can work
+ with arbitrary precision integers, multiple precision floats,
+ rational numbers, complex numbers, linear algebra, number theory,
+ numerical calculus, statistics, numerical equation solving,
+ combinatorics, elementary functions, modular arithmetic.
+ It has a programming language with automatic typing.
+ It can do various 2D and 3D plots, with possibility
+ to export to eps or png. Genius has a GUI IDE.
+ It can output matrices in LaTeX, Troff (eqn) or MathML.
+ </longdescription>
+</pkgmetadata>
diff --git a/sci-mathematics/reduce/Manifest b/sci-mathematics/reduce/Manifest
new file mode 100644
index 00000000..77447adb
--- /dev/null
+++ b/sci-mathematics/reduce/Manifest
@@ -0,0 +1 @@
+DIST reduce-src-2014-11-30.tar.bz2 253343100 SHA256 b15debc944475d4daee1bcbdbaff415693522306785507f2d3110d75df6e7006 SHA512 46dfead80b2778b37ac723343d2922d00a48f4bd5ca7d92c14039abd880cd1b0b3276c660e9ee443cdc6383e42448479893411360bfdbe2a239e11a780d6672b WHIRLPOOL ef020a09dd23794d7363062d96ae18b35d622b27549790b19addc84292fa78fbcb687312dcc7449c9f6844d041a6d5e14430ecf33ce9696495c7d0c0219860c6
diff --git a/sci-mathematics/reduce/files/64reduce-gentoo.el b/sci-mathematics/reduce/files/64reduce-gentoo.el
new file mode 100644
index 00000000..2c20bff9
--- /dev/null
+++ b/sci-mathematics/reduce/files/64reduce-gentoo.el
@@ -0,0 +1,4 @@
+;; site-init for sci-mathematics/reduce
+(add-to-list 'load-path "@SITELISP@")
+(autoload 'reduce-mode "reduce-mode" "Major mode for REDUCE code editing" t)
+(add-to-list 'auto-mode-alist '("\\.red\\'" . reduce-mode))
diff --git a/sci-mathematics/reduce/files/csl b/sci-mathematics/reduce/files/csl
new file mode 100755
index 00000000..895b6bd8
--- /dev/null
+++ b/sci-mathematics/reduce/files/csl
@@ -0,0 +1,2 @@
+#!/bin/sh
+exec /usr/lib/reduce/csl $*
diff --git a/sci-mathematics/reduce/files/redcsl b/sci-mathematics/reduce/files/redcsl
new file mode 100755
index 00000000..ff40e3e0
--- /dev/null
+++ b/sci-mathematics/reduce/files/redcsl
@@ -0,0 +1,2 @@
+#!/bin/sh
+exec /usr/lib/reduce/reduce $*
diff --git a/sci-mathematics/reduce/metadata.xml b/sci-mathematics/reduce/metadata.xml
new file mode 100644
index 00000000..523cb94a
--- /dev/null
+++ b/sci-mathematics/reduce/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sci-mathematics</herd>
+<maintainer>
+ <email>grozin@gentoo.org</email>
+ <name>Andrey Grozin</name>
+</maintainer>
+<longdescription lang="en">
+A general-purpose computer algebra system.
+Powerful, mature and efficient.
+</longdescription>
+</pkgmetadata>
diff --git a/sci-mathematics/reduce/reduce-20141130-r1.ebuild b/sci-mathematics/reduce/reduce-20141130-r1.ebuild
new file mode 100644
index 00000000..80f9ed9e
--- /dev/null
+++ b/sci-mathematics/reduce/reduce-20141130-r1.ebuild
@@ -0,0 +1,105 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+RESTRICT="mirror"
+inherit elisp-common eutils multilib
+
+DESCRIPTION="A general-purpose computer algebra system"
+HOMEPAGE="http://reduce-algebra.sourceforge.net/
+ http://reduce-algebra.com/"
+IUSE="doc emacs gnuplot X"
+PVyear=${PV%????}
+PVday=${PV#??????}
+PVmonth=${PV#????}
+PVmonth=${PVmonth%??}
+mPV="${PVyear}-${PVmonth}-${PVday}"
+TARBALL="${PN}-src-${mPV}"
+SRC_URI="mirror://sourceforge/${PN}-algebra/Snapshot_${mPV}/${TARBALL}.tar.bz2"
+LICENSE="BSD-2 X? ( LGPL-2.1 )"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+S="${WORKDIR}/${TARBALL}"
+
+RDEPEND="X? ( x11-libs/libXrandr
+ x11-libs/libXcursor
+ x11-libs/libXft )
+ gnuplot? ( sci-visualization/gnuplot )
+ emacs? ( virtual/emacs )"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ sed -i -e '2iecho gentoo; exit' -- "${S}"/scripts/findos.sh
+ # sed -i -e 's/\${l}/"\${l}"/g' -- "${S}"/scripts/make.sh
+ epatch_user
+}
+
+src_configure() {
+ # If you pass --prefix to this damn configure,
+ # make (not make install!) will try to install stuff
+ # into the live file system => sandbox violation
+ # Therefore, I cannot use econf here
+ # Also, make calls configure in maintainer mode in subdirs *by design*
+ # The trunk sucks less => WONTFIX until the next release
+ ./configure --with-csl $(use_with X gui)
+ # psl build requires Internet connection at build time
+ # we cannot support it
+}
+
+src_compile() {
+ emake -j1 STRIP=true
+
+ pushd cslbuild/*/csl/reduce.doc > /dev/null
+ rm -f *.txt *.tex
+ popd > /dev/null
+
+ if use emacs; then
+ einfo "Compiling emacs lisp files"
+ elisp-compile generic/emacs/*.el || die "elisp-compile failed"
+ fi
+}
+
+src_test() {
+ emake -j1 testall || die "emake testall failed"
+}
+
+src_install() {
+ local lib="$(get_libdir)"
+ dodoc README BUILDING DEPENDENCY_TRACKING
+ pushd bin > /dev/null
+ cp "${FILESDIR}"/redcsl "${FILESDIR}"/csl .
+ sed -e "s/lib/${lib}/" -i redcsl
+ sed -e "s/lib/${lib}/" -i csl
+ exeinto /usr/bin
+ doexe redcsl csl
+ popd > /dev/null
+
+ pushd cslbuild/*/csl > /dev/null
+ exeinto /usr/${lib}/${PN}
+ doexe reduce csl
+ insinto /usr/$(get_libdir)/${PN}
+ doins reduce.img csl.img
+ insinto /usr/share/${PN}
+ doins -r ${PN}.doc
+ mv "${D}"usr/share/${PN}/${PN}.doc "${D}"usr/share/${PN}/doc
+ dosym /usr/share/${PN}/doc /usr/${lib}/${PN}/${PN}.doc
+ if use X; then
+ doins -r ${PN}.fonts
+ mv "${D}"usr/share/${PN}/${PN}.fonts "${D}"usr/share/${PN}/fonts
+ dosym /usr/share/${PN}/fonts /usr/${lib}/${PN}/${PN}.fonts
+ fi
+ popd > /dev/null
+
+ if use doc; then
+ insinto /usr/share/doc/${PF}
+ doins doc/util/r38.pdf
+ fi
+
+ if use emacs; then
+ pushd generic/emacs > /dev/null
+ elisp-install ${PN} *.el *.elc || die "elisp-install failed"
+ elisp-site-file-install "${FILESDIR}/64${PN}-gentoo.el"
+ popd > /dev/null
+ fi
+}