summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Väth <martin@mvath.de>2017-05-26 06:38:51 +0200
committerMartin Väth <martin@mvath.de>2017-05-26 06:38:51 +0200
commitb3e41b2c76b1193f5ce3107120db4cbd79e274e3 (patch)
tree67dc462ead84dc8c5f512290438534dec54d45cc /sys-apps/openrc-wrapper/openrc-wrapper-2.1.ebuild
parentRemoval of www-plugins/stylish since I learnt it might be spyware (diff)
downloadmv-b3e41b2c76b1193f5ce3107120db4cbd79e274e3.tar.gz
mv-b3e41b2c76b1193f5ce3107120db4cbd79e274e3.tar.bz2
mv-b3e41b2c76b1193f5ce3107120db4cbd79e274e3.zip
Mass bump: new versions treat 0 and - as false only if no symbol follows
Diffstat (limited to 'sys-apps/openrc-wrapper/openrc-wrapper-2.1.ebuild')
-rw-r--r--sys-apps/openrc-wrapper/openrc-wrapper-2.1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/sys-apps/openrc-wrapper/openrc-wrapper-2.1.ebuild b/sys-apps/openrc-wrapper/openrc-wrapper-2.1.ebuild
new file mode 100644
index 00000000..37f0dc36
--- /dev/null
+++ b/sys-apps/openrc-wrapper/openrc-wrapper-2.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+RESTRICT="mirror"
+inherit systemd
+
+DESCRIPTION="Use openrc init scripts with systemd or other init systems"
+HOMEPAGE="https://github.com/vaeth/openrc-wrapper"
+SRC_URI="https://github.com/vaeth/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND="!!<sys-fs/squash_dir-3.2"
+# the last dependency is not really needed, but without it the output is ugly,
+# and the costs are really not high: sys-apps/gentoo-functions is tiny
+RDEPEND="${DEPEND}
+|| ( sys-apps/gentoo-functions sys-apps/openrc )"
+IUSE=""
+
+src_install() {
+ dodoc README
+ dobin bin/*
+ systemd_dounit systemd/system/*
+ insinto /usr/share/zsh/site-functions
+ doins zsh/*
+}