summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Väth <martin@mvath.de>2017-07-14 18:27:12 +0200
committerMartin Väth <martin@mvath.de>2017-07-14 18:27:12 +0200
commit7494ee3151e20b7ab531aa6177bfd8088a198e02 (patch)
treeb8d999b9b399724704d1d68c273a958e71001636 /sys-apps/openrc-wrapper/openrc-wrapper-2.2.ebuild
parentmedia-tv/sundtek-tv: Version bump (diff)
downloadmv-7494ee3151e20b7ab531aa6177bfd8088a198e02.tar.gz
mv-7494ee3151e20b7ab531aa6177bfd8088a198e02.tar.bz2
mv-7494ee3151e20b7ab531aa6177bfd8088a198e02.zip
Mass bump: Fix systemd unit path, split /usr
Diffstat (limited to 'sys-apps/openrc-wrapper/openrc-wrapper-2.2.ebuild')
-rw-r--r--sys-apps/openrc-wrapper/openrc-wrapper-2.2.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/sys-apps/openrc-wrapper/openrc-wrapper-2.2.ebuild b/sys-apps/openrc-wrapper/openrc-wrapper-2.2.ebuild
new file mode 100644
index 00000000..3de964a2
--- /dev/null
+++ b/sys-apps/openrc-wrapper/openrc-wrapper-2.2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+RESTRICT="mirror"
+inherit systemd
+
+DESCRIPTION="Use openrc init scripts with systemd or other init systems"
+HOMEPAGE="https://github.com/vaeth/openrc-wrapper"
+SRC_URI="https://github.com/vaeth/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND="!!<sys-fs/squash_dir-3.2"
+# the last dependency is not really needed, but without it the output is ugly,
+# and the costs are really not high: sys-apps/gentoo-functions is tiny
+RDEPEND="${DEPEND}
+|| ( sys-apps/gentoo-functions sys-apps/openrc )"
+IUSE=""
+
+src_install() {
+ dodoc README
+ systemd_dounit systemd/system/*
+ insinto /usr/share/zsh/site-functions
+ doins zsh/*
+ into /
+ dobin bin/*
+}