summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Väth <martin@mvath.de>2018-01-19 08:15:20 +0100
committerMartin Väth <martin@mvath.de>2018-01-19 08:15:20 +0100
commitc8da4f86a98e3f84e932e080347ae07d3daefba1 (patch)
tree25bea5a0886ce585fe62326bd3261a83cd39a15c /sys-apps/openrc-wrapper/openrc-wrapper-2.3.ebuild
parentsys-boot/grub-cfg-mv: Version bump (diff)
downloadmv-c8da4f86a98e3f84e932e080347ae07d3daefba1.tar.gz
mv-c8da4f86a98e3f84e932e080347ae07d3daefba1.tar.bz2
mv-c8da4f86a98e3f84e932e080347ae07d3daefba1.zip
sys-apps/openrc-wrapper: Version bump. Fix sourcing of /lib*/rc/sh/functions.sh
Diffstat (limited to 'sys-apps/openrc-wrapper/openrc-wrapper-2.3.ebuild')
-rw-r--r--sys-apps/openrc-wrapper/openrc-wrapper-2.3.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/sys-apps/openrc-wrapper/openrc-wrapper-2.3.ebuild b/sys-apps/openrc-wrapper/openrc-wrapper-2.3.ebuild
new file mode 100644
index 00000000..735bed28
--- /dev/null
+++ b/sys-apps/openrc-wrapper/openrc-wrapper-2.3.ebuild
@@ -0,0 +1,31 @@
+# Copyright 2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+RESTRICT="mirror"
+inherit systemd
+
+DESCRIPTION="Use openrc init scripts with systemd or other init systems"
+HOMEPAGE="https://github.com/vaeth/openrc-wrapper"
+SRC_URI="https://github.com/vaeth/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND="!!<sys-fs/squash_dir-3.2"
+# the last dependency is not really needed, but without it the output is ugly,
+# and the costs are really not high: sys-apps/gentoo-functions is tiny
+RDEPEND="${DEPEND}
+|| ( sys-apps/gentoo-functions sys-apps/openrc )"
+IUSE=""
+
+src_install() {
+ dodoc README
+ systemd_dounit systemd/system/*
+ insinto /usr/share/zsh/site-functions
+ doins zsh/*
+ into /
+ dobin bin/*
+}