summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Väth <martin@mvath.de>2015-10-11 11:26:48 +0200
committerMartin Väth <martin@mvath.de>2015-10-11 11:32:18 +0200
commit109d6b4f673a249aea4deeb0cdb5b54a21592410 (patch)
treeec3589a50dac5be54ef6248d1e0ff3a9fd3b41b4 /sys-apps/openrc-wrapper
downloadmv-109d6b4f673a249aea4deeb0cdb5b54a21592410.tar.gz
mv-109d6b4f673a249aea4deeb0cdb5b54a21592410.tar.bz2
mv-109d6b4f673a249aea4deeb0cdb5b54a21592410.zip
Clear history for egencache --repo=mv --update-changelogs
Diffstat (limited to 'sys-apps/openrc-wrapper')
-rw-r--r--sys-apps/openrc-wrapper/Manifest1
-rw-r--r--sys-apps/openrc-wrapper/metadata.xml16
-rw-r--r--sys-apps/openrc-wrapper/openrc-wrapper-1.7.ebuild35
3 files changed, 52 insertions, 0 deletions
diff --git a/sys-apps/openrc-wrapper/Manifest b/sys-apps/openrc-wrapper/Manifest
new file mode 100644
index 00000000..2787170d
--- /dev/null
+++ b/sys-apps/openrc-wrapper/Manifest
@@ -0,0 +1 @@
+DIST openrc-wrapper-1.7.tar.gz 2432 SHA256 4bef51a81461772b277ca9df8dd3295043c0a61a976cef39e401cf26ce3b8c15 SHA512 f825e2a44b613c372948c12c83183a95723bb99ceb86e24739eb10f3b24dc3768d542f4410db6cf1f2ad44559c20eba2cb2a70ecd038f5b3e9d8877008b0e488 WHIRLPOOL 37a0685562a2a0f546927c2ec61807e8ef94d01825ae5c6e8a25c7c361e5854765e3b791b00925f1ff11c54d683f1ac649b8b6aced8d2a32fea630e1e6a3d583
diff --git a/sys-apps/openrc-wrapper/metadata.xml b/sys-apps/openrc-wrapper/metadata.xml
new file mode 100644
index 00000000..db6be5a2
--- /dev/null
+++ b/sys-apps/openrc-wrapper/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>martin@mvath.de</email>
+ <name>Martin Väth</name>
+ </maintainer>
+ <upstream>
+ <maintainer>
+ <email>martin@mvath.de</email>
+ <name>Martin Väth</name>
+ </maintainer>
+ <bugs-to>mailto:martin@mvath.de</bugs-to>
+ <remote-id type="github">vaeth/openrc-wrapper</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/sys-apps/openrc-wrapper/openrc-wrapper-1.7.ebuild b/sys-apps/openrc-wrapper/openrc-wrapper-1.7.ebuild
new file mode 100644
index 00000000..88be0ecc
--- /dev/null
+++ b/sys-apps/openrc-wrapper/openrc-wrapper-1.7.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+RESTRICT="mirror"
+inherit eutils systemd
+
+DESCRIPTION="Use openrc init scripts with systemd or other init systems"
+HOMEPAGE="https://github.com/vaeth/openrc-wrapper"
+SRC_URI="https://github.com/vaeth/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND="!!<sys-fs/squash_dir-3.2"
+# the last dependency is not really needed, but without it the output is ugly,
+# and the costs are really not high: sys-apps/gentoo-functions is tiny
+RDEPEND="${DEPEND}
+|| ( sys-apps/gentoo-functions sys-apps/openrc )"
+IUSE=""
+
+src_prepare() {
+ epatch_user
+}
+
+src_install() {
+ dodoc README
+ dobin bin/*
+ systemd_dounit systemd/system/*
+ insinto /usr/share/zsh/site-functions
+ doins zsh/*
+}