summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Väth <martin@mvath.de>2016-04-07 21:15:26 +0200
committerMartin Väth <martin@mvath.de>2016-04-07 21:15:26 +0200
commit14aa2dffe8627e17e9a858642744648fa466a2a7 (patch)
tree2cad6867f03db9c430e55605f941d53988528351 /sys-apps
parentnet-dns/noip-updater: Fix typo in systemd service file (diff)
downloadmv-14aa2dffe8627e17e9a858642744648fa466a2a7.tar.gz
mv-14aa2dffe8627e17e9a858642744648fa466a2a7.tar.bz2
mv-14aa2dffe8627e17e9a858642744648fa466a2a7.zip
Follow gentoo concerning handling of lesspipe
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/less/Manifest1
-rw-r--r--sys-apps/less/files/code2color-0.2.patch26
-rw-r--r--sys-apps/less/files/lesspipe.sh27
-rw-r--r--sys-apps/less/less-483-r1.ebuild (renamed from sys-apps/less/less-483.ebuild)35
-rw-r--r--sys-apps/less/metadata.xml2
-rw-r--r--sys-apps/lesspipe/Manifest1
-rw-r--r--sys-apps/lesspipe/lesspipe-1.83.ebuild210
-rw-r--r--sys-apps/lesspipe/metadata.xml46
8 files changed, 27 insertions, 321 deletions
diff --git a/sys-apps/less/Manifest b/sys-apps/less/Manifest
index f2e3a449..0f090058 100644
--- a/sys-apps/less/Manifest
+++ b/sys-apps/less/Manifest
@@ -1,3 +1,2 @@
-DIST code2color-0.2 200711 SHA256 2365c9009b1cc3c30430b88775ec402164df105fd12364871d05dcaed20be954
DIST less-483.tar.gz 316897 SHA256 7ebb1a0a141a94f863c0b83eff94fb115d716802fabe8007e442adbaf81ce41f
DIST less-select-2.6.tar.gz 26354 SHA256 df4ab8f17568cabd864358e5f0a765241f586b8c30341116a649db91db9048bf
diff --git a/sys-apps/less/files/code2color-0.2.patch b/sys-apps/less/files/code2color-0.2.patch
deleted file mode 100644
index f8a78250..00000000
--- a/sys-apps/less/files/code2color-0.2.patch
+++ /dev/null
@@ -1,26 +0,0 @@
---- code2color
-+++ code2color
-@@ -163,11 +163,11 @@
- # building up the database
- # newer entries overwrite old ones
- my @CONFIG_FILES;
-- push @CONFIG_FILES, "/etc/code2html.config";
-+ push @CONFIG_FILES, "/etc/code2color";
- push @CONFIG_FILES,
-- $ENV{'HOME'}."/.code2html.config" if $ENV{'HOME'};
-+ $ENV{'HOME'}."/.code2color" if $ENV{'HOME'};
- push @CONFIG_FILES,
-- split(/:/,$ENV{'CODE2HTML_CONFIG'}) if $ENV{'CODE2HTML_CONFIG'};
-+ split(/:/,$ENV{'CODE2COLOR_CONFIG'}) if $ENV{'CODE2COLOR_CONFIG'};
- push @CONFIG_FILES,
- split(/:/,$params{'langfile'}) if $params{'langfile'};
-
-@@ -3192,7 +3192,7 @@
- #
-
- $LANGUAGE{'shellscript'} = {
-- 'filename' => '\\.(sh|shell)$',
-+ 'filename' => '\\.(ebuild|eclass|sh|shell)$',
- 'regex' => '^\\s*#\\s*![^\\s]*(sh|bash|ash|zsh|ksh)',
- 'patterns' => [ {
- 'name' => 'comment',
diff --git a/sys-apps/less/files/lesspipe.sh b/sys-apps/less/files/lesspipe.sh
index 6edaa3ce..291d6d66 100644
--- a/sys-apps/less/files/lesspipe.sh
+++ b/sys-apps/less/files/lesspipe.sh
@@ -59,6 +59,15 @@ lesspipe() {
[[ ${match} == *.${ignore} ]] && exit 0
done
+ # Handle non-regular file types.
+ if [[ -d $1 ]] ; then
+ ls -alF -- "$1"
+ return
+ elif [[ ! -f $1 ]] ; then
+ stat "$1"
+ return
+ fi
+
case "${match}" in
### Doc files ###
@@ -90,7 +99,8 @@ lesspipe() {
esac
;;
*.dvi) dvi2tty "$1" ;;
- *.ps|*.pdf) ps2ascii "$1" || pstotext "$1" || pdftotext "$1" ;;
+ *.ps) ps2ascii "$1" || pstotext "$1" ;;
+ *.pdf) pdftotext "$1" - || ps2ascii "$1" || pstotext "$1" ;;
*.doc) antiword "$1" || catdoc "$1" ;;
*.rtf) unrtf --nopict --text "$1" ;;
*.conf|*.txt|*.log) ;; # force less to work on these directly #150256
@@ -234,14 +244,12 @@ lesspipe() {
if [[ -z $1 ]] ; then
echo "Usage: lesspipe <file>"
elif [[ $1 == "-V" || $1 == "--version" ]] ; then
- Id="cvsid"
cat <<-EOF
- $Id$
- Copyright 2001-2013 Gentoo Foundation
+ lesspipe (git)
+ Copyright 2001-2016 Gentoo Foundation
Mike Frysinger <vapier@gentoo.org>
(with plenty of ideas stolen from other projects/distros)
-
EOF
less -V
elif [[ $1 == "-h" || $1 == "--help" ]] ; then
@@ -251,21 +259,20 @@ elif [[ $1 == "-h" || $1 == "--help" ]] ; then
Usage: lesspipe <file>
lesspipe specific settings:
- LESSCOLOR env - toggle colorizing of output (no/yes/always)
+ LESSCOLOR env - toggle colorizing of output (no/yes/always; default: no)
LESSCOLORIZER env - program used to colorize output (default: code2color)
LESSIGNORE - list of extensions to ignore (don't do anything fancy)
You can create per-user filters as well by creating the executable file:
~/.lessfilter
- One argument is passed to it: the file to display.
+ One argument is passed to it: the file to display. The script should exit 0
+ to indicate it handled the file, or non-zero to tell lesspipe to handle it.
To use lesspipe, simply add to your environment:
export LESSOPEN="|lesspipe %s"
- Run 'less --help' or 'man less' for more info
+ Run 'less --help' or 'man less' for more info.
EOF
-elif [[ -d $1 ]] ; then
- ls -alF -- "$1"
else
recur=0
[[ -n ${LESSDEBUG} ]] \
diff --git a/sys-apps/less/less-483.ebuild b/sys-apps/less/less-483-r1.ebuild
index 6ce6c2bc..11b232c2 100644
--- a/sys-apps/less/less-483.ebuild
+++ b/sys-apps/less/less-483-r1.ebuild
@@ -4,8 +4,6 @@
EAPI=6
-CODE2COLOR_PV="0.2"
-CODE2COLOR_P="code2color-${CODE2COLOR_PV}"
DESCRIPTION="Excellent text file viewer, optionally with additional selection feature"
PATCHN="less-select"
PATCHV="2.6"
@@ -15,8 +13,7 @@ PATCHBALL="${PATCHRUMP}.tar.gz"
SELECTDIR="${WORKDIR}/${PATCHRUMP}"
HOMEPAGE="http://www.greenwoodsoftware.com/less/ https://github.com/vaeth/${PATCHN}"
SRC_URI="http://www.greenwoodsoftware.com/less/${P}.tar.gz
- less-select? ( https://github.com/vaeth/${PATCHN}/archive/v${PATCHV}.tar.gz -> ${PATCHBALL} )
- http://www-zeuthen.desy.de/~friebel/unix/less/code2color -> ${CODE2COLOR_P}"
+ less-select? ( https://github.com/vaeth/${PATCHN}/archive/v${PATCHV}.tar.gz -> ${PATCHBALL} )"
LICENSE="|| ( GPL-3 BSD-2 )"
SLOT="0"
@@ -29,7 +26,7 @@ DEPEND=">=app-misc/editor-wrapper-3
RDEPEND="${DEPEND}
less-select? ( dev-lang/perl )"
# || ( >=dev-lang/perl-5.10.1 >=virtual/perl-File-Temp-0.19 )
-PDEPEND="lesspipe? ( sys-apps/lesspipe )"
+PDEPEND="lesspipe? ( app-text/lesspipe )"
pkg_setup() {
if use source && ! use less-select
@@ -37,14 +34,6 @@ pkg_setup() {
fi
}
-src_unpack() {
- unpack ${P}.tar.gz
- cp "${DISTDIR}/${CODE2COLOR_P}" "${S}"/code2color || die
- if use less-select
- then unpack ${PATCHBALL}
- fi
-}
-
src_prepare() {
if use less-select
then eapply "${SELECTDIR}/patches/less-${PATCHVER}-select.patch"
@@ -52,7 +41,6 @@ src_prepare() {
sed -i -e 's|\([^a-zA-Z]\)/etc/less-select-key.bin|\1'"${EPREFIX}"'/etc/less/select-key.bin|g' \
"${SELECTDIR}/bin/less-select" || die
fi
- eapply -p0 "${FILESDIR}/${CODE2COLOR_P}.patch"
chmod a+x configure || die
eapply_user
}
@@ -74,19 +62,19 @@ src_compile() {
}
src_install() {
- local a
+ local a b
default
- if ! use lesspipe
- then dobin code2color
- newbin "${FILESDIR}"/lesspipe.sh lesspipe
- dosym lesspipe /usr/bin/lesspipe.sh
- fi
+ newbin "${FILESDIR}"/lesspipe.sh lesspipe
+
if use original-gentoo
then a="-R -M --shift 5"
else a="-sFRiMX --shift 5"
fi
- printf '%s\n' 'LESSOPEN="|lesspipe.sh %s"' "LESS=\"${a}\"" >70less
+ printf '%s\n' \
+ 'LESSOPEN="|lesspipe'$(! use lesspipe || echo .sh)'%s"' \
+ "LESS=\"${a}\"" \
+ >70less || die
doenvd 70less
dodoc "${FILESDIR}"/README.Gentoo
@@ -102,8 +90,3 @@ src_install() {
fi
fi
}
-
-pkg_postinst() {
- use lesspipe || \
- elog "lesspipe offers colorization options. Run 'lesspipe -h' for info."
-}
diff --git a/sys-apps/less/metadata.xml b/sys-apps/less/metadata.xml
index d56b6e96..812305c4 100644
--- a/sys-apps/less/metadata.xml
+++ b/sys-apps/less/metadata.xml
@@ -21,7 +21,7 @@
</upstream>
<use>
<flag name="original-gentoo">Use the gentoo default for the LESS variable.</flag>
- <flag name="lesspipe">Use sys-apps/lesspipe instead of Gentoo's default lesspipe.sh.</flag>
+ <flag name="lesspipe">Default to lesspipe.sh from app-text/lesspipe instead of the gentoo specific lesspipe.</flag>
<flag name="less-select">Add the less-select feature (additional options and a binary helper).</flag>
<flag name="source">Install sources for keybindings (only useful with less-select).</flag>
</use>
diff --git a/sys-apps/lesspipe/Manifest b/sys-apps/lesspipe/Manifest
deleted file mode 100644
index acfea077..00000000
--- a/sys-apps/lesspipe/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST lesspipe-1.83.tar.gz 115129 SHA256 d616f0d51852e60fb0d0801eec9c31b10e0acc6fdfdc62ec46ef7bfd60ce675e
diff --git a/sys-apps/lesspipe/lesspipe-1.83.ebuild b/sys-apps/lesspipe/lesspipe-1.83.ebuild
deleted file mode 100644
index 874ba79a..00000000
--- a/sys-apps/lesspipe/lesspipe-1.83.ebuild
+++ /dev/null
@@ -1,210 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=6
-RESTRICT="mirror"
-
-DESCRIPTION="Wolfgang Friebel's preprocessor for sys-apps/less. Disable by appending colon"
-HOMEPAGE="http://www-zeuthen.desy.de/~friebel/unix/lesspipe.html"
-SRC_URI="http://www-zeuthen.desy.de/~friebel/unix/less/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~hppa-hpux ~ia64-hpux ~x86-interix ~amd64-linux ~arm-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="antiword cabextract catdoc +cpio +djvu dpkg +dvi2tty +elinks fastjar +ghostscript gpg +groff hdf5 +html2text id3v2 image isoinfo libplist +links +lynx lzip mp3info mp3info2 netcdf ooffice p7zip pdf pstotext rar rpm +rpm2targz unrar unrtf +unzip +w3m xlhtml"
-
-htmlmode="( || ( html2text links lynx elinks w3m ) )"
-REQUIRED_USE="!rpm2targz? ( rpm? ( cpio ) )
- ooffice? ${htmlmode}
- xlhtml? ${htmlmode}
- amd64-fbsd? ( !antiword !catdoc !dpkg !elinks !fastjar !html2text
- !id3v2 !lzip !mp3info !mp3info2 !ooffice !p7zip !pstotext
- !rar !rpm !unrtf !w3m !xlhtml )
- alpha? ( !catdoc !fastjar !id3v2 !libplist !mp3info !mp3info2 !netcdf
- !ooffice !pstotext !rar )
- arm? ( !antiword !catdoc !fastjar !html2text !id3v2 !mp3info
- !ooffice !pstotext !rar !xlhtml )
- hppa? ( !catdoc !fastjar !hdf5 !libplist !mp3info2 !netcdf
- !ooffice !rar !w3m !xlhtml )
- ia64? ( !antiword !catdoc !fastjar !id3v2 !libplist !mp3info !mp3info2
- !netcdf !ooffice !pstotext !rar !xlhtml )
- ppc64? ( !catdoc !fastjar !ooffice !xlhtml )
- sparc? ( !catdoc !fastjar !id3v2 !libplist !mp3info2 !netcdf
- !ooffice !pstotext )"
-
-RDEPEND="sys-apps/file
- app-arch/xz-utils
- app-arch/bzip2
- dev-lang/perl
- sys-apps/less[lesspipe]
- unzip? ( app-arch/unzip )
- fastjar? ( !amd64-fbsd? ( !alpha? ( !arm? ( !hppa? ( !ia64? ( !ppc64?
- ( !sparc? ( app-arch/fastjar ) ) ) ) ) ) ) )
- unrar? ( app-arch/unrar )
- !unrar? (
- rar? ( !amd64-fbsd? ( !alpha? ( !arm? ( !hppa? ( !ia64?
- ( app-text/o3read ) ) ) ) ) )
- )
- lzip? ( !amd64-fbsd? ( app-arch/lzip ) )
- p7zip? ( !amd64-fbsd? ( app-arch/p7zip ) )
- cpio? ( app-arch/cpio )
- cabextract? ( app-arch/cabextract )
- html2text? ( !amd64-fbsd? ( !arm? ( app-text/html2text ) ) )
- !html2text? (
- links? ( www-client/links )
- !links? (
- lynx? ( www-client/lynx )
- !lynx? (
- elinks? ( !amd64-fbsd? ( www-client/elinks ) )
- !elinks? (
- w3m? ( !amd64-fbsd? ( !hppa? ( www-client/w3m ) ) )
- )
- )
- )
- )
- groff? ( sys-apps/groff )
- rpm2targz? ( app-arch/rpm2targz )
- !rpm2targz? (
- rpm? ( !amd64-fbsd? ( app-arch/rpm ) )
- )
- antiword? ( !amd64-fbsd? ( !arm? ( !ia64? ( app-text/antiword ) ) ) )
- !antiword? (
- catdoc? ( !amd64-fbsd? ( !alpha? ( !arm? ( !hppa? ( !ia64? ( !ppc64?
- ( !sparc? ( app-text/catdoc ) ) ) ) ) ) ) )
- )
- xlhtml? ( !amd64-fbsd? ( !arm? ( !hppa? ( !ia64? ( !ppc64?
- ( app-text/xlhtml ) ) ) ) ) )
- unrtf? ( !amd64-fbsd? ( app-text/unrtf ) )
- ooffice? ( !amd64-fbsd? ( !alpha? ( !arm? ( !hppa? ( !ia64? ( !ppc64?
- ( !sparc? ( app-text/o3read ) ) ) ) ) ) ) )
- djvu? ( app-text/djvu )
- dvi2tty? ( dev-tex/dvi2tty )
- pstotext? ( !amd64-fbsd? ( !alpha? ( !arm? ( !ia64? ( !sparc?
- ( app-text/pstotext ) ) ) ) ) )
- !pstotext? (
- ghostscript? ( app-text/ghostscript-gpl )
- )
- gpg? ( app-crypt/gnupg )
- pdf? ( app-text/poppler )
- id3v2? ( !amd64-fbsd? ( !alpha? ( !arm? ( !ia64? ( !sparc?
- ( media-sound/id3v2 ) ) ) ) ) )
- !id3v2? (
- mp3info2? ( !amd64-fbsd? ( !alpha? ( !hppa? ( !ia64? ( !sparc?
- ( dev-perl/MP3-Tag ) ) ) ) ) )
- !mp3info2? (
- mp3info? ( !amd64-fbsd? ( !alpha? ( !arm? ( !ia64?
- ( media-sound/mp3info ) ) ) ) )
- )
- )
- image? ( || ( media-gfx/graphicsmagick[imagemagick] media-gfx/imagemagick ) )
- isoinfo? ( || ( app-cdr/cdrtools app-cdr/dvd+rw-tools app-cdr/cdrkit ) )
- libplist? ( !alpha? ( !hppa? ( !ia64? ( !sparc? ( app-pda/libplist ) ) ) ) )
- dpkg? ( !amd64-fbsd? ( app-arch/dpkg ) )
- hdf5? ( !hppa? ( sci-libs/hdf5 ) )
- netcdf? ( !alpha? ( !hppa? ( !ia64? ( !sparc? ( sci-libs/netcdf ) ) ) ) )"
-DEPEND="${RDEPEND}"
-
-ModifyStart() {
- sedline=
-}
-
-Modify() {
- if [ -z "${sedline:++}" ]
- then sedline='/^__END__$/,${'
- else sedline=${sedline}';'
- fi
- sedline=${sedline}'s/^\('${1}'[[:space:]][[:space:]]*\)[nNyY]/\1'${2:-Y}'/'
-}
-
-ModifyEnd() {
- sedline=${sedline}'}'
- sed -i -e "${sedline}" "${S}/configure"
-}
-
-ModifyY() {
- local i
- for i
- do Modify "${i}"
- done
-}
-
-ModifyN() {
- local i
- for i
- do Modify "${i}" N
- done
-}
-
-ModifyX() {
- if [ ${?} -eq 0 ]
- then ModifyY "${@}"
- else ModifyN "${@}"
- fi
-}
-
-ModifyU() {
- local i
- for i
- do use "${i}"; ModifyX "${i}"
- done
-}
-
-Modify1() {
- local i search
- search=:
- for i
- do ${search} && use "${i}" && search=false; ModifyX "${i}"
- done
-}
-
-src_prepare() {
- printf 'h5dump\t\tN\nncdump\t\tN\n' >>"${S}/configure"
- ModifyStart
- ModifyY 'HILITE'
- ModifyY 'LESS_ADVANCED_PREPROCESSOR'
- ModifyY 'nm'
- ModifyY 'iconv'
- ModifyY 'bzip2'
- ModifyY 'xz' 'lzma'
- ModifyY 'perldoc'
- ModifyU 'unzip' 'fastjar'
- Modify1 'unrar' 'rar'
- ModifyU 'lzip'
- use p7zip; ModifyX '7za'
- ModifyU 'cpio' 'cabextract' 'groff'
- Modify1 'html2text' 'links' 'lynx' 'elinks' 'w3m'
- use rpm2targz; ModifyX 'rpmunpack'
- ! use rpm2targz && use rpm; ModifyX 'rpm' 'rpm2cpio'
- Modify1 'antiword' 'catdoc'
- use xlhtml; ModifyX 'ppthtml' 'xlhtml'
- ModifyU 'unrtf'
- use ooffice; ModifyX 'o3tohtml'
- use djvu; ModifyX 'djvutxt'
- ModifyU 'dvi2tty'
- ModifyU 'pstotext'
- ! use pstotext && use ghostscript; ModifyX 'ps2ascii'
- ModifyU 'gpg'
- use pdf; ModifyX 'pdftohtml' 'pdftotext'
- Modify1 'id3v2' 'mp3info2' 'mp3info'
- use image; ModifyX 'identify'
- ModifyU 'isoinfo'
- ModifyN 'dpkg'
- ModifyN 'lsbom'
- use libplist; ModifyX 'plutil'
- use hdf5; ModifyX 'h5dump'
- use netcdf; ModifyX 'ncdump'
- ModifyEnd
- printf '%s\n' 'LESS_ADVANCED_PREPROCESSOR=1' >70lesspipe
- eapply_user
-}
-
-src_configure() {
- ./configure --fixed --prefix=/usr
-}
-
-src_install() {
- doenvd 70lesspipe
- dodir /usr/share/man/man1
- default
-}
diff --git a/sys-apps/lesspipe/metadata.xml b/sys-apps/lesspipe/metadata.xml
deleted file mode 100644
index b0cbac41..00000000
--- a/sys-apps/lesspipe/metadata.xml
+++ /dev/null
@@ -1,46 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="person">
- <email>martin@mvath.de</email>
- <name>Martin Väth</name>
- </maintainer>
- <use>
- <flag name="antiword">Support doc files with app-text/antiword; this overrides catdoc</flag>
- <flag name="cabextract">Support cabextract files</flag>
- <flag name="catdoc">Support doc files with app-text/catdoc; unused if antiword is set</flag>
- <flag name="cpio">Support cpio files</flag>
- <flag name="djvu">Support djvu files</flag>
- <flag name="dpkg">Support Debian package files</flag>
- <flag name="dvi2tty">Support dvi files with dev-tex/dvi2tty</flag>
- <flag name="elinks">Support html files with www-client/elinks; ignored if html2text, links, or lynx is set; this overrides w3m</flag>
- <flag name="fastjar">Support jar files with app-arch/fastjar</flag>
- <flag name="ghostscript">Support ps files with app-text/ghostscript-gpl; ignored if pstotext is set</flag>
- <flag name="gpg">Support gpg files</flag>
- <flag name="groff">Support man and nroff files</flag>
- <flag name="hdf5">Support h5dump from sci-libs/hdf5</flag>
- <flag name="html2text">Support html files with app-text/html2text; this overrides links, lynx, elinks, w3m</flag>
- <flag name="id3v2">Support mp3 files with media-sound/id3v2; this overrides mp3info2, mp3info</flag>
- <flag name="image">Support image/jpg files</flag>
- <flag name="isoinfo">Support CD/DVD-iso files</flag>
- <flag name="libplist">Support Apple Property List files</flag>
- <flag name="links">Support html files with www-client/links; ignored if html2text is set; this overrides lynx, elinks, w3m</flag>
- <flag name="lynx">Support html files with www-client/lynx; ignored if html2text or links is set; this overrides elinks, w3m</flag>
- <flag name="lzip">Support lzip files</flag>
- <flag name="mp3info">Support mp3 files with media-sound/mp3info; unused if id3v2 or mp3info2 is set</flag>
- <flag name="mp3info2">Support mp3 files with dev-perl/MP3-Tag (mp3info2); ignored if id3v2 is set; this overrides mp3info</flag>
- <flag name="netcdf">Support ncdump from sci-libs/netcdf</flag>
- <flag name="ooffice">Support OpenOffice files</flag>
- <flag name="p7zip">Support p7zip files</flag>
- <flag name="pdf">Support pdf files</flag>
- <flag name="pstotext">Support ps files with app-text/pstotext; this overrides ghostscript</flag>
- <flag name="rar">Support rar files with app-arch/rar; unused if unrar is set</flag>
- <flag name="rpm">Support rpm files with app-arch/rpm or rpm5; ignored if rpm2targz is set</flag>
- <flag name="rpm2targz">Support rpm files with app-arch/rpm2targz; this overrides rpm</flag>
- <flag name="unrar">Support rar files with app-arch/unrar; this overrides rar</flag>
- <flag name="unrtf">Support rtf files with app-text/unrtf</flag>
- <flag name="unzip">Support zip files with app-arch/unzip</flag>
- <flag name="w3m">Support html files with www-client/w3m; ignored if html2text, links, lynx, or elinks is set</flag>
- <flag name="xlhtml">Support Excel and Powerpoint files with app-arch/xlhtml</flag>
- </use>
-</pkgmetadata>