summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Väth <martin@mvath.de>2010-11-24 20:10:02 +0100
committerMartin Väth <martin@mvath.de>2015-10-11 10:46:20 +0200
commit1eabe6f8eedcc70266659242ce0a1af54f56388a (patch)
tree90e3100338ec1fafb9ad442a65cff9c28bd10c7e /sys-fs/aufs2-util/aufs2-util-99999999.ebuild
parentBump aufs2 to aufs2.1. Bump compcache-tools for kernel 2.6.36 (diff)
downloadmv-1eabe6f8eedcc70266659242ce0a1af54f56388a.tar.gz
mv-1eabe6f8eedcc70266659242ce0a1af54f56388a.tar.bz2
mv-1eabe6f8eedcc70266659242ce0a1af54f56388a.zip
Add aufs2-util
Diffstat (limited to 'sys-fs/aufs2-util/aufs2-util-99999999.ebuild')
-rw-r--r--sys-fs/aufs2-util/aufs2-util-99999999.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/sys-fs/aufs2-util/aufs2-util-99999999.ebuild b/sys-fs/aufs2-util/aufs2-util-99999999.ebuild
new file mode 100644
index 00000000..06556ccb
--- /dev/null
+++ b/sys-fs/aufs2-util/aufs2-util-99999999.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header $
+
+EAPI="3"
+
+EGIT_REPO_URI="http://git.c3sl.ufpr.br/pub/scm/aufs/aufs2-util.git"
+EGIT_PROJECT="aufs2-util"
+# BRANCH/COMMIT will be overridden in pkg_setup (according to kernel version)
+EGIT_BRANCH="aufs2.1"
+EGIT_COMMIT="${EGIT_BRANCH}"
+[ -n "${EGIT_OFFLINE:-${ESCM_OFFLINE}}" ] || EGIT_PRUNE=true
+
+inherit git linux-info multilib
+
+DESCRIPTION="Userspace tools for aufs2"
+HOMEPAGE="http://aufs.sourceforge.net/"
+
+LICENSE="GPL-2"
+SLOT="0"
+# Since this is a live ebuild, we require ACCEPT_KEYWORDS='**'
+#KEYWORDS="~amd64 ~x86"
+KEYWORDS=""
+IUSE=""
+PROPERTIES="live"
+
+RDEPEND=""
+DEPEND="dev-vcs/git[curl]"
+
+src_prepare() {
+ local i l
+ ln -s "${KERNEL_DIR}"/include local_kernel
+ set -- local_kernel/linux/aufs*.h
+ test -e "${1}" || {
+ eerror "It seems you do not have installed aufs2 into your kernel tree."
+ die "You might need to emerge =sys-fs/aufs2-99999999::mv"
+ }
+ l="s|/usr/lib|$(get_libdir)|"
+ sed -i -e "1iCFLAGS += -I./local_kernel" -e "${l}" Makefile || \
+ die "Patching Makefile failed"
+ for i in lib*/Makefile
+ do test -e "${i}" || continue
+ sed -i -e "1iCFLAGS += -I../local_kernel" -e "${l}" "${i}" || \
+ die "Patching ${i} failed"
+ done
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+}