summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Väth <martin@mvath.de>2014-09-20 16:58:41 +0200
committerMartin Väth <martin@mvath.de>2015-10-11 10:49:18 +0200
commit6e1670643d9e62118f7b166efb643dec962005e9 (patch)
tree7d1e1c732d420e2fd45a48718df3b3c05cb0d1fd /sys-fs/emount/emount-2.8.1.ebuild
parentBump sundtek-tv (diff)
downloadmv-6e1670643d9e62118f7b166efb643dec962005e9.tar.gz
mv-6e1670643d9e62118f7b166efb643dec962005e9.tar.bz2
mv-6e1670643d9e62118f7b166efb643dec962005e9.zip
Bump emount, mv_perl
Diffstat (limited to 'sys-fs/emount/emount-2.8.1.ebuild')
-rw-r--r--sys-fs/emount/emount-2.8.1.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/sys-fs/emount/emount-2.8.1.ebuild b/sys-fs/emount/emount-2.8.1.ebuild
new file mode 100644
index 00000000..f435992c
--- /dev/null
+++ b/sys-fs/emount/emount-2.8.1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+RESTRICT="mirror"
+inherit eutils
+
+DESCRIPTION="mount/unmount (and create/remove) dm-crypt filesystems according to your /etc/fstab"
+HOMEPAGE="https://github.com/vaeth/emount/"
+SRC_URI="https://github.com/vaeth/${PN}/archive/v${PV}.tar.gz -> ${PN}-v${PV}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-lang/perl-5.12
+ sys-fs/cryptsetup"
+# || ( >=dev-lang/perl-5.6.1 >=virtual/perl-Getopt-Long-2.24 )
+# || ( >=dev-lang/perl-5.4.5 virtual/perl-File-Spec )
+
+src_prepare() {
+ use prefix || sed -i \
+ -e '1s"^#!/usr/bin/env perl$"#!'"${EPREFIX}/usr/bin/perl"'"' \
+ -- bin/* || die
+ epatch_user
+}
+
+src_install() {
+ local i
+ insinto /usr/bin
+ for i in bin/*
+ do if test -h "${i}" || ! test -x "${i}"
+ then doins "${i}"
+ else dobin "${i}"
+ fi
+ done
+ insinto /usr/share/zsh/site-functions
+ doins zsh/*
+}