summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Väth <martin@mvath.de>2013-11-21 21:08:47 +0100
committerMartin Väth <martin@mvath.de>2015-10-11 10:49:04 +0200
commitda891b2e490ba8a42d25187063dca66aaf72eff2 (patch)
tree699f1754940fc7bc18b99a5f61b78f535724e618 /sys-fs/emount/emount-2.8.ebuild
parentBump archwrap (diff)
downloadmv-da891b2e490ba8a42d25187063dca66aaf72eff2.tar.gz
mv-da891b2e490ba8a42d25187063dca66aaf72eff2.tar.bz2
mv-da891b2e490ba8a42d25187063dca66aaf72eff2.zip
Bump packages to push email
Diffstat (limited to 'sys-fs/emount/emount-2.8.ebuild')
-rw-r--r--sys-fs/emount/emount-2.8.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/sys-fs/emount/emount-2.8.ebuild b/sys-fs/emount/emount-2.8.ebuild
new file mode 100644
index 00000000..bc0cb8f9
--- /dev/null
+++ b/sys-fs/emount/emount-2.8.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+RESTRICT="mirror"
+inherit eutils vcs-snapshot
+
+DESCRIPTION="mount/unmount (and create/remove) dm-crypt filesystems according to your /etc/fstab"
+HOMEPAGE="https://github.com/vaeth/emount/"
+SRC_URI="http://github.com/vaeth/${PN}/tarball/${PV} -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-lang/perl
+ sys-fs/cryptsetup
+ virtual/perl-Getopt-Long"
+
+src_prepare() {
+ epatch_user
+}
+
+src_install() {
+ local i
+ insinto /usr/bin
+ for i in bin/*
+ do if test -h "${i}" || ! test -x "${i}"
+ then doins "${i}"
+ else dobin "${i}"
+ fi
+ done
+ insinto /usr/share/zsh/site-functions
+ doins zsh/*
+}