summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Väth <martin@mvath.de>2013-08-13 21:35:18 +0200
committerMartin Väth <martin@mvath.de>2015-10-11 10:48:50 +0200
commit89db25f386c068d9bf9b86a3e86d550aa5b625e0 (patch)
treefb00029c8c78b4291b8fe070d9382f9de4e0687f /sys-fs/squash_dir
parentUpdate zsh live dependency (diff)
downloadmv-89db25f386c068d9bf9b86a3e86d550aa5b625e0.tar.gz
mv-89db25f386c068d9bf9b86a3e86d550aa5b625e0.tar.bz2
mv-89db25f386c068d9bf9b86a3e86d550aa5b625e0.zip
Bumps to support systemd: squash_dir, firewall-mv
Diffstat (limited to 'sys-fs/squash_dir')
-rw-r--r--sys-fs/squash_dir/ChangeLog5
-rw-r--r--sys-fs/squash_dir/Manifest2
-rw-r--r--sys-fs/squash_dir/squash_dir-13.0.ebuild (renamed from sys-fs/squash_dir/squash_dir-12.10.ebuild)23
3 files changed, 25 insertions, 5 deletions
diff --git a/sys-fs/squash_dir/ChangeLog b/sys-fs/squash_dir/ChangeLog
index 5d00de92..207b8701 100644
--- a/sys-fs/squash_dir/ChangeLog
+++ b/sys-fs/squash_dir/ChangeLog
@@ -2,6 +2,11 @@
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+*squash_dir-13.0 (13 Aug 2013)
+
+ 13 Auf 2013; Martin Väth <martin@mvath.de>:
+ Version bump, remove old ebuild. Support systemd
+
*squash_dir-12.10 (04 Aug 2013)
04 Auf 2013; Martin Väth <martin@mvath.de>:
diff --git a/sys-fs/squash_dir/Manifest b/sys-fs/squash_dir/Manifest
index 264825cf..28a8ef9a 100644
--- a/sys-fs/squash_dir/Manifest
+++ b/sys-fs/squash_dir/Manifest
@@ -1 +1 @@
-DIST squash_dir-12.10.tar.gz 29087 SHA256 20009cba5e9d6cf21acb1136273e2d05966f4234412e6e41dc00bb5bdae58f4d SHA512 7a20a8505b92d17228dd56cbdd5c49f431a577772c3a6f193408072ecea528a207e35ef7deb9a9db65706deab634f7593d4c7fed186a8f71b77aa9b5d7d41dbd WHIRLPOOL 581aa90f2d2fa508c6951aa9984e3ccab0f78506de5e5486868a73069e9efbd1e43c487c81b6fc24c4fce9ca09dbf2d7f392b5c96005bb8ee98ba2b8e770a71d
+DIST squash_dir-13.0.tar.gz 30660 SHA256 ed915083a5b50456077648adad9626a84309486f43b470f25907762f8e66fbcd SHA512 73efe1c20c9800d4c5b2bbce8e3d31ad59ecb062a1513be87bc7d9461e42ff10327e74cea3077c8696ce8c030a1fc0135cc7190d85c5b2bed59afd9f4de51e87 WHIRLPOOL e17670871737ae8141029cfb74bc7cfc6955b55056b6313081675bfe12edf50f90aedb96e65232b99ecc825144f1469be15a0bdbb42c9133b81d192294968103
diff --git a/sys-fs/squash_dir/squash_dir-12.10.ebuild b/sys-fs/squash_dir/squash_dir-13.0.ebuild
index 3547534f..23a4befb 100644
--- a/sys-fs/squash_dir/squash_dir-12.10.ebuild
+++ b/sys-fs/squash_dir/squash_dir-13.0.ebuild
@@ -5,7 +5,8 @@
EAPI=5
RESTRICT="mirror"
WANT_LIBTOOL=none
-inherit autotools eutils linux-info vcs-snapshot
+AUTOTOOLS_IN_SOURCE_BUILD=true
+inherit autotools autotools-utils eutils linux-info systemd vcs-snapshot
DESCRIPTION="Keep directories compressed with squashfs. Useful for portage tree, texmf-dist"
HOMEPAGE="http://forums.gentoo.org/viewtopic-t-465367.html"
@@ -27,7 +28,17 @@ src_prepare() {
if [ -n "${EPREFIX%/}" ]
then sed -i \
-e "s\"'[^']*/etc/conf[.]d/${PN}'\"'${EPREFIX%/}/etc/conf.d/${PN}'\"g" \
- "init.d/${PN}"
+ "init.d/${PN}" || die
+ sed -i \
+ -e "s\"=/etc/\"=${EPREFIX%/}/etc/\"" \
+ -e "s\"=/usr/\"=${EPREFIX%/}/usr/\"" \
+ "systemd/${PN}@.service" || die
+ sed -i \
+ -e "s\":/usr/sbin:/sbin'\":${EPREFIX%/}/usr/sbin:${EPREFIX%/}/sbin:/usr/sbin:/sbin'\"" \
+ "sbin/${PN}" || die
+ sed -i \
+ -e "s\"'/lib/rc/bin:\":'${EPREFIX%/}/lib/rc/bin:/lib/rc/bin:\"" \
+ "sbin/openrc-wrapper" || die
fi
epatch_user
eautoreconf
@@ -38,8 +49,12 @@ src_configure() {
use unionfs-fuse && order=unionfs-fuse
use aufs && order=aufs
use overlayfs && order=overlayfs
- econf --docdir="${EPREFIX}/usr/share/doc/${PF}" \
- "$(use_with zsh-completion)" ${order:+"--with-first-order=${order}"}
+ local myeconfargs=(
+ "$(use_with zsh-completion)"
+ ${order:+"--with-first-order=${order}"}
+ )
+ systemd_to_myeconfargs
+ autotools-utils_src_configure
}
linux_config_missing() {