summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Väth <martin@mvath.de>2010-08-23 13:09:10 +0200
committerMartin Väth <martin@mvath.de>2015-10-11 10:45:59 +0200
commit3177765b3a138e0e118554fa70fd69c697528ce3 (patch)
tree66b7745cbb003da8e39542ce6312d367644e2104 /sys-fs/squashfs-tools/squashfs-tools-3.2_p2-r1.ebuild
parentaufs2: Fix treatment of EGIT_PRUNE. Bump EAPI (diff)
downloadmv-3177765b3a138e0e118554fa70fd69c697528ce3.tar.gz
mv-3177765b3a138e0e118554fa70fd69c697528ce3.tar.bz2
mv-3177765b3a138e0e118554fa70fd69c697528ce3.zip
squashfs: Bump EAPI
Diffstat (limited to 'sys-fs/squashfs-tools/squashfs-tools-3.2_p2-r1.ebuild')
-rw-r--r--sys-fs/squashfs-tools/squashfs-tools-3.2_p2-r1.ebuild6
1 files changed, 3 insertions, 3 deletions
diff --git a/sys-fs/squashfs-tools/squashfs-tools-3.2_p2-r1.ebuild b/sys-fs/squashfs-tools/squashfs-tools-3.2_p2-r1.ebuild
index c35f0715..c56d6bdb 100644
--- a/sys-fs/squashfs-tools/squashfs-tools-3.2_p2-r1.ebuild
+++ b/sys-fs/squashfs-tools/squashfs-tools-3.2_p2-r1.ebuild
@@ -2,6 +2,8 @@
# Distributed under the terms of the GNU General Public License v2
# $Header $
+EAPI="3"
+
inherit toolchain-funcs eutils
MY_PV=${PV/_p/-r}
@@ -18,9 +20,7 @@ RDEPEND="sys-libs/zlib"
S=${WORKDIR}/squashfs${MY_PV}/squashfs-tools
-src_unpack() {
- unpack ${A}
- cd "${S}"
+src_prepare() {
sed -i \
-e 's:-O2:$(CFLAGS):' \
-e '/-lz/s:$: $(LDFLAGS):' \