summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Väth <martin@mvath.de>2010-07-03 20:02:48 +0200
committerMartin Väth <martin@mvath.de>2015-10-11 10:45:42 +0200
commit1c279313fb94948dca58ee61ea45cd1855ab86ed (patch)
treed6d63d202963e119a6cfdbbf3604f1f027110bf4 /sys-fs/squashfs-tools/squashfs-tools-3.2_p2.ebuild
parentFix typo in FETCHCOMMAND description (diff)
downloadmv-1c279313fb94948dca58ee61ea45cd1855ab86ed.tar.gz
mv-1c279313fb94948dca58ee61ea45cd1855ab86ed.tar.bz2
mv-1c279313fb94948dca58ee61ea45cd1855ab86ed.zip
Various bumps
Diffstat (limited to 'sys-fs/squashfs-tools/squashfs-tools-3.2_p2.ebuild')
-rw-r--r--sys-fs/squashfs-tools/squashfs-tools-3.2_p2.ebuild42
1 files changed, 0 insertions, 42 deletions
diff --git a/sys-fs/squashfs-tools/squashfs-tools-3.2_p2.ebuild b/sys-fs/squashfs-tools/squashfs-tools-3.2_p2.ebuild
deleted file mode 100644
index c35f0715..00000000
--- a/sys-fs/squashfs-tools/squashfs-tools-3.2_p2.ebuild
+++ /dev/null
@@ -1,42 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header $
-
-inherit toolchain-funcs eutils
-
-MY_PV=${PV/_p/-r}
-DESCRIPTION="Tool for creating compressed filesystem type squashfs"
-HOMEPAGE="http://squashfs.sourceforge.net/"
-SRC_URI="mirror://sourceforge/squashfs/squashfs${MY_PV}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="3.0" # squashfs filesystem version
-KEYWORDS="alpha amd64 arm hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86"
-IUSE="+progress-redirect"
-
-RDEPEND="sys-libs/zlib"
-
-S=${WORKDIR}/squashfs${MY_PV}/squashfs-tools
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- sed -i \
- -e 's:-O2:$(CFLAGS):' \
- -e '/-lz/s:$: $(LDFLAGS):' \
- Makefile || die "sed failed"
- use progress-redirect && \
- epatch "${FILESDIR}/${PN}-3.3-progress-stderr.patch"
- echo "struct dir_info; `grep '^int dir_scan2' mksquashfs.c`;" >> global.h
-}
-
-src_compile() {
- emake CC="$(tc-getCC)" || die
-}
-
-src_install() {
- newbin mksquashfs mksquashfs-${SLOT} || die
- newbin unsquashfs unsquashfs-${SLOT} || die
- cd ..
- dodoc README ACKNOWLEDGEMENTS CHANGES PERFORMANCE.README README-3.2
-}