summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Väth <martin@mvath.de>2012-04-19 16:24:08 +0200
committerMartin Väth <martin@mvath.de>2015-10-11 10:47:38 +0200
commitf0062b7e950f8d010703d054fb809ea8f05031d5 (patch)
tree9f1a87679db0d3ef0794d39c06cf6357b42ab7bc /sys-fs/squashfs-tools/squashfs-tools-3.2_p2.ebuild
parentFix typo: base_src_prepare (diff)
downloadmv-f0062b7e950f8d010703d054fb809ea8f05031d5.tar.gz
mv-f0062b7e950f8d010703d054fb809ea8f05031d5.tar.bz2
mv-f0062b7e950f8d010703d054fb809ea8f05031d5.zip
Bump trickyfetch. Bump squashfs-tools to main tree versions
Diffstat (limited to 'sys-fs/squashfs-tools/squashfs-tools-3.2_p2.ebuild')
-rw-r--r--sys-fs/squashfs-tools/squashfs-tools-3.2_p2.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/sys-fs/squashfs-tools/squashfs-tools-3.2_p2.ebuild b/sys-fs/squashfs-tools/squashfs-tools-3.2_p2.ebuild
new file mode 100644
index 00000000..3cfbac3e
--- /dev/null
+++ b/sys-fs/squashfs-tools/squashfs-tools-3.2_p2.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header $
+
+EAPI="4"
+inherit base toolchain-funcs
+
+MY_PV=${PV/_p/-r}
+DESCRIPTION="Tool for creating compressed filesystem type squashfs"
+HOMEPAGE="http://squashfs.sourceforge.net/"
+SRC_URI="mirror://sourceforge/squashfs/squashfs${MY_PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="3.0" # squashfs filesystem version
+KEYWORDS="alpha amd64 arm hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86"
+IUSE="+progress-redirect"
+
+RDEPEND="sys-libs/zlib"
+
+S="${WORKDIR}/squashfs${MY_PV}/squashfs-tools"
+
+src_prepare() {
+ sed -i \
+ -e 's:-O2:$(CFLAGS):' \
+ -e '/-lz/s:$: $(LDFLAGS):' \
+ Makefile || die "sed failed"
+ use progress-redirect && \
+ epatch "${FILESDIR}/${PN}-3.3-progress-stderr.patch"
+ echo "struct dir_info; `grep '^int dir_scan2' mksquashfs.c`;" >> global.h
+ base_src_prepare
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" || die
+}
+
+src_install() {
+ newbin mksquashfs mksquashfs-${SLOT} || die
+ newbin unsquashfs unsquashfs-${SLOT} || die
+ cd ..
+ dodoc README ACKNOWLEDGEMENTS CHANGES PERFORMANCE.README README-3.2
+}