summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Väth <martin@mvath.de>2012-04-19 16:24:08 +0200
committerMartin Väth <martin@mvath.de>2015-10-11 10:47:38 +0200
commitf0062b7e950f8d010703d054fb809ea8f05031d5 (patch)
tree9f1a87679db0d3ef0794d39c06cf6357b42ab7bc /sys-fs/squashfs-tools/squashfs-tools-4.2.ebuild
parentFix typo: base_src_prepare (diff)
downloadmv-f0062b7e950f8d010703d054fb809ea8f05031d5.tar.gz
mv-f0062b7e950f8d010703d054fb809ea8f05031d5.tar.bz2
mv-f0062b7e950f8d010703d054fb809ea8f05031d5.zip
Bump trickyfetch. Bump squashfs-tools to main tree versions
Diffstat (limited to 'sys-fs/squashfs-tools/squashfs-tools-4.2.ebuild')
-rw-r--r--sys-fs/squashfs-tools/squashfs-tools-4.2.ebuild61
1 files changed, 0 insertions, 61 deletions
diff --git a/sys-fs/squashfs-tools/squashfs-tools-4.2.ebuild b/sys-fs/squashfs-tools/squashfs-tools-4.2.ebuild
deleted file mode 100644
index 83c7d3d6..00000000
--- a/sys-fs/squashfs-tools/squashfs-tools-4.2.ebuild
+++ /dev/null
@@ -1,61 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header $
-
-EAPI="4"
-
-inherit base toolchain-funcs
-
-MY_PV=${PV}
-DESCRIPTION="Tool for creating compressed filesystem type squashfs"
-HOMEPAGE="http://squashfs.sourceforge.net"
-SRC_URI="mirror://sourceforge/squashfs/squashfs${MY_PV}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc x86 ~x86-linux"
-IUSE="+gzip lzo +progress-redirect xattr +xz"
-REQUIRED_USE="|| ( gzip lzo xz )"
-
-RDEPEND="
- gzip? ( sys-libs/zlib )
- xz? ( app-arch/xz-utils )
- lzo? ( dev-libs/lzo )
- xattr? ( sys-apps/attr )"
-DEPEND="${RDEPEND}"
-
-S="${WORKDIR}/squashfs${MY_PV}/squashfs-tools"
-
-src_prepare() {
- use progress-redirect && \
- epatch "${FILESDIR}/${PN}-4.0-progress-stderr.patch"
- base_src_prepare
-}
-
-use_sed() {
- local u=$1 s="${2:-`echo $1 | tr '[:lower:]' '[:upper:]'`}_SUPPORT"
- printf '/^#?%s =/%s\n' "${s}" \
- "$( use $u && echo s:.*:${s} = 1: || echo d )"
-}
-
-src_configure() {
- tc-export CC
- sed -i -r \
- -e "$(use_sed gzip)" \
- -e "$(use_sed xz)" \
- -e "$(use_sed lzo)" \
- -e "$(use_sed xattr)" \
- Makefile || die
-}
-
-src_install() {
- dobin mksquashfs unsquashfs
- cd ..
- dodoc README ACKNOWLEDGEMENTS CHANGES PERFORMANCE.README
-}
-
-pkg_postinst() {
- ewarn "This version of mksquashfs requires a 2.6.29 kernel or better"
- use xz &&
- ewarn "XZ support requires a 2.6.38 kernel or better"
-}