summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Väth <martin@mvath.de>2012-02-11 17:22:35 +0100
committerMartin Väth <martin@mvath.de>2015-10-11 10:47:17 +0200
commitf848511905143cda54cd9d136117502b7f43356c (patch)
tree43bee84b6f9af24f1f295bca2b8b66861ac9ad47 /sys-fs/squashfs-tools/squashfs-tools-4.2.ebuild
parentBump noscript. Update checksums (diff)
downloadmv-f848511905143cda54cd9d136117502b7f43356c.tar.gz
mv-f848511905143cda54cd9d136117502b7f43356c.tar.bz2
mv-f848511905143cda54cd9d136117502b7f43356c.zip
squashfs-tools: Rename USE lzma->xz and other changes from gentoo main tree
Diffstat (limited to 'sys-fs/squashfs-tools/squashfs-tools-4.2.ebuild')
-rw-r--r--sys-fs/squashfs-tools/squashfs-tools-4.2.ebuild35
1 files changed, 8 insertions, 27 deletions
diff --git a/sys-fs/squashfs-tools/squashfs-tools-4.2.ebuild b/sys-fs/squashfs-tools/squashfs-tools-4.2.ebuild
index e1bb2f34..5ba04f37 100644
--- a/sys-fs/squashfs-tools/squashfs-tools-4.2.ebuild
+++ b/sys-fs/squashfs-tools/squashfs-tools-4.2.ebuild
@@ -13,14 +13,14 @@ SRC_URI="mirror://sourceforge/squashfs/squashfs${MY_PV}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~alpha amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc x86 ~x86-linux"
-IUSE="+gzip +lzma lzo +progress-redirect xattr"
+KEYWORDS="~alpha amd64 arm hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc x86 ~x86-linux"
+IUSE="+gzip lzo +progress-redirect xattr +xz"
+REQUIRED_USE="|| ( gzip lzo xz )"
RDEPEND="
gzip? ( sys-libs/zlib )
- lzma? ( app-arch/xz-utils )
+ xz? ( app-arch/xz-utils )
lzo? ( dev-libs/lzo )
- !lzma? ( !lzo? ( sys-libs/zlib ) )
xattr? ( sys-apps/attr )"
DEPEND="${RDEPEND}"
@@ -39,41 +39,22 @@ use_sed() {
src_configure() {
tc-export CC
- local def
- if [[ -n ${SQUASH_FS_DEFAULT_COMP} ]]; then
- def=${SQUASH_FS_DEFAULT_COMP}
- else
- einfo "You can set the default compression (gzip, xz or lzo) by exporting SQUASH_FS_DEFAULT_COMP"
- if use gzip; then
- def="gzip"
- elif use lzma; then
- def="xz"
- elif use lzo; then
- def="lzo"
- else
- die "Please set at least one of the gzip, lzma and lzo USE flags as compression algorithm."
- fi
- fi
-
- einfo "Using ${def} as compression algorithm."
-
sed -i -r \
- -e "/^COMP_DEFAULT =/s:=.*:= ${def}:" \
-e "$(use_sed gzip)" \
- -e "$(use_sed lzma XZ)" \
+ -e "$(use_sed xz)" \
-e "$(use_sed lzo)" \
-e "$(use_sed xattr)" \
Makefile || die
}
src_install() {
- dobin mksquashfs unsquashfs || die
+ dobin mksquashfs unsquashfs
cd ..
- dodoc README ACKNOWLEDGEMENTS CHANGES PERFORMANCE.README || die
+ dodoc README ACKNOWLEDGEMENTS CHANGES PERFORMANCE.README
}
pkg_postinst() {
ewarn "This version of mksquashfs requires a 2.6.29 kernel or better"
- use lzma &&
+ use xz &&
ewarn "XZ support requires a 2.6.38 kernel or better"
}