summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Väth <martin@mvath.de>2017-11-15 10:15:32 +0100
committerMartin Väth <martin@mvath.de>2017-11-15 10:15:32 +0100
commited8860676106e3ec328e8e7a4508c0793072f8ae (patch)
treed906cb0e8c057a52b80fca8d4618218aed4e00a5 /sys-fs/squashfuse
parentsys-fs/squashfs-tools: Version bump. Support zstd. Use subslot deps (diff)
downloadmv-ed8860676106e3ec328e8e7a4508c0793072f8ae.tar.gz
mv-ed8860676106e3ec328e8e7a4508c0793072f8ae.tar.bz2
mv-ed8860676106e3ec328e8e7a4508c0793072f8ae.zip
sys-fs/squashfuse: Copy and bump from gentoo repository to support zstd
Diffstat (limited to 'sys-fs/squashfuse')
-rw-r--r--sys-fs/squashfuse/Manifest1
-rw-r--r--sys-fs/squashfuse/metadata.xml23
-rw-r--r--sys-fs/squashfuse/squashfuse-0.1.101_alpha20170917.ebuild44
3 files changed, 68 insertions, 0 deletions
diff --git a/sys-fs/squashfuse/Manifest b/sys-fs/squashfuse/Manifest
new file mode 100644
index 00000000..69a7183a
--- /dev/null
+++ b/sys-fs/squashfuse/Manifest
@@ -0,0 +1 @@
+DIST squashfuse-0.1.101_alpha20170917.tar.gz 57581 SHA512 2921f572eb35058459f35d49844786c1ebba84c38e407ca4fb30c6f589cacbd4cd7e2175cfc7caf5a36c284f4693499b560009da0bac2ce56ad6c51dce1cd548
diff --git a/sys-fs/squashfuse/metadata.xml b/sys-fs/squashfuse/metadata.xml
new file mode 100644
index 00000000..9a59f7af
--- /dev/null
+++ b/sys-fs/squashfuse/metadata.xml
@@ -0,0 +1,23 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <upstream>
+ <bugs-to>mailto:dave@vasilevsky.ca</bugs-to>
+ <changelog>https://github.com/vasi/squashfuse/commits/master</changelog>
+ <doc>https://raw.github.com/vasi/squashfuse/master/README</doc>
+ <remote-id type="github">vasi/squashfuse</remote-id>
+ </upstream>
+ <maintainer type="person">
+ <email>martin@mvath.de</email>
+ <name>Martin Väth</name>
+ <description>maintainer of the updates in the mv overlay</description>
+ </maintainer>
+ <maintainer type="person">
+ <email>zmedico@gentoo.org</email>
+ <name>Zac Medico</name>
+ </maintainer>
+ <use>
+ <flag name="lz4">Enable support for lz4 compression</flag>
+ <flag name="zstd">Enable support for zstd compression</flag>
+ </use>
+</pkgmetadata>
diff --git a/sys-fs/squashfuse/squashfuse-0.1.101_alpha20170917.ebuild b/sys-fs/squashfuse/squashfuse-0.1.101_alpha20170917.ebuild
new file mode 100644
index 00000000..2a75ad5b
--- /dev/null
+++ b/sys-fs/squashfuse/squashfuse-0.1.101_alpha20170917.ebuild
@@ -0,0 +1,44 @@
+# Copyright 2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit autotools flag-o-matic
+
+DESCRIPTION="FUSE filesystem to mount squashfs archives"
+HOMEPAGE="https://github.com/vasi/squashfuse"
+EGIT_COMMIT="e275db06955d3dc455d55d25c015a6b64b1e4756"
+SRC_URI="https://github.com/vasi/squashfuse/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~arm-linux ~x86-linux"
+IUSE="lz4 lzma lzo +zlib zstd"
+REQUIRED_USE="|| ( lz4 lzma lzo zlib zstd )"
+
+COMMON_DEPEND="
+ >=sys-fs/fuse-2.8.6:=
+ lzma? ( >=app-arch/xz-utils-5.0.4:= )
+ zlib? ( >=sys-libs/zlib-1.2.5-r2:= )
+ lzo? ( >=dev-libs/lzo-2.06:= )
+ lz4? ( >=app-arch/lz4-0_p106:= )
+ zstd? ( >=app-arch/zstd-1.0:= )
+"
+DEPEND="${COMMON_DEPEND}"
+RDEPEND="${COMMON_DEPEND}"
+S=${WORKDIR}/${PN}-${EGIT_COMMIT}
+
+src_prepare() {
+ sed -i -e '1s:\[0\.1\.100\]:['"${PV}"']:' configure.ac || die
+ AT_M4DIR=${S}/m4 eautoreconf
+ default
+}
+
+src_configure() {
+ filter-flags -flto* -fwhole-program -fno-common
+ econf \
+ $(use lz4 || echo --without-lz4) \
+ $(use lzma || echo --without-xz) \
+ $(use lzo || echo --without-lzo) \
+ $(use zlib || echo --without-zlib)
+ $(use zstd || echo --without-zstd)
+}