summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Väth <martin@mvath.de>2014-07-05 09:38:02 +0200
committerMartin Väth <martin@mvath.de>2015-10-11 10:49:11 +0200
commit0556494dd98892799376ce50f6fb2b3b28337c48 (patch)
tree1b0933bf9c08675ea5610ee26aa7ceb3679fdaa6 /sys-fs/squashmount
parentBump squashmount, termcolors-mv, sundtek-tv, noscript (diff)
downloadmv-0556494dd98892799376ce50f6fb2b3b28337c48.tar.gz
mv-0556494dd98892799376ce50f6fb2b3b28337c48.tar.bz2
mv-0556494dd98892799376ce50f6fb2b3b28337c48.zip
Bump squashmount
Diffstat (limited to 'sys-fs/squashmount')
-rw-r--r--sys-fs/squashmount/ChangeLog5
-rw-r--r--sys-fs/squashmount/Manifest2
-rw-r--r--[l---------]sys-fs/squashmount/squashmount-6.3.ebuild69
-rw-r--r--sys-fs/squashmount/squashmount-7.1.ebuild (renamed from sys-fs/squashmount/squashmount-7.0.ebuild)0
4 files changed, 74 insertions, 2 deletions
diff --git a/sys-fs/squashmount/ChangeLog b/sys-fs/squashmount/ChangeLog
index e9366d64..ac120f9b 100644
--- a/sys-fs/squashmount/ChangeLog
+++ b/sys-fs/squashmount/ChangeLog
@@ -2,6 +2,11 @@
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+*squashmount-7.1 (05 Jul 2014)
+
+ 05 Jul 2014; Martin Väth <martin@mvath.de>:
+ Version bump, remove old ebuild.
+
*squashmount-7.0 (04 Jul 2014)
04 Jul 2014; Martin Väth <martin@mvath.de>:
diff --git a/sys-fs/squashmount/Manifest b/sys-fs/squashmount/Manifest
index baa4f152..132370b1 100644
--- a/sys-fs/squashmount/Manifest
+++ b/sys-fs/squashmount/Manifest
@@ -1,2 +1,2 @@
DIST squashmount-6.3.tar.gz 42059 SHA256 09699ad6355e39e694e2e95c1074a111a428e2615f5c21c6f0d1942825a5d188 SHA512 c1ffe71abc43b10fde4ac9a66a7518bf3450b6257a59b167f0eabf4f82ba32b82a737099ff0b050ad838ae06ddcefc968c08ab9923b8c89fe579c1492974ebf3 WHIRLPOOL 69c94ff4ee0e1161f59618f58b37fd004495adeedd7ba107c6fdc1318fc13e60e5fadbf44db4a5e06482e708cba648da4e24ec726c7cfb70bdf4e33f914c9464
-DIST squashmount-7.0.tar.gz 43077 SHA256 f36e8fcbca9288386953d46e5540ad6b76ec65c002370ede51492fb0e7ee52d4 SHA512 36a13c94324c700e25c8fdca2a7ab4e33efd312ef4224241224ac72d9393fdc7104d1818690ec4204e326135d82c398dac57322babbc5233f9d76786d784cf55 WHIRLPOOL 7e11c7db02e1f92a6b02851bf438f2b39f2111df674c6bb556eaab2e7db281c4913b013b558200df05d1e2f1f072956a2e5dd4fff9a40c461bc8a81b65aefa1e
+DIST squashmount-7.1.tar.gz 43470 SHA256 6be80976c85438b0a6da26110b91376f296cad1381a85f764ea908767d732145 SHA512 778ebcdc06d2785147dbeded201aae728c189b6abb635fb2d99701692216417b435bdd1ae074a3fe9d1dfe1f04e71f717e5f9f8ba53f193c8162c761a2e66096 WHIRLPOOL 4b2fa74d14ed443c162895d2b7831c744088dec9ba8070d340cd7c27a7b470d201b73c7ef16cc1243585536c185aa8179530cdb1a06d193a0b76dd1849c7efb1
diff --git a/sys-fs/squashmount/squashmount-6.3.ebuild b/sys-fs/squashmount/squashmount-6.3.ebuild
index f9c58e61..a20304c2 120000..100644
--- a/sys-fs/squashmount/squashmount-6.3.ebuild
+++ b/sys-fs/squashmount/squashmount-6.3.ebuild
@@ -1 +1,68 @@
-squashmount-7.0.ebuild \ No newline at end of file
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+RESTRICT="mirror"
+inherit eutils readme.gentoo systemd vcs-snapshot
+
+DESCRIPTION="Keep directories compressed with squashfs. Useful for portage tree, texmf-dist"
+HOMEPAGE="http://forums.gentoo.org/viewtopic-t-465367.html"
+SRC_URI="https://github.com/vaeth/${PN}/tarball/${PV} -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND=">=app-shells/runtitle-2.3
+ dev-lang/perl
+ || ( dev-perl/File-Which sys-apps/which )
+ virtual/perl-File-Path
+ virtual/perl-File-Spec
+ virtual/perl-File-Temp
+ virtual/perl-Getopt-Long
+ sys-fs/squashfs-tools
+ !<sys-fs/unionfs-fuse-0.25"
+DEPEND=""
+
+DISABLE_AUTOFORMATTING="true"
+DOC_CONTENTS="Please adapt /etc/squashmount.pl to your needs.
+For improved output use squasfs-tools from the mv overlay.
+It is recommended to put into your zshrc the line:
+alias squashmount='noglob squashmount'"
+
+src_prepare() {
+ use prefix || sed -i \
+ -e '1s"^#!/usr/bin/env perl$"#!'"${EPREFIX}/usr/bin/perl"'"' \
+ -- bin/* || die
+ epatch_user
+}
+
+src_install() {
+ dobin bin/*
+ dodoc README ChangeLog compress.txt
+ doinitd openrc/init.d/*
+ systemd_dounit systemd/system/*
+ insinto /etc
+ doins etc/*
+ insinto /usr/lib/tmpfiles.d
+ doins tmpfiles.d/*
+ insinto /usr/share/zsh/site-functions
+ doins zsh/*
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ optfeature "status bar support" 'app-shells/runtitle'
+ optfeature "improved compatibility and security" 'dev-perl/File-Which'
+ optfeature "colored output" '>=dev-lang/perl-5.14' 'perl-core/Term-ANSIColor'
+ optfeature "using ? or ?? attributes" '>=dev-lang/perl-5.12' 'virtual/perl-IO-Compress'
+ case " ${REPLACING_VERSIONS}" in
+ ' '[0-9][0-9]*|' '[3-9]*|' '2.[0-9][0-9]*|' '2.[7-9]*)
+ :;;
+ *)
+ FORCE_PRINT_ELOG="true";;
+ esac
+ readme.gentoo_pkg_postinst
+}
diff --git a/sys-fs/squashmount/squashmount-7.0.ebuild b/sys-fs/squashmount/squashmount-7.1.ebuild
index a20304c2..a20304c2 100644
--- a/sys-fs/squashmount/squashmount-7.0.ebuild
+++ b/sys-fs/squashmount/squashmount-7.1.ebuild