summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Väth <martin@mvath.de>2015-10-11 11:26:48 +0200
committerMartin Väth <martin@mvath.de>2015-10-11 11:32:18 +0200
commit109d6b4f673a249aea4deeb0cdb5b54a21592410 (patch)
treeec3589a50dac5be54ef6248d1e0ff3a9fd3b41b4 /sys-fs/squashmount
downloadmv-109d6b4f673a249aea4deeb0cdb5b54a21592410.tar.gz
mv-109d6b4f673a249aea4deeb0cdb5b54a21592410.tar.bz2
mv-109d6b4f673a249aea4deeb0cdb5b54a21592410.zip
Clear history for egencache --repo=mv --update-changelogs
Diffstat (limited to 'sys-fs/squashmount')
-rw-r--r--sys-fs/squashmount/Manifest1
-rw-r--r--sys-fs/squashmount/metadata.xml16
-rw-r--r--sys-fs/squashmount/squashmount-12.2.0.ebuild73
3 files changed, 90 insertions, 0 deletions
diff --git a/sys-fs/squashmount/Manifest b/sys-fs/squashmount/Manifest
new file mode 100644
index 00000000..f946a86a
--- /dev/null
+++ b/sys-fs/squashmount/Manifest
@@ -0,0 +1 @@
+DIST squashmount-12.2.0.tar.gz 60947 SHA256 1c0bd682cecd1dafb44e2191e9c5844e9a731f91a8d65eca014a563feecbff01 SHA512 50b6356f7de8992198b950df1d86333e80fed6493bd683eca51be3beff577406f9914182ff3b5adc8956ed1337a5e2518a171e80075f60e7c1b7d1c05f4c19fc WHIRLPOOL 9afa5f3d02b71c84e7e8d7b56911a2c052f7059289ed0b344087917dac21ba07a0b65860e99fc3f682b6cec2ef1c36e4df3e1395c3b72c803df9d54007d0e348
diff --git a/sys-fs/squashmount/metadata.xml b/sys-fs/squashmount/metadata.xml
new file mode 100644
index 00000000..5c80606b
--- /dev/null
+++ b/sys-fs/squashmount/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>martin@mvath.de</email>
+ <name>Martin Väth</name>
+ </maintainer>
+ <upstream>
+ <maintainer>
+ <email>martin@mvath.de</email>
+ <name>Martin Väth</name>
+ </maintainer>
+ <bugs-to>mailto:martin@mvath.de</bugs-to>
+ <remote-id type="github">vaeth/squashmount</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/sys-fs/squashmount/squashmount-12.2.0.ebuild b/sys-fs/squashmount/squashmount-12.2.0.ebuild
new file mode 100644
index 00000000..21864cd5
--- /dev/null
+++ b/sys-fs/squashmount/squashmount-12.2.0.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+RESTRICT="mirror"
+inherit eutils readme.gentoo systemd
+
+DESCRIPTION="Keep directories compressed with squashfs. Useful for portage tree, texmf-dist"
+HOMEPAGE="http://forums.gentoo.org/viewtopic-t-465367.html
+https://github.com/vaeth/squashmount/"
+SRC_URI="https://github.com/vaeth/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND="!<sys-apps/openrc-0.13
+ >=app-shells/runtitle-2.3
+ >=dev-lang/perl-5.12
+ || ( dev-perl/File-Which sys-apps/which )
+ sys-fs/squashfs-tools
+ !<sys-fs/unionfs-fuse-0.25"
+# || ( >=dev-lang/perl-5.10.1 >=virtual/perl-File-Path-2.6.5 )
+# || ( >=dev-lang/perl-5.4.5 virtual/perl-File-Spec )
+# || ( >=dev-lang/perl-5.10.1 >=virtual/perl-File-Temp-0.19 )
+# || ( >=dev-lang/perl-5.6.1 >=virtual/perl-Getopt-Long-2.24 )
+# || ( >=dev-lang/perl-5.9.3 virtual/perl-IO-Compress )
+DEPEND=""
+
+DISABLE_AUTOFORMATTING="true"
+DOC_CONTENTS="Please adapt /etc/squashmount.pl as well as
+/etc/systemd/system/squashmount.service.d/timeout.conf to your needs.
+
+Configure the mount point 'gentoo' only if you use sync-type = squashdelta.
+
+For improved output use squasfs-tools from the mv overlay.
+
+It is recommended to put into your zshrc the line:
+alias squashmount='noglob squashmount'"
+
+src_prepare() {
+ use prefix || sed -i \
+ -e '1s"^#!/usr/bin/env perl$"#!'"${EPREFIX}/usr/bin/perl"'"' \
+ -- bin/* || die
+ epatch_user
+}
+
+src_install() {
+ dobin bin/*
+ dodoc README ChangeLog compress.txt etc/squashmount.pl
+ doinitd openrc/init.d/*
+ systemd_dounit systemd/system/*
+ insinto /etc
+ doins -r etc/*
+ insinto /usr/lib/tmpfiles.d
+ doins tmpfiles.d/*
+ insinto /usr/share/zsh/site-functions
+ doins zsh/*
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ optfeature "status bar support" 'app-shells/runtitle'
+ optfeature "improved compatibility and security" 'dev-perl/File-Which'
+ optfeature "colored output" '>=dev-lang/perl-5.14' 'virtual/perl-Term-ANSIColor'
+ case " ${REPLACING_VERSIONS}" in
+ ' '[0-7].*|' '8.[0-6]*|' '8.7.[0-4]*)
+ FORCE_PRINT_ELOG="true";;
+ esac
+ readme.gentoo_pkg_postinst
+}