summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Väth <martin@mvath.de>2016-12-21 17:01:46 +0100
committerMartin Väth <martin@mvath.de>2016-12-21 17:01:46 +0100
commita2f2bdfed5526419757fd91d7eff30e2177c2c53 (patch)
tree5b261ee3c0e9b8d56913789351dd854dfd1c270d /sys-fs/squashmount
parentapp-portage/eix: Use tmpfiles.eclass and avoid postinst hacks (diff)
downloadmv-a2f2bdfed5526419757fd91d7eff30e2177c2c53.tar.gz
mv-a2f2bdfed5526419757fd91d7eff30e2177c2c53.tar.bz2
mv-a2f2bdfed5526419757fd91d7eff30e2177c2c53.zip
sys-fs/squashmount: Use tmpfiles.eclass
Diffstat (limited to 'sys-fs/squashmount')
-rw-r--r--sys-fs/squashmount/squashmount-15.4.0_p2-r1.ebuild78
1 files changed, 78 insertions, 0 deletions
diff --git a/sys-fs/squashmount/squashmount-15.4.0_p2-r1.ebuild b/sys-fs/squashmount/squashmount-15.4.0_p2-r1.ebuild
new file mode 100644
index 00000000..8ecd766b
--- /dev/null
+++ b/sys-fs/squashmount/squashmount-15.4.0_p2-r1.ebuild
@@ -0,0 +1,78 @@
+# Copyright 2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+RESTRICT="mirror"
+inherit eutils readme.gentoo-r1 systemd tmpfiles
+
+DESCRIPTION="Keep directories compressed with squashfs. Useful for portage tree, texmf-dist"
+HOMEPAGE="http://forums.gentoo.org/viewtopic-t-465367.html
+https://github.com/vaeth/squashmount/"
+SRC_URI="https://github.com/vaeth/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE=""
+
+RDEPEND="!<sys-apps/openrc-0.13
+ >=dev-lang/perl-5.22
+ || ( dev-perl/File-Which sys-apps/which )
+ sys-fs/squashfs-tools
+ !<sys-fs/unionfs-fuse-0.25"
+# >=dev-lang/perl-5.12
+# || ( >=dev-lang/perl-5.10.1 >=virtual/perl-File-Path-2.6.5 )
+# || ( >=dev-lang/perl-5.4.5 virtual/perl-File-Spec )
+# || ( >=dev-lang/perl-5.10.1 >=virtual/perl-File-Temp-0.19 )
+# || ( >=dev-lang/perl-5.6.1 >=virtual/perl-Getopt-Long-2.24 )
+# || ( >=dev-lang/perl-5.9.3 virtual/perl-IO-Compress )
+DEPEND=""
+
+DISABLE_AUTOFORMATTING="true"
+DOC_CONTENTS="Please adapt /etc/squashmount.pl as well as
+/etc/systemd/system/squashmount.service.d/timeout.conf to your needs.
+
+Configure the mount point 'gentoo' only if you use sync-type = squashdelta.
+
+For improved output use sys-fs/squashfs-tools from the mv overlay.
+
+It is recommended to put into your zshrc the line:
+alias squashmount='noglob squashmount'"
+
+src_prepare() {
+ use prefix || sed -i \
+ -e '1s"^#!/usr/bin/env perl$"#!'"${EPREFIX}/usr/bin/perl"'"' \
+ -- bin/* || die
+ eapply_user
+}
+
+src_install() {
+ dobin bin/*
+ dodoc README ChangeLog compress.txt etc/squashmount.pl
+ doinitd openrc/init.d/*
+ systemd_dounit systemd/system/*
+ dotmpfiles tmpfiles.d/*
+ insinto /etc
+ doins etc/squashmount.pl
+ doins -r etc/revdep-rebuild etc/systemd etc/find_cruft.d
+ exeinto /etc/portage/repo.postsync.d
+ doexe etc/portage/repo.postsync.d/*
+ insinto /usr/share/zsh/site-functions
+ doins zsh/*
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ optfeature "status bar support" 'app-shells/runtitle'
+ optfeature "improved compatibility and security" 'dev-perl/File-Which'
+ optfeature "improved output" 'dev-perl/String-ShellQuote'
+ optfeature "user mounting" \
+ '>=sys-fs/squashfuse-0.1.100 >=sys-fs/unionfs-fuse-0.25' \
+ '>=sys-fs/squashfuse-0.1.100 sys-fs/funionfs'
+ case " ${REPLACING_VERSIONS}" in
+ *' '[0-9].*|*' '1[0-4].*|*' '15.[0-2].*|*' '15.3.0*)
+ FORCE_PRINT_ELOG="true";;
+ esac
+ readme.gentoo_print_elog
+ tmpfiles_process squashmount.conf
+}