summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorMartin Väth <martin@mvath.de>2013-10-12 21:12:31 +0200
committerMartin Väth <martin@mvath.de>2015-10-11 10:48:59 +0200
commit5d21146b66819048d79903a55a151e52fc64749c (patch)
tree8f7da4a59d3c1d8a91d1f9f194285e38e81fd29d /sys-fs
parentBump firewall-mv (diff)
downloadmv-5d21146b66819048d79903a55a151e52fc64749c.tar.gz
mv-5d21146b66819048d79903a55a151e52fc64749c.tar.bz2
mv-5d21146b66819048d79903a55a151e52fc64749c.zip
Add fvwm-crystal. Use readme.gentoo.eclass
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/squash_dir/ChangeLog3
-rw-r--r--sys-fs/squash_dir/squash_dir-13.3.ebuild17
-rw-r--r--sys-fs/squashmount/ChangeLog3
-rw-r--r--sys-fs/squashmount/squashmount-3.5.ebuild12
4 files changed, 22 insertions, 13 deletions
diff --git a/sys-fs/squash_dir/ChangeLog b/sys-fs/squash_dir/ChangeLog
index 09b0b699..28585086 100644
--- a/sys-fs/squash_dir/ChangeLog
+++ b/sys-fs/squash_dir/ChangeLog
@@ -4,6 +4,9 @@
*squash_dir-13.3 (31 Aug 2013)
+ 12 Oct 2013; Martin Väth <martin@mvath.de>:
+ Use readme.gentoo.eclass
+
10 Sep 2013; Martin Väth <martin@mvath.de>:
Install zsh-completion unconditionally according to gentoo policy
diff --git a/sys-fs/squash_dir/squash_dir-13.3.ebuild b/sys-fs/squash_dir/squash_dir-13.3.ebuild
index 5ce07a5f..0c8df83a 100644
--- a/sys-fs/squash_dir/squash_dir-13.3.ebuild
+++ b/sys-fs/squash_dir/squash_dir-13.3.ebuild
@@ -6,7 +6,7 @@ EAPI=5
RESTRICT="mirror"
WANT_LIBTOOL=none
AUTOTOOLS_IN_SOURCE_BUILD=true
-inherit autotools autotools-utils eutils linux-info systemd vcs-snapshot
+inherit autotools autotools-utils eutils linux-info readme.gentoo systemd vcs-snapshot
DESCRIPTION="Keep directories compressed with squashfs. Useful for portage tree, texmf-dist"
HOMEPAGE="http://forums.gentoo.org/viewtopic-t-465367.html"
@@ -27,6 +27,11 @@ RDEPEND="sys-fs/squashfs-tools
DEPEND=">=sys-devel/autoconf-2.65
${BOTHDEPEND}"
+DISABLE_AUTOFORMATTING="true"
+DOC_CONTENTS="Please adapt ${EPREFIX}/etc/conf.d/${PN} to your needs.
+It is recommended to put into your zshrc the line:
+alias squash_dir='noglob squash_dir'"
+
src_prepare() {
if [ -n "${EPREFIX}" ]
then sed -i \
@@ -66,6 +71,7 @@ linux_config_missing() {
}
pkg_postinst() {
+ readme.gentoo_pkg_postinst
local fs=overlayfs
use unionfs-fuse && fs=unionfs-fuse
use aufs && fs=aufs
@@ -85,19 +91,10 @@ pkg_postinst() {
then ewarn "To use ${PN} activate aufs in your kernel. Use e.g. sys-fs/aufs*"
fi;;
esac
- case " ${REPLACING_VERSIONS}" in
- ' '[0-9][0-9][0-9]*|' '[2-9][0-9]*|' '1[3-9]*|' '12.[0-9][0-9]*|' '12.[7-9]*) :;;
- *) elog "Please adopt ${EPREFIX}/etc/conf.d/${PN} to your needs.";;
- esac
if ! has_version sys-fs/squashfs-tools[progress-redirect]
then elog "For better output of ${PN}, it is recommended to install"
elog "sys-fs/squashfs-tools from the mv overlay with USE=progress-redirect."
fi
has_version app-shells/runtitle || elog \
"Install app-shells/runtitle to let ${PN} update the status bar."
- case " ${REPLACING_VERSIONS}" in
- ' '[0-9][0-9][0-9]*|' '[2-9][0-9]*|' '1[4-9]*|' '13.[0-9][0-9]*|' '13.[3-9]*) :;;
- *) elog "It is recommended to put into your zshrc the line:"
- elog "alias squash_dir='noglob squash_dir'";;
- esac
}
diff --git a/sys-fs/squashmount/ChangeLog b/sys-fs/squashmount/ChangeLog
index 4013e69d..7f0ba398 100644
--- a/sys-fs/squashmount/ChangeLog
+++ b/sys-fs/squashmount/ChangeLog
@@ -4,6 +4,9 @@
*squashmount-3.5 (09 Oct 2013)
+ 12 Oct 2013; Martin Väth <martin@mvath.de>:
+ Use readme.gentoo.eclass
+
09 Oct 2013; Martin Väth <martin@mvath.de>:
Version bump, remove old ebuild.
diff --git a/sys-fs/squashmount/squashmount-3.5.ebuild b/sys-fs/squashmount/squashmount-3.5.ebuild
index 840e160d..332b2f27 100644
--- a/sys-fs/squashmount/squashmount-3.5.ebuild
+++ b/sys-fs/squashmount/squashmount-3.5.ebuild
@@ -4,7 +4,7 @@
EAPI=5
RESTRICT="mirror"
-inherit eutils systemd vcs-snapshot
+inherit eutils readme.gentoo systemd vcs-snapshot
DESCRIPTION="Keep directories compressed with squashfs. Useful for portage tree, texmf-dist"
HOMEPAGE="http://forums.gentoo.org/viewtopic-t-465367.html"
@@ -26,6 +26,11 @@ RDEPEND=">=app-shells/runtitle-2.3
!<sys-fs/unionfs-fuse-0.25"
DEPEND=""
+DISABLE_AUTOFORMATTING="true"
+DOC_CONTENTS="Please adapt /etc/squashmount.pl to your needs.
+It is recommended to put into your zshrc the line:
+alias squashmount='noglob squashmount'"
+
src_prepare() {
epatch_user
}
@@ -41,6 +46,7 @@ src_install() {
doins tmpfiles.d/*
insinto /usr/share/zsh/site-functions
doins zsh/*
+ readme.gentoo_src_install
}
pkg_postinst() {
@@ -62,7 +68,7 @@ pkg_postinst() {
}
case " ${REPLACING_VERSIONS}" in
' '[0-9][0-9]*|' '[3-9]*|' '2.[0-9][0-9]*|' '2.[7-9]*) :;;
- *) elog "It is recommended to put into your zshrc the line:"
- elog "alias squashmount='noglob squashmount'";;
+ *) FORCE_PRINT_ELOG="true";;
esac
+ readme.gentoo_pkg_postinst
}