summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorMartin Väth <martin@mvath.de>2014-05-21 00:33:44 +0200
committerMartin Väth <martin@mvath.de>2015-10-11 10:49:10 +0200
commit8c06d6d72a30aabbd4066224210d3c8ba5d3d359 (patch)
tree04d9824b03e1dcd31f9626184dce320ae1d70947 /sys-fs
parentBump zshrc-mv (diff)
downloadmv-8c06d6d72a30aabbd4066224210d3c8ba5d3d359.tar.gz
mv-8c06d6d72a30aabbd4066224210d3c8ba5d3d359.tar.bz2
mv-8c06d6d72a30aabbd4066224210d3c8ba5d3d359.zip
Bump squashmount to revert COMPRESSION=xz default
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/squashmount/ChangeLog5
-rw-r--r--sys-fs/squashmount/Manifest1
-rw-r--r--sys-fs/squashmount/squashmount-6.0.ebuild2
-rw-r--r--sys-fs/squashmount/squashmount-6.0a.ebuild68
4 files changed, 75 insertions, 1 deletions
diff --git a/sys-fs/squashmount/ChangeLog b/sys-fs/squashmount/ChangeLog
index af5c761f..8d835515 100644
--- a/sys-fs/squashmount/ChangeLog
+++ b/sys-fs/squashmount/ChangeLog
@@ -2,6 +2,11 @@
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+*squashmount-6.0a (21 May 2014)
+
+ 21 May 2014; Martin Väth <martin@mvath.de>:
+ Version bump to revert to COMPRESSION=xz default. Mask old by keyword.
+
*squashmount-6.0 (17 May 2014)
17 May 2014; Martin Väth <martin@mvath.de>:
diff --git a/sys-fs/squashmount/Manifest b/sys-fs/squashmount/Manifest
index 3d85b870..4f602284 100644
--- a/sys-fs/squashmount/Manifest
+++ b/sys-fs/squashmount/Manifest
@@ -1 +1,2 @@
DIST squashmount-6.0.tar.gz 40089 SHA256 33167386a86ca6eabeee46a3bc06ec1c9f64305afd978378c36ab2b24c2a3220 SHA512 ef09f674d8dd84563e6911248e40187c80082705f0b6b3638c1e8c513df9bf822778d811a26dd7d4ab61c28202f8f606e4c4f295231e95becaf9c15bfaeda99f WHIRLPOOL 53d6410daaa990347c052e0194fa26d9799b2b55481357df783cf66236bf694122b2ef1e8b5b027cc6274cb4065ffa3f0d5537d82e7d7a5a3d9ac0b5828811e2
+DIST squashmount-6.0a.tar.gz 40133 SHA256 a7dbdaa23240f77719f6fe9704c1b8dd6692680ac137c00f1ec5006b722e118c SHA512 96a610c6aae2f40a2bdf71ba0e781ba12785a696401ea895a3b8a0a801c20aee267bae8782e1902d5fbd0bd5d4b6901ed86166ff3fe40c9c7047e3dce6264bc8 WHIRLPOOL 0a828d36499823e0edc4d3c9ebe87d25d5b6c2e3cd8e679d5033dae4cb75903763e466b2e7dbc6d8ba32370a46f78a6c856385150888d7c602a8d0b50d38828c
diff --git a/sys-fs/squashmount/squashmount-6.0.ebuild b/sys-fs/squashmount/squashmount-6.0.ebuild
index ed9d9899..e6424f30 100644
--- a/sys-fs/squashmount/squashmount-6.0.ebuild
+++ b/sys-fs/squashmount/squashmount-6.0.ebuild
@@ -12,7 +12,7 @@ SRC_URI="https://github.com/vaeth/${PN}/tarball/${PV} -> ${P}.tar.gz"
LICENSE="BSD"
SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86"
+KEYWORDS=""
IUSE=""
RDEPEND=">=app-shells/runtitle-2.3
diff --git a/sys-fs/squashmount/squashmount-6.0a.ebuild b/sys-fs/squashmount/squashmount-6.0a.ebuild
new file mode 100644
index 00000000..ed9d9899
--- /dev/null
+++ b/sys-fs/squashmount/squashmount-6.0a.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+RESTRICT="mirror"
+inherit eutils readme.gentoo systemd vcs-snapshot
+
+DESCRIPTION="Keep directories compressed with squashfs. Useful for portage tree, texmf-dist"
+HOMEPAGE="http://forums.gentoo.org/viewtopic-t-465367.html"
+SRC_URI="https://github.com/vaeth/${PN}/tarball/${PV} -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND=">=app-shells/runtitle-2.3
+ dev-lang/perl
+ || ( dev-perl/File-Which sys-apps/which )
+ virtual/perl-File-Path
+ virtual/perl-File-Spec
+ virtual/perl-File-Temp
+ virtual/perl-Getopt-Long
+ sys-fs/squashfs-tools
+ !<sys-fs/unionfs-fuse-0.25"
+DEPEND=""
+
+DISABLE_AUTOFORMATTING="true"
+DOC_CONTENTS="Please adapt /etc/squashmount.pl to your needs.
+It is recommended to put into your zshrc the line:
+alias squashmount='noglob squashmount'"
+
+src_prepare() {
+ use prefix || sed -i \
+ -e '1s"^#!/usr/bin/env perl$"#!'"${EPREFIX}/usr/bin/perl"'"' \
+ -- bin/* || die
+ epatch_user
+}
+
+src_install() {
+ dobin bin/*
+ dodoc README ChangeLog compress.txt
+ doinitd openrc/init.d/*
+ systemd_dounit systemd/system/*
+ insinto /etc
+ doins etc/*
+ insinto /usr/lib/tmpfiles.d
+ doins tmpfiles.d/*
+ insinto /usr/share/zsh/site-functions
+ doins zsh/*
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ optfeature "improved output" 'sys-fs/squashfs-tools[progress-redirect]'
+ optfeature "status bar support" 'app-shells/runtitle'
+ optfeature "improved compatibility and security" 'dev-perl/File-Which'
+ optfeature "colored output" '>=dev-lang/perl-5.14' 'perl-core/Term-ANSIColor'
+ optfeature "using ? or ?? attributes" '>=dev-lang/perl-5.12' 'virtual/perl-IO-Compress'
+ case " ${REPLACING_VERSIONS}" in
+ ' '[0-9][0-9]*|' '[3-9]*|' '2.[0-9][0-9]*|' '2.[7-9]*)
+ :;;
+ *)
+ FORCE_PRINT_ELOG="true";;
+ esac
+ readme.gentoo_pkg_postinst
+}