summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorMartin Väth <martin@mvath.de>2012-05-12 21:48:57 +0200
committerMartin Väth <martin@mvath.de>2015-10-11 10:48:06 +0200
commitd4094d9b83a0e74ac34c8e84cf6afcf9f29a2af6 (patch)
tree2a5ea9ae39450958316da86a1e309d6de091e7c5 /sys-fs
parentBump portage-bashrc-mv, noscript. Update checksums (diff)
downloadmv-d4094d9b83a0e74ac34c8e84cf6afcf9f29a2af6.tar.gz
mv-d4094d9b83a0e74ac34c8e84cf6afcf9f29a2af6.tar.bz2
mv-d4094d9b83a0e74ac34c8e84cf6afcf9f29a2af6.zip
base-eclass. Update checksums
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/aufs-util/ChangeLog3
-rw-r--r--sys-fs/aufs-util/aufs-util-99999999.2.ebuild6
-rw-r--r--sys-fs/aufs-util/aufs-util-99999999.3.ebuild6
-rw-r--r--sys-fs/aufs/ChangeLog3
-rw-r--r--sys-fs/aufs/aufs-99999999.2.ebuild41
-rw-r--r--sys-fs/aufs/aufs-99999999.3-r1.ebuild36
-rw-r--r--sys-fs/emount/ChangeLog3
-rw-r--r--sys-fs/emount/emount-2.1-r1.ebuild6
-rw-r--r--sys-fs/squash_dir/ChangeLog3
-rw-r--r--sys-fs/squash_dir/squash_dir-11.10.ebuild4
-rw-r--r--sys-fs/squashfs-tools/ChangeLog3
-rw-r--r--sys-fs/squashfs-tools/squashfs-tools-3.2_p2.ebuild4
-rw-r--r--sys-fs/squashfs-tools/squashfs-tools-3.4.ebuild4
-rw-r--r--sys-fs/squashfs-tools/squashfs-tools-4.2-r1.ebuild4
-rw-r--r--sys-fs/unionfs-fuse/ChangeLog3
-rw-r--r--sys-fs/unionfs-fuse/unionfs-fuse-0.25.ebuild6
-rw-r--r--sys-fs/unionfs-fuse/unionfs-fuse-99999999.ebuild6
17 files changed, 83 insertions, 58 deletions
diff --git a/sys-fs/aufs-util/ChangeLog b/sys-fs/aufs-util/ChangeLog
index 01945044..d9de4fe5 100644
--- a/sys-fs/aufs-util/ChangeLog
+++ b/sys-fs/aufs-util/ChangeLog
@@ -2,6 +2,9 @@
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
# $Header $
+ 12 May 2012; Martin Väth <martin@mvath.de>
+ base->eutils
+
15 Apr 2012; Martin Väth <martin@mvath.de>
Inherit base
diff --git a/sys-fs/aufs-util/aufs-util-99999999.2.ebuild b/sys-fs/aufs-util/aufs-util-99999999.2.ebuild
index 47a0cfa3..bcfff4ec 100644
--- a/sys-fs/aufs-util/aufs-util-99999999.2.ebuild
+++ b/sys-fs/aufs-util/aufs-util-99999999.2.ebuild
@@ -5,10 +5,10 @@
EAPI="4"
EGIT_REPO_URI="http://git.c3sl.ufpr.br/pub/scm/aufs/aufs2-util.git"
EGIT_BRANCH="aufs2.1"
-EGIT_COMMIT="${EGIT_BRANCH}"
+EGIT_COMMIT=${EGIT_BRANCH}
EGIT_HAS_SUBMODULES=true
[ -n "${EVCS_OFFLINE}" ] || EGIT_REPACK=true
-inherit base git-2 linux-info multilib
+inherit eutils git-2 linux-info multilib
DESCRIPTION="Userspace tools for aufs"
HOMEPAGE="http://aufs.sourceforge.net/"
@@ -40,5 +40,5 @@ src_prepare() {
sed -i -e "1iCFLAGS += -I../local_kernel" -e "${l}" "${i}" || \
die "Patching ${i} failed"
done
- base_src_prepare
+ epatch_user
}
diff --git a/sys-fs/aufs-util/aufs-util-99999999.3.ebuild b/sys-fs/aufs-util/aufs-util-99999999.3.ebuild
index 16d999ec..c4337c93 100644
--- a/sys-fs/aufs-util/aufs-util-99999999.3.ebuild
+++ b/sys-fs/aufs-util/aufs-util-99999999.3.ebuild
@@ -5,10 +5,10 @@
EAPI="4"
EGIT_REPO_URI="git://aufs.git.sourceforge.net/gitroot/aufs/aufs-util.git"
EGIT_BRANCH="aufs3.0"
-EGIT_COMMIT="${EGIT_BRANCH}"
+EGIT_COMMIT=${EGIT_BRANCH}
EGIT_HAS_SUBMODULES=true
[ -n "${EVCS_OFFLINE}" ] || EGIT_REPACK=true
-inherit base git-2 linux-info multilib
+inherit eutils git-2 linux-info multilib
DESCRIPTION="Userspace tools for aufs"
HOMEPAGE="http://aufs.sourceforge.net/"
@@ -40,5 +40,5 @@ src_prepare() {
sed -i -e "1iCFLAGS += -I../local_kernel" -e "${l}" "${i}" || \
die "Patching ${i} failed"
done
- base_src_prepare
+ epatch_user
}
diff --git a/sys-fs/aufs/ChangeLog b/sys-fs/aufs/ChangeLog
index 2f40d8d6..339225f5 100644
--- a/sys-fs/aufs/ChangeLog
+++ b/sys-fs/aufs/ChangeLog
@@ -2,6 +2,9 @@
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
# $Header $
+ 12 May 2012; Martin Väth <martin@mvath.de>
+ base->eutils
+
15 Apr 2012; Martin Väth <martin@mvath.de>
Inherit base
diff --git a/sys-fs/aufs/aufs-99999999.2.ebuild b/sys-fs/aufs/aufs-99999999.2.ebuild
index 26c6194b..56a3ec77 100644
--- a/sys-fs/aufs/aufs-99999999.2.ebuild
+++ b/sys-fs/aufs/aufs-99999999.2.ebuild
@@ -7,10 +7,10 @@ EGIT_REPO_URI="http://git.c3sl.ufpr.br/pub/scm/aufs/aufs2-standalone.git"
EGIT_PROJECT="aufs2.git"
# BRANCH/COMMIT will be overridden in pkg_setup (according to kernel version)
EGIT_BRANCH="aufs2.2"
-EGIT_COMMIT="${EGIT_BRANCH}"
+EGIT_COMMIT=${EGIT_BRANCH}
EGIT_HAS_SUBMODULES=true
[ -n "${EVCS_OFFLINE}" ] || EGIT_REPACK=true
-inherit base git-2 linux-info eutils
+inherit eutils git-2 linux-info eutils
DESCRIPTION="An entirely re-designed and re-implemented Unionfs"
HOMEPAGE="http://aufs.sourceforge.net/"
@@ -33,17 +33,15 @@ fill_my_patchlist() {
local i
my_patchlist=()
for i
- do case "${i}" in
- *.patch|*.diff) test -f "${i}" && my_patchlist+=("${i}")
- ;;
+ do case ${i} in
+ *.patch|*.diff) ! test -f "${i}" || my_patchlist+=("${i}");;
esac
done
- :
}
apply_my_patch() {
local r
- r=''
+ r=
if [ ${#} -gt 1 ]
then shift
r='-R'
@@ -59,14 +57,14 @@ apply_my_patch() {
apply_my_patchlist() {
local r i
- r=''
- if [ "${#}" -gt 0 ]
+ r=
+ if [ ${#} -gt 0 ]
then shift
r='-R'
fi
set --
for i in "${my_patchlist[@]}"
- do if use all-patches || case "${i}" in
+ do if use all-patches || case ${i} in
aufs*) :;;
*) false;;
esac
@@ -106,14 +104,14 @@ pkg_setup() {
elog " AUFSBRANCH=aufs2.2-3.0 emerge -1 aufs"
elog "To use the aufs2.1 branch for kernel version 2.6.39 use:"
elog " AUFSBRANCH=aufs2.1-39 emerge -1 aufs"
- msg=''
+ msg=
if [ -n "${msg}" ]
then
elog "Note that it might be necessary in addition to fetch the newest aufs:"
elog "Set ${msg# } and be sure to be online during emerge."
fi
elog
- EGIT_COMMIT="${EGIT_BRANCH}"
+ EGIT_COMMIT=${EGIT_BRANCH}
use kernel-patch || return 0
(
@@ -125,27 +123,26 @@ pkg_setup() {
src_prepare() {
local i j w v newest all
- base_src_prepare
+ epatch_user
all="2.2.0 2.2.1 2.2.2 2.2.2.r1"
- newest="${all##* }"
- v=''
+ newest=${all##* }
+ v=
for i in ${GRSECURITYPATCHVER-+}
- do case "${i}" in
- '+') j="${newest}";;
- '*') j="${all}";;
+ do case ${i} in
+ '+') j=${newest};;
+ '*') j=${all};;
*) w=:
for j in ${all}
do [ "${i}" = "${j}" ] && w=false && continue
done
if ${w}
then warn "GRSECURITYPATCHVER contains bad version ${i}"
- else j="${i}"
- fi
- ;;
+ else j=${i}
+ fi;;
esac
v="${v} ${j}"
done
- v="${v# }"
+ v=${v# }
elog
elog "Using GRSECURITYPATCHVER: ${v}"
elog "If you want other patches, set GRSECURITYPATCHVER to some or more of:"
diff --git a/sys-fs/aufs/aufs-99999999.3-r1.ebuild b/sys-fs/aufs/aufs-99999999.3-r1.ebuild
index 359dad55..ff5b7252 100644
--- a/sys-fs/aufs/aufs-99999999.3-r1.ebuild
+++ b/sys-fs/aufs/aufs-99999999.3-r1.ebuild
@@ -7,10 +7,10 @@ EGIT_REPO_URI="git://aufs.git.sourceforge.net/gitroot/aufs/aufs3-standalone.git"
EGIT_PROJECT="aufs3.git"
# BRANCH/COMMIT will be overridden in pkg_setup (according to kernel version)
EGIT_BRANCH="aufs3.0"
-EGIT_COMMIT="${EGIT_BRANCH}"
+EGIT_COMMIT=${EGIT_BRANCH}
EGIT_HAS_SUBMODULES=true
[ -n "${EVCS_OFFLINE}" ] || EGIT_REPACK=true
-inherit base git-2 linux-info eutils
+inherit eutils git-2 linux-info eutils
DESCRIPTION="An entirely re-designed and re-implemented Unionfs"
HOMEPAGE="http://aufs.sourceforge.net/"
@@ -33,16 +33,15 @@ fill_my_patchlist() {
local i
my_patchlist=()
for i
- do case "${i}" in
- *.patch|*.diff) test -f "${i}" && my_patchlist+=("${i}");;
+ do case ${i} in
+ *.patch|*.diff) ! test -f "${i}" || my_patchlist+=("${i}");;
esac
done
- :
}
apply_my_patch() {
local r
- r=''
+ r=
if [ ${#} -gt 1 ]
then shift
r='-R'
@@ -58,8 +57,8 @@ apply_my_patch() {
apply_my_patchlist() {
local r i
- r=''
- if [ "${#}" -gt 0 ]
+ r=
+ if [ ${#} -gt 0 ]
then shift
r='-R'
fi
@@ -103,14 +102,14 @@ pkg_setup() {
elog "If this guess for the branch is wrong, set AUFSBRANCH."
elog "For example, to use the aufs3.0 branch for kernel version 3.0, use:"
elog " AUFSBRANCH=aufs3.0 emerge -1 aufs"
- msg=''
+ msg=
if [ -n "${msg}" ]
then
elog "Note that it might be necessary in addition to fetch the newest aufs:"
elog "Set ${msg# } and be sure to be online during emerge."
fi
elog
- EGIT_COMMIT="${EGIT_BRANCH}"
+ EGIT_COMMIT=${EGIT_BRANCH}
use kernel-patch || return 0
(
@@ -122,14 +121,14 @@ pkg_setup() {
src_prepare() {
local i j w v newest all
- base_src_prepare
+ epatch_user
all="2.2.0 2.2.1 2.2.2 2.2.2.r1"
- newest="${all##* }"
- v=''
+ newest=${all##* }
+ v=
for i in ${GRSECURITYPATCHVER-+}
- do case "${i}" in
- '+') j="${newest}";;
- '*') j="${all}";;
+ do case ${i} in
+ '+') j=${newest};;
+ '*') j=${all};;
*) w=:
for j in ${all}
do [ "${i}" = "${j}" ] && w=false && continue
@@ -137,12 +136,11 @@ src_prepare() {
if ${w}
then warn "GRSECURITYPATCHVER contains bad version ${i}"
else j="${i}"
- fi
- ;;
+ fi;;
esac
v="${v} ${j}"
done
- v="${v# }"
+ v=${v# }
elog
elog "Using GRSECURITYPATCHVER: ${v}"
elog "If you want other patches, set GRSECURITYPATCHVER to some or more of:"
diff --git a/sys-fs/emount/ChangeLog b/sys-fs/emount/ChangeLog
index 9db27a18..afe77d2b 100644
--- a/sys-fs/emount/ChangeLog
+++ b/sys-fs/emount/ChangeLog
@@ -4,6 +4,9 @@
*emount-2.1-r1 (03 Feb 2012)
+ 12 May 2012; Martin Väth <martin@mvath.de>
+ base->eutils
+
15 Apr 2012; Martin Väth <martin@mvath.de>
Inherit base
diff --git a/sys-fs/emount/emount-2.1-r1.ebuild b/sys-fs/emount/emount-2.1-r1.ebuild
index 51fbdde3..544fc96b 100644
--- a/sys-fs/emount/emount-2.1-r1.ebuild
+++ b/sys-fs/emount/emount-2.1-r1.ebuild
@@ -4,7 +4,7 @@
EAPI="4"
RESTRICT="mirror"
-inherit base vcs-snapshot
+inherit eutils vcs-snapshot
DESCRIPTION="mount/unmount (and create/remove) dm-crypt filesystems according to your /etc/fstab"
HOMEPAGE="https://github.com/vaeth/emount/"
@@ -19,6 +19,10 @@ RDEPEND="dev-lang/perl
sys-fs/cryptsetup
virtual/perl-Getopt-Long"
+src_prepare() {
+ epatch_user
+}
+
src_install() {
local i
insinto /usr/bin
diff --git a/sys-fs/squash_dir/ChangeLog b/sys-fs/squash_dir/ChangeLog
index 81c13362..4b8df871 100644
--- a/sys-fs/squash_dir/ChangeLog
+++ b/sys-fs/squash_dir/ChangeLog
@@ -4,6 +4,9 @@
*squash_dir-11.10 (07 May 2012)
+ 12 May 2012; Martin Väth <martin@mvath.de>
+ base->eutils
+
07 May 2012; Martin Väth <martin@mvath.de>
Version bump, remove old ebuild.
diff --git a/sys-fs/squash_dir/squash_dir-11.10.ebuild b/sys-fs/squash_dir/squash_dir-11.10.ebuild
index e853960d..8857f78b 100644
--- a/sys-fs/squash_dir/squash_dir-11.10.ebuild
+++ b/sys-fs/squash_dir/squash_dir-11.10.ebuild
@@ -5,7 +5,7 @@
EAPI="4"
RESTRICT="mirror"
WANT_LIBTOOL=none
-inherit base autotools vcs-snapshot
+inherit eutils autotools vcs-snapshot
DESCRIPTION="Keep directories compressed with squashfs. Useful for portage tree, texmf-dist"
HOMEPAGE="http://forums.gentoo.org/viewtopic-t-465367.html"
@@ -28,7 +28,7 @@ RDEPEND="sys-fs/squashfs-tools
DEPEND=">=sys-devel/autoconf-2.65"
src_prepare() {
- base_src_prepare
+ epatch_user
eautoreconf
}
diff --git a/sys-fs/squashfs-tools/ChangeLog b/sys-fs/squashfs-tools/ChangeLog
index a7576606..5f2e77f6 100644
--- a/sys-fs/squashfs-tools/ChangeLog
+++ b/sys-fs/squashfs-tools/ChangeLog
@@ -2,6 +2,9 @@
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
# $Header $
+ 12 May 2012; Martin Väth <martin@mvath.de>
+ base->eutils
+
15 Apr 2012; Martin Väth <martin@mvath.de>
Add old LZMA support back (and revbump) as in the main tree.
Downgrade revision numbers to match with main tree.
diff --git a/sys-fs/squashfs-tools/squashfs-tools-3.2_p2.ebuild b/sys-fs/squashfs-tools/squashfs-tools-3.2_p2.ebuild
index 3cfbac3e..02f1bb59 100644
--- a/sys-fs/squashfs-tools/squashfs-tools-3.2_p2.ebuild
+++ b/sys-fs/squashfs-tools/squashfs-tools-3.2_p2.ebuild
@@ -3,7 +3,7 @@
# $Header $
EAPI="4"
-inherit base toolchain-funcs
+inherit eutils toolchain-funcs
MY_PV=${PV/_p/-r}
DESCRIPTION="Tool for creating compressed filesystem type squashfs"
@@ -27,7 +27,7 @@ src_prepare() {
use progress-redirect && \
epatch "${FILESDIR}/${PN}-3.3-progress-stderr.patch"
echo "struct dir_info; `grep '^int dir_scan2' mksquashfs.c`;" >> global.h
- base_src_prepare
+ epatch_user
}
src_compile() {
diff --git a/sys-fs/squashfs-tools/squashfs-tools-3.4.ebuild b/sys-fs/squashfs-tools/squashfs-tools-3.4.ebuild
index 4a8c1c94..f233805f 100644
--- a/sys-fs/squashfs-tools/squashfs-tools-3.4.ebuild
+++ b/sys-fs/squashfs-tools/squashfs-tools-3.4.ebuild
@@ -3,7 +3,7 @@
# $Header $
EAPI="4"
-inherit base toolchain-funcs
+inherit eutils toolchain-funcs
MY_PV=${PV/_p/-r}
DESCRIPTION="Tool for creating compressed filesystem type squashfs"
@@ -27,7 +27,7 @@ src_prepare() {
use progress-redirect && \
epatch "${FILESDIR}/${P}-progress-stderr.patch"
sed -i -e 's:get_nprocs():sysconf(_SC_NPROCESSORS_ONLN):' *.c
- base_src_prepare
+ epatch_user
}
src_compile() {
diff --git a/sys-fs/squashfs-tools/squashfs-tools-4.2-r1.ebuild b/sys-fs/squashfs-tools/squashfs-tools-4.2-r1.ebuild
index 90bc7eb4..e451cc0c 100644
--- a/sys-fs/squashfs-tools/squashfs-tools-4.2-r1.ebuild
+++ b/sys-fs/squashfs-tools/squashfs-tools-4.2-r1.ebuild
@@ -4,7 +4,7 @@
EAPI="4"
-inherit base toolchain-funcs
+inherit eutils toolchain-funcs
MY_PV=${PV}
DESCRIPTION="Tool for creating compressed filesystem type squashfs"
@@ -30,7 +30,7 @@ S="${WORKDIR}/squashfs${MY_PV}/squashfs-tools"
src_prepare() {
use progress-redirect && \
epatch "${FILESDIR}/${PN}-4.0-progress-stderr.patch"
- base_src_prepare
+ epatch_user
}
use_sed() {
diff --git a/sys-fs/unionfs-fuse/ChangeLog b/sys-fs/unionfs-fuse/ChangeLog
index c33475de..4a418ce2 100644
--- a/sys-fs/unionfs-fuse/ChangeLog
+++ b/sys-fs/unionfs-fuse/ChangeLog
@@ -2,6 +2,9 @@
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
# $Header $
+ 12 May 2012; Martin Väth <martin@mvath.de>
+ base->eutils
+
15 Apr 2012; Martin Väth <martin@mvath.de>
Inherit base
diff --git a/sys-fs/unionfs-fuse/unionfs-fuse-0.25.ebuild b/sys-fs/unionfs-fuse/unionfs-fuse-0.25.ebuild
index ef28ad4e..e352faba 100644
--- a/sys-fs/unionfs-fuse/unionfs-fuse-0.25.ebuild
+++ b/sys-fs/unionfs-fuse/unionfs-fuse-0.25.ebuild
@@ -3,7 +3,7 @@
# $Header $
EAPI="4"
-inherit base flag-o-matic
+inherit eutils flag-o-matic
RESTRICT="mirror"
DESCRIPTION="Self-syncing tree-merging file system based on FUSE"
@@ -18,6 +18,10 @@ IUSE=""
DEPEND="sys-fs/fuse"
RDEPEND="${DEPEND}"
+src_prepare() {
+ epatch_user
+}
+
src_configure() {
filter-flags -flto -fuse-linkerplugin -fwhole-program -fno-common
}
diff --git a/sys-fs/unionfs-fuse/unionfs-fuse-99999999.ebuild b/sys-fs/unionfs-fuse/unionfs-fuse-99999999.ebuild
index 305feebe..61ef452d 100644
--- a/sys-fs/unionfs-fuse/unionfs-fuse-99999999.ebuild
+++ b/sys-fs/unionfs-fuse/unionfs-fuse-99999999.ebuild
@@ -5,7 +5,7 @@
EAPI="4"
EHG_REPO_URI="http://podgorny.cz/~bernd/hg/hgwebdir.cgi/0.25"
S="${WORKDIR}/0.25"
-inherit base mercurial flag-o-matic
+inherit eutils mercurial flag-o-matic
DESCRIPTION="Self-syncing tree-merging file system based on FUSE"
@@ -22,6 +22,10 @@ PROPERTIES="live"
DEPEND="sys-fs/fuse"
RDEPEND="${DEPEND}"
+src_prepare() {
+ epatch_user
+}
+
src_configure() {
filter-flags -flto -fuse-linkerplugin -fwhole-program -fno-common
}