summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Väth <martin@mvath.de>2017-11-01 21:03:56 +0100
committerMartin Väth <martin@mvath.de>2017-11-01 21:03:56 +0100
commitd1bdf34d9cfb3dcdae4ed8a5e1c48f09d2e24275 (patch)
tree6736ae7dc84f7423081bf0b24c485a81472c7a69 /sys-kernel/kccmp/kccmp-0.3-r1.ebuild
parentapp-portage/portage-bashrc-mv: Version bump (diff)
downloadmv-d1bdf34d9cfb3dcdae4ed8a5e1c48f09d2e24275.tar.gz
mv-d1bdf34d9cfb3dcdae4ed8a5e1c48f09d2e24275.tar.bz2
mv-d1bdf34d9cfb3dcdae4ed8a5e1c48f09d2e24275.zip
sys-kernel/kccmp: Add from gentoo repository to build with qt5
Diffstat (limited to 'sys-kernel/kccmp/kccmp-0.3-r1.ebuild')
-rw-r--r--sys-kernel/kccmp/kccmp-0.3-r1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/sys-kernel/kccmp/kccmp-0.3-r1.ebuild b/sys-kernel/kccmp/kccmp-0.3-r1.ebuild
new file mode 100644
index 00000000..e9801be8
--- /dev/null
+++ b/sys-kernel/kccmp/kccmp-0.3-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit qmake-utils
+
+DESCRIPTION="A simple tool for comparing two linux kernel .config files"
+HOMEPAGE="http://stoopidsimple.com/kccmp/"
+SRC_URI="http://stoopidsimple.com/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ echo "QT += widgets" >> ${PN}.pro
+ default
+}
+
+src_configure() {
+ local project_file=$(qmake-utils_find_pro_file)
+ eqmake5 "${project_file}"
+}
+
+src_install() {
+ dobin kccmp
+ dodoc README
+}