summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Väth <martin@mvath.de>2017-07-12 06:45:56 +0200
committerMartin Väth <martin@mvath.de>2017-07-12 06:45:56 +0200
commitb9fca023460563d66c2f3c0dc2d77f0752b72e46 (patch)
tree3a51aec50eed862fa16e9e1ac9d034e442656e1f /sys-kernel/kernel/kernel-4.3.ebuild
parentsys-fs/squash_dir: Version bump (diff)
downloadmv-b9fca023460563d66c2f3c0dc2d77f0752b72e46.tar.gz
mv-b9fca023460563d66c2f3c0dc2d77f0752b72e46.tar.bz2
mv-b9fca023460563d66c2f3c0dc2d77f0752b72e46.zip
sys-kernel/kernel: Version bump
Diffstat (limited to 'sys-kernel/kernel/kernel-4.3.ebuild')
-rw-r--r--sys-kernel/kernel/kernel-4.3.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/sys-kernel/kernel/kernel-4.3.ebuild b/sys-kernel/kernel/kernel-4.3.ebuild
new file mode 100644
index 00000000..36896207
--- /dev/null
+++ b/sys-kernel/kernel/kernel-4.3.ebuild
@@ -0,0 +1,43 @@
+# Copyright 2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+RESTRICT="mirror"
+inherit eutils
+
+DESCRIPTION="A POSIX shell script to compile the kernel with user permissions"
+HOMEPAGE="https://github.com/vaeth/kernel/"
+SRC_URI="https://github.com/vaeth/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+# This should really depend on a USE-flag but must not by policy.
+# Waiting for https://bugs.gentoo.org/show_bug.cgi?id=424283
+OPTIONAL_RDEPEND=">=app-shells/runtitle-2.3"
+
+RDEPEND="app-admin/sudo
+ app-admin/sudox
+ >=app-shells/push-2.0-r2
+ !<dev-util/ccache-3.2
+ ${OPTIONAL_RDEPEND}"
+DEPEND=""
+
+src_prepare() {
+ use prefix || sed -i \
+ -e '1s"^#!/usr/bin/env sh$"#!'"${EPREFIX}/bin/sh"'"' \
+ -- bin/* || die
+ eapply_user
+}
+
+src_install() {
+ dobin bin/*
+ insinto /usr/share/zsh/site-functions
+ doins zsh/*
+}
+
+pkg_postinst() {
+ optfeature "faster execution" '>=app-portage/eix-0.32.2'
+}