summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Väth <martin@mvath.de>2021-06-12 20:53:35 +0200
committerMartin Väth <martin@mvath.de>2021-06-12 20:53:35 +0200
commit04236776ea7bed5d4e9820026b01f46a46278083 (patch)
treedbb2db2b17f3b42c2a6cb1df625726388ff9ae47 /sys-kernel/kernel/kernel-6.3.ebuild
parentapp-portage/eix: Version bump (diff)
downloadmv-04236776ea7bed5d4e9820026b01f46a46278083.tar.gz
mv-04236776ea7bed5d4e9820026b01f46a46278083.tar.bz2
mv-04236776ea7bed5d4e9820026b01f46a46278083.zip
sys-kernel/kernel: Version bump
Signed-off-by: Martin Väth <martin@mvath.de>
Diffstat (limited to 'sys-kernel/kernel/kernel-6.3.ebuild')
-rw-r--r--sys-kernel/kernel/kernel-6.3.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/sys-kernel/kernel/kernel-6.3.ebuild b/sys-kernel/kernel/kernel-6.3.ebuild
new file mode 100644
index 00000000..4879fa8d
--- /dev/null
+++ b/sys-kernel/kernel/kernel-6.3.ebuild
@@ -0,0 +1,43 @@
+# Copyright 2011-2021 Martin V\"ath
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+RESTRICT="mirror"
+inherit optfeature
+
+DESCRIPTION="A POSIX shell script to compile the kernel with user permissions"
+HOMEPAGE="https://github.com/vaeth/kernel/"
+SRC_URI="https://github.com/vaeth/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~x64-cygwin ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+# This should really depend on a USE-flag but must not by policy.
+# Waiting for https://bugs.gentoo.org/show_bug.cgi?id=424283
+OPTIONAL_RDEPEND=">=app-shells/runtitle-2.3"
+
+RDEPEND="app-admin/sudo
+ app-admin/sudox
+ >=app-shells/push-2.0-r2
+ !<dev-util/ccache-3.2
+ ${OPTIONAL_RDEPEND}"
+DEPEND=""
+
+src_prepare() {
+ use prefix || sed -i \
+ -e '1s"^#!/usr/bin/env sh$"#!'"${EPREFIX}/bin/sh"'"' \
+ -- bin/* || die
+ default
+}
+
+src_install() {
+ dobin bin/*
+ insinto /usr/share/zsh/site-functions
+ doins zsh/*
+}
+
+pkg_postinst() {
+ optfeature "faster execution" '>=app-portage/eix-0.32.2'
+}