summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Väth <martin@mvath.de>2014-09-22 17:05:00 +0200
committerMartin Väth <martin@mvath.de>2015-10-11 10:49:18 +0200
commitabef8a182f273d23442f80125a379f667486bc19 (patch)
tree773ae0586a2ca5877ecdc8c9ee39f02aead78b43 /sys-process/systemd-cron/systemd-cron-1.3.1.ebuild
parentAdd File-lchown, ExtUtils-CChecker. Udate mv_perl. Fix lesspipe (diff)
downloadmv-abef8a182f273d23442f80125a379f667486bc19.tar.gz
mv-abef8a182f273d23442f80125a379f667486bc19.tar.bz2
mv-abef8a182f273d23442f80125a379f667486bc19.zip
Bump noscript, systemd-cron
Diffstat (limited to 'sys-process/systemd-cron/systemd-cron-1.3.1.ebuild')
-rw-r--r--sys-process/systemd-cron/systemd-cron-1.3.1.ebuild56
1 files changed, 56 insertions, 0 deletions
diff --git a/sys-process/systemd-cron/systemd-cron-1.3.1.ebuild b/sys-process/systemd-cron/systemd-cron-1.3.1.ebuild
new file mode 100644
index 00000000..fd76e62f
--- /dev/null
+++ b/sys-process/systemd-cron/systemd-cron-1.3.1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+RESTRICT="mirror"
+PYTHON_COMPAT=( pypy python{2_7,3_3,3_4} )
+inherit eutils python-single-r1 systemd
+
+DESCRIPTION="systemd units to provide minimal cron daemon functionality by running scripts in cron directories"
+HOMEPAGE="https://github.com/dbent/systemd-cron/"
+SRC_URI="https://github.com/dbent/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="cron-boot yearly"
+
+RDEPEND=">=sys-apps/systemd-212
+ sys-apps/debianutils"
+DEPEND=""
+
+src_prepare() {
+ python_setup
+ python_fix_shebang "${S}/src/bin"
+ sed -i \
+ -e 's/^crontab/crontab-systemd/' \
+ "${S}/src/man/crontab.1.in"
+ epatch_user
+}
+
+my_use_enable() {
+ if use ${1}
+ then echo --enable-${2:-${1}}=yes
+ else echo --enable-${2:-${1}}=no
+ fi
+}
+
+src_configure() {
+ ./configure \
+ --prefix="${EPREFIX}" \
+ --runparts="${EPREFIX}/bin/run-parts" \
+ --mandir="${EPREFIX}/usr/share/man" \
+ --unitdir="$(systemd_get_unitdir)" \
+ $(my_use_enable cron-boot boot) \
+ $(my_use_enable yearly) \
+ --enable-persistent=yes
+}
+
+src_install() {
+ emake DESTDIR="${ED}" install
+ dodoc LICENSE
+ mv "${ED}"/bin/crontab{,-systemd} || die
+ mv "${ED}"/usr/share/man/man1/crontab{,-systemd}.1 || die
+ mv "${ED}"/usr/share/man/man5/crontab{,-systemd}.5 || die
+}