summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Väth <martin@mvath.de>2016-12-18 15:01:28 +0100
committerMartin Väth <martin@mvath.de>2016-12-18 15:01:28 +0100
commit5d86718a21e6349e877b652134a76d4f53cc8513 (patch)
tree524cc896d3e4e30c279d2de5a5e68ae02009950d /sys-process
parentmedia-tv/nvtv: Add from gentoo repository to fix autotools issues (diff)
downloadmv-5d86718a21e6349e877b652134a76d4f53cc8513.tar.gz
mv-5d86718a21e6349e877b652134a76d4f53cc8513.tar.bz2
mv-5d86718a21e6349e877b652134a76d4f53cc8513.zip
sys-process/systemd-cron: Reintroduce to support python3_5. EAPI=6
Diffstat (limited to 'sys-process')
-rw-r--r--sys-process/systemd-cron/Manifest1
-rw-r--r--sys-process/systemd-cron/metadata.xml22
-rw-r--r--sys-process/systemd-cron/systemd-cron-1.5.4.ebuild72
3 files changed, 95 insertions, 0 deletions
diff --git a/sys-process/systemd-cron/Manifest b/sys-process/systemd-cron/Manifest
new file mode 100644
index 00000000..1146fe37
--- /dev/null
+++ b/sys-process/systemd-cron/Manifest
@@ -0,0 +1 @@
+DIST systemd-cron-1.5.4.tar.gz 30436 SHA256 acb99095cbef7812e556ac98574a9121c06ffdc3f28622b9dee098d81bcbbdcd
diff --git a/sys-process/systemd-cron/metadata.xml b/sys-process/systemd-cron/metadata.xml
new file mode 100644
index 00000000..d7a78e21
--- /dev/null
+++ b/sys-process/systemd-cron/metadata.xml
@@ -0,0 +1,22 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>martin@mvath.de</email>
+ <name>Martin Väth</name>
+ <description>maintainer of the updates in the mv overlay</description>
+ </maintainer>
+ <maintainer type="person">
+ <email>rich0@gentoo.org</email>
+ </maintainer>
+ <use>
+ <flag name="cron-boot">Include support for the boot timer.</flag>
+ <flag name="etc-crontab-systemd">Use dedicated /etc/crontab-systemd instead of parsing /etc/crontab</flag>
+ <flag name="minutely">Support /etc/cron.minutely</flag>
+ <flag name="yearly">Support /etc/cron.yearly</flag>
+ <flag name="setgid">Compile setgid C helper for crontab. Needs GCC or Clang.</flag>
+ </use>
+ <upstream>
+ <remote-id type="github">systemd-cron/systemd-cron</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/sys-process/systemd-cron/systemd-cron-1.5.4.ebuild b/sys-process/systemd-cron/systemd-cron-1.5.4.ebuild
new file mode 100644
index 00000000..02ef82d9
--- /dev/null
+++ b/sys-process/systemd-cron/systemd-cron-1.5.4.ebuild
@@ -0,0 +1,72 @@
+# Copyright 2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( pypy3 python3_4 python3_5 )
+inherit python-single-r1
+
+DESCRIPTION="systemd units to create timers for cron directories and crontab"
+HOMEPAGE="https://github.com/systemd-cron/systemd-cron/"
+SRC_URI="https://github.com/systemd-cron/${PN}/archive/v${PV}.tar.gz -> systemd-cron-${PV}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 ~x86"
+IUSE="cron-boot etc-crontab-systemd minutely setgid yearly"
+
+RDEPEND=">=sys-apps/systemd-217
+ sys-apps/debianutils
+ !etc-crontab-systemd? ( !sys-process/dcron )
+ ${PYTHON_DEPS}
+ sys-process/cronbase"
+
+DEPEND="sys-process/cronbase"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+src_prepare() {
+ python_fix_shebang --force "${S}/src/bin"
+
+ sed -i \
+ -e 's/^crontab/crontab-systemd/' \
+ -e 's/^CRONTAB/CRONTAB-SYSTEMD/' \
+ -- "${S}/src/man/crontab."{1,5}".in" || die
+
+ sed -i \
+ -e 's!/crontab$!/crontab-systemd!' \
+ -e 's!/crontab\(\.[15]\)$!/crontab-systemd\1!' \
+ -- "${S}/Makefile.in" || die
+
+ if use etc-crontab-systemd
+ then sed -i \
+ -e "s!/etc/crontab!/etc/crontab-systemd!" \
+ -- "${S}/src/man/crontab."{1,5}".in" \
+ "${S}/src/bin/systemd-crontab-generator.py" || die
+ fi
+
+ eapply_user
+}
+
+my_use_enable() {
+ if use ${1}; then
+ echo --enable-${2:-${1}}=yes
+ else
+ echo --enable-${2:-${1}}=no
+ fi
+}
+
+src_configure() {
+ ./configure \
+ --prefix="${EPREFIX}/usr" \
+ --confdir="${EPREFIX}/etc" \
+ --runparts="${EPREFIX}/bin/run-parts" \
+ --mandir="${EPREFIX}/usr/share/man" \
+ --unitdir="$(systemd_get_unitdir)" \
+ $(my_use_enable cron-boot boot) \
+ $(my_use_enable minutely) \
+ $(my_use_enable yearly) \
+ $(my_use_enable yearly quarterly) \
+ $(my_use_enable yearly semi_annually) \
+ $(my_use_enable setgid) \
+ --enable-persistent=yes
+}