summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Väth <martin@mvath.de>2017-07-18 05:18:12 +0200
committerMartin Väth <martin@mvath.de>2017-07-18 05:18:12 +0200
commit86f88228b56896df8437fc963a68b5f40e621ec4 (patch)
treebdee8c0a7fa0ae94516c7af664e847db425f6034 /sys-process
parentsys-fs/squashmount: Version bump (diff)
downloadmv-86f88228b56896df8437fc963a68b5f40e621ec4.tar.gz
mv-86f88228b56896df8437fc963a68b5f40e621ec4.tar.bz2
mv-86f88228b56896df8437fc963a68b5f40e621ec4.zip
sys-process/systemd-cron: Version bump. Fix libpath for split /usr
Diffstat (limited to 'sys-process')
-rw-r--r--sys-process/systemd-cron/Manifest1
-rw-r--r--sys-process/systemd-cron/systemd-cron-1.5.10.ebuild75
-rw-r--r--sys-process/systemd-cron/systemd-cron-1.5.4.ebuild8
3 files changed, 81 insertions, 3 deletions
diff --git a/sys-process/systemd-cron/Manifest b/sys-process/systemd-cron/Manifest
index 1146fe37..14489eed 100644
--- a/sys-process/systemd-cron/Manifest
+++ b/sys-process/systemd-cron/Manifest
@@ -1 +1,2 @@
+DIST systemd-cron-1.5.10.tar.gz 31191 SHA256 46872d8662e642f588f5c98c2f9540572a0862972b43f3fc76a73bdd6551a915
DIST systemd-cron-1.5.4.tar.gz 30436 SHA256 acb99095cbef7812e556ac98574a9121c06ffdc3f28622b9dee098d81bcbbdcd
diff --git a/sys-process/systemd-cron/systemd-cron-1.5.10.ebuild b/sys-process/systemd-cron/systemd-cron-1.5.10.ebuild
new file mode 100644
index 00000000..cf7a20c8
--- /dev/null
+++ b/sys-process/systemd-cron/systemd-cron-1.5.10.ebuild
@@ -0,0 +1,75 @@
+# Copyright 2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( pypy3 python3_{4,5,6} )
+inherit python-single-r1 systemd
+
+DESCRIPTION="systemd units to create timers for cron directories and crontab"
+HOMEPAGE="https://github.com/systemd-cron/systemd-cron/"
+SRC_URI="https://github.com/systemd-cron/${PN}/archive/v${PV}.tar.gz -> systemd-cron-${PV}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="cron-boot etc-crontab-systemd minutely setgid test yearly"
+
+RDEPEND=">=sys-apps/systemd-234-r1
+ sys-apps/debianutils
+ !etc-crontab-systemd? ( !sys-process/dcron )
+ ${PYTHON_DEPS}
+ sys-process/cronbase"
+
+DEPEND="sys-process/cronbase
+ test? ( sys-apps/man-db dev-python/pyflakes )"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+src_prepare() {
+ python_fix_shebang --force "${S}/src/bin"
+
+ sed -i \
+ -e 's/^crontab/crontab-systemd/' \
+ -e 's/^CRONTAB/CRONTAB-SYSTEMD/' \
+ -- "${S}/src/man/crontab."{1,5}".in" || die
+
+ sed -i \
+ -e 's!/crontab$!/crontab-systemd!' \
+ -e 's!/crontab\(\.[15]\)$!/crontab-systemd\1!' \
+ -e 's/pyflakes3/pyflakes/' \
+ -- "${S}/Makefile.in" || die
+
+ if use etc-crontab-systemd
+ then sed -i \
+ -e "s!/etc/crontab!/etc/crontab-systemd!" \
+ -- "${S}/src/man/crontab."{1,5}".in" \
+ "${S}/src/bin/systemd-crontab-generator.py" || die
+ fi
+
+ eapply_user
+}
+
+my_use_enable() {
+ if use ${1}; then
+ echo --enable-${2:-${1}}=yes
+ else
+ echo --enable-${2:-${1}}=no
+ fi
+}
+
+src_configure() {
+ ./configure \
+ --prefix="${EPREFIX}/usr" \
+ --confdir="${EPREFIX}/etc" \
+ --runparts="${EPREFIX}/bin/run-parts" \
+ --mandir="${EPREFIX}/usr/share/man" \
+ --libdir="${EPREFIX}/lib" \
+ --unitdir="$(systemd_get_systemunitdir)" \
+ $(my_use_enable cron-boot boot) \
+ $(my_use_enable minutely) \
+ $(my_use_enable yearly) \
+ $(my_use_enable yearly quarterly) \
+ $(my_use_enable yearly semi_annually) \
+ $(my_use_enable setgid) \
+ --enable-persistent=yes
+}
diff --git a/sys-process/systemd-cron/systemd-cron-1.5.4.ebuild b/sys-process/systemd-cron/systemd-cron-1.5.4.ebuild
index 186ca544..39f79da3 100644
--- a/sys-process/systemd-cron/systemd-cron-1.5.4.ebuild
+++ b/sys-process/systemd-cron/systemd-cron-1.5.4.ebuild
@@ -11,8 +11,8 @@ SRC_URI="https://github.com/systemd-cron/${PN}/archive/v${PV}.tar.gz -> systemd-
LICENSE="MIT"
SLOT="0"
-KEYWORDS="amd64 ~x86"
-IUSE="cron-boot etc-crontab-systemd minutely setgid yearly"
+KEYWORDS="amd64 x86"
+IUSE="cron-boot etc-crontab-systemd minutely setgid test yearly"
RDEPEND=">=sys-apps/systemd-217
sys-apps/debianutils
@@ -20,7 +20,8 @@ RDEPEND=">=sys-apps/systemd-217
${PYTHON_DEPS}
sys-process/cronbase"
-DEPEND="sys-process/cronbase"
+DEPEND="sys-process/cronbase
+ test? ( sys-apps/man-db dev-python/pyflakes )"
REQUIRED_USE="${PYTHON_REQUIRED_USE}"
@@ -35,6 +36,7 @@ src_prepare() {
sed -i \
-e 's!/crontab$!/crontab-systemd!' \
-e 's!/crontab\(\.[15]\)$!/crontab-systemd\1!' \
+ -e 's/pyflakes3/pyflakes/' \
-- "${S}/Makefile.in" || die
if use etc-crontab-systemd