summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Väth <martin@mvath.de>2016-12-18 16:59:33 +0100
committerMartin Väth <martin@mvath.de>2016-12-18 16:59:33 +0100
commitfea5696c5024f87c6a3b55342a1fc26eeedff4d5 (patch)
tree9a2180c97b31969a85b1e9296ea2c15d5b54be4b /sys-process
parentapp-portage/mirrorselect: Copy from gentoo to support python3_5. EAPI=6 (diff)
downloadmv-fea5696c5024f87c6a3b55342a1fc26eeedff4d5.tar.gz
mv-fea5696c5024f87c6a3b55342a1fc26eeedff4d5.tar.bz2
mv-fea5696c5024f87c6a3b55342a1fc26eeedff4d5.zip
sys-process/systemd-cron: Fix installation directory
Diffstat (limited to 'sys-process')
-rw-r--r--sys-process/systemd-cron/systemd-cron-1.5.4.ebuild4
1 files changed, 2 insertions, 2 deletions
diff --git a/sys-process/systemd-cron/systemd-cron-1.5.4.ebuild b/sys-process/systemd-cron/systemd-cron-1.5.4.ebuild
index 02ef82d9..a3605241 100644
--- a/sys-process/systemd-cron/systemd-cron-1.5.4.ebuild
+++ b/sys-process/systemd-cron/systemd-cron-1.5.4.ebuild
@@ -3,7 +3,7 @@
EAPI=6
PYTHON_COMPAT=( pypy3 python3_4 python3_5 )
-inherit python-single-r1
+inherit python-single-r1 systemd
DESCRIPTION="systemd units to create timers for cron directories and crontab"
HOMEPAGE="https://github.com/systemd-cron/systemd-cron/"
@@ -61,7 +61,7 @@ src_configure() {
--confdir="${EPREFIX}/etc" \
--runparts="${EPREFIX}/bin/run-parts" \
--mandir="${EPREFIX}/usr/share/man" \
- --unitdir="$(systemd_get_unitdir)" \
+ --unitdir="$(systemd_get_systemunitdir)" \
$(my_use_enable cron-boot boot) \
$(my_use_enable minutely) \
$(my_use_enable yearly) \