summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Väth <martin@mvath.de>2018-09-09 12:42:56 +0200
committerMartin Väth <martin@mvath.de>2018-09-09 12:42:56 +0200
commit048a4a9babbabe4ac33b11255a5d5cf65bc9caa5 (patch)
tree3aabc94694f6df34bf5cc9bd778f8f3477b372b3 /www-client
parentwww-client/firefox: add temporarily to fix virtual/cargo dependency (diff)
downloadmv-048a4a9babbabe4ac33b11255a5d5cf65bc9caa5.tar.gz
mv-048a4a9babbabe4ac33b11255a5d5cf65bc9caa5.tar.bz2
mv-048a4a9babbabe4ac33b11255a5d5cf65bc9caa5.zip
www-client/firefox: new patch from gentoo repository
Diffstat (limited to 'www-client')
-rw-r--r--www-client/firefox/files/firefox-60.0-blessings-TERM.patch56
-rw-r--r--www-client/firefox/firefox-60.2.0.ebuild12
-rw-r--r--www-client/firefox/firefox-62.0-r1.ebuild5
3 files changed, 71 insertions, 2 deletions
diff --git a/www-client/firefox/files/firefox-60.0-blessings-TERM.patch b/www-client/firefox/files/firefox-60.0-blessings-TERM.patch
new file mode 100644
index 00000000..3d024a47
--- /dev/null
+++ b/www-client/firefox/files/firefox-60.0-blessings-TERM.patch
@@ -0,0 +1,56 @@
+https://github.com/erikrose/blessings/pull/137
+
+Fixes: https://bugs.gentoo.org/654316
+
+From 5fefc65c306cf9ec492e7b422d6bb4842385afbc Mon Sep 17 00:00:00 2001
+From: Jay Kamat <jaygkamat@gmail.com>
+Date: Fri, 24 Aug 2018 11:11:57 -0700
+Subject: [PATCH 1/2] Fix error when TERM is unset or improperly set
+
+---
+ blessings/__init__.py | 9 +++++++--
+ 1 file changed, 7 insertions(+), 2 deletions(-)
+
+diff --git a/blessings/__init__.py b/blessings/__init__.py
+index 98b75c3..3872b5f 100644
+--- a/third_party/python/blessings/blessings/__init__.py
++++ b/third_party/python/blessings/blessings/__init__.py
+@@ -94,8 +94,13 @@ def __init__(self, kind=None, stream=None, force_styling=False):
+ # init sequences to the stream if it has a file descriptor, and
+ # send them to stdout as a fallback, since they have to go
+ # somewhere.
+- setupterm(kind or environ.get('TERM', 'unknown'),
+- self._init_descriptor)
++ try:
++ setupterm(kind or environ.get('TERM', 'dumb') or 'dumb',
++ self._init_descriptor)
++ except:
++ # There was an error setting up the terminal, either curses is
++ # not supported or TERM is incorrectly set. Fall back to dumb.
++ self._does_styling = False
+
+ self.stream = stream
+
+
+From d885df78c6f931abf3259343aaaa897e16c8cba1 Mon Sep 17 00:00:00 2001
+From: Jay Kamat <jaygkamat@gmail.com>
+Date: Sat, 1 Sep 2018 13:20:32 -0700
+Subject: [PATCH 2/2] Explicitly catch curses.error
+
+---
+ blessings/__init__.py | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/blessings/__init__.py b/blessings/__init__.py
+index 3872b5f..fdceb09 100644
+--- a/third_party/python/blessings/blessings/__init__.py
++++ b/third_party/python/blessings/blessings/__init__.py
+@@ -97,7 +97,7 @@ def __init__(self, kind=None, stream=None, force_styling=False):
+ try:
+ setupterm(kind or environ.get('TERM', 'dumb'),
+ self._init_descriptor)
+- except:
++ except curses.error:
+ # There was an error setting up the terminal, either curses is
+ # not supported or TERM is incorrectly set. Fall back to dumb.
+ self._does_styling = False
diff --git a/www-client/firefox/firefox-60.2.0.ebuild b/www-client/firefox/firefox-60.2.0.ebuild
index ea3ee61d..b32f7700 100644
--- a/www-client/firefox/firefox-60.2.0.ebuild
+++ b/www-client/firefox/firefox-60.2.0.ebuild
@@ -35,7 +35,7 @@ inherit check-reqs flag-o-matic toolchain-funcs eutils gnome2-utils llvm \
DESCRIPTION="Firefox Web Browser"
HOMEPAGE="http://www.mozilla.com/firefox"
-KEYWORDS="~amd64 ~x86"
+KEYWORDS="amd64 x86"
SLOT="0"
LICENSE="MPL-2.0 GPL-2 LGPL-2.1"
@@ -125,7 +125,8 @@ src_prepare() {
rm "${WORKDIR}/firefox/2005_ffmpeg4.patch"
eapply "${WORKDIR}/firefox"
- eapply "${FILESDIR}/bug_1461221.patch"
+ eapply "${FILESDIR}"/bug_1461221.patch
+ eapply "${FILESDIR}"/${PN}-60.0-blessings-TERM.patch # 654316
# Enable gnomebreakpad
if use debug ; then
@@ -215,6 +216,13 @@ src_configure() {
# Only available on mozilla-overlay for experimentation -- Removed in Gentoo repo per bug 571180
#use egl && mozconfig_annotate 'Enable EGL as GL provider' --with-gl-provider=EGL
+ # Disable built-in ccache support to avoid sandbox violation, #665420
+ # Use FEATURES=ccache instead!
+ mozconfig_annotate '' --without-ccache
+ sed -i -e 's/ccache_stats = None/return None/' \
+ python/mozbuild/mozbuild/controller/building.py || \
+ die "Failed to disable ccache stats call"
+
# Setup api key for location services
echo -n "${_google_api_key}" > "${S}"/google-api-key
mozconfig_annotate '' --with-google-api-keyfile="${S}/google-api-key"
diff --git a/www-client/firefox/firefox-62.0-r1.ebuild b/www-client/firefox/firefox-62.0-r1.ebuild
index 8c43c3a2..b5658f8f 100644
--- a/www-client/firefox/firefox-62.0-r1.ebuild
+++ b/www-client/firefox/firefox-62.0-r1.ebuild
@@ -182,6 +182,8 @@ src_unpack() {
src_prepare() {
eapply "${WORKDIR}/firefox"
+ eapply "${FILESDIR}"/${PN}-60.0-blessings-TERM.patch # 654316
+
# Enable gnomebreakpad
if use debug ; then
sed -i -e "s:GNOME_DISABLE_CRASH_DIALOG=1:GNOME_DISABLE_CRASH_DIALOG=0:g" \
@@ -351,6 +353,9 @@ src_configure() {
# Disable built-in ccache support to avoid sandbox violation, #665420
# Use FEATURES=ccache instead!
mozconfig_annotate '' --without-ccache
+ sed -i -e 's/ccache_stats = None/return None/' \
+ python/mozbuild/mozbuild/controller/building.py || \
+ die "Failed to disable ccache stats call"
mozconfig_use_enable dbus