summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Väth <martin@mvath.de>2010-04-02 23:19:53 +0200
committerMartin Väth <martin@mvath.de>2015-10-11 10:45:19 +0200
commit1360c2cf3ce1116c83473789a64acb7aca60920f (patch)
tree0bff7ed2560238f5c2f4dcda201fcee024ddf899 /www-plugins/noscript
parentUpdate squash_fs without revbump (no ebuild in tarball); new autotools.eclass (diff)
downloadmv-1360c2cf3ce1116c83473789a64acb7aca60920f.tar.gz
mv-1360c2cf3ce1116c83473789a64acb7aca60920f.tar.bz2
mv-1360c2cf3ce1116c83473789a64acb7aca60920f.zip
Bump firefox-plugins. Add noscript
Diffstat (limited to 'www-plugins/noscript')
-rw-r--r--www-plugins/noscript/ChangeLog8
-rw-r--r--www-plugins/noscript/Manifest4
-rw-r--r--www-plugins/noscript/metadata.xml14
-rw-r--r--www-plugins/noscript/noscript-1.9.9.57.ebuild75
4 files changed, 101 insertions, 0 deletions
diff --git a/www-plugins/noscript/ChangeLog b/www-plugins/noscript/ChangeLog
new file mode 100644
index 00000000..3991b797
--- /dev/null
+++ b/www-plugins/noscript/ChangeLog
@@ -0,0 +1,8 @@
+# ChangeLog for www-plugins/noscript
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header $
+
+*noscript-1.9.9.57 (02 Apr 2010)
+
+ 02 Apr 2010; Martin Väth <martin@mvath.de>
+ Version bump from the portage tree; clearing previous ChangeLog.
diff --git a/www-plugins/noscript/Manifest b/www-plugins/noscript/Manifest
new file mode 100644
index 00000000..cdf9955e
--- /dev/null
+++ b/www-plugins/noscript/Manifest
@@ -0,0 +1,4 @@
+DIST noscript-1.9.9.57.xpi 466150 RMD160 477cf0b9f46d40f8b7c59219f40bd467d4272cb2 SHA1 f7d3e6a1c6e4b887af391929e81aaed05b3ebc8e SHA256 226d4ec3d022d5ee5309ec0891745c2a8bc0506b17fb52a5adb72908aaac71f8
+EBUILD noscript-1.9.9.57.ebuild 2123 RMD160 91b4d707d89f1cfb10437bf29d4d559bfa05fc93 SHA1 db8203d058853132199cbcfe3da22aa483acd13a SHA256 c5d959ec7825d81229ac208b8d44acb86d22d3bd1557424a4064d133d1f6e801
+MISC ChangeLog 285 RMD160 144f22770508d78bb67a367c66dcb3a9691907f2 SHA1 19d573d172b78f5cbf68b5e9494a3e1e94171153 SHA256 00d000ab072df18a69437e092a5ae5bcbe34fb4663ac3feb4320692654e606bb
+MISC metadata.xml 457 RMD160 0dc8a6d2852f0253b9d01dfd20b3062bbe6af7dd SHA1 b7434144492d8517cf07306a65d6b9e013092c3b SHA256 6a60a819f504e9082841faecba17f77bbfbeaa8cde3fc34cee9d0f51cd3fab93
diff --git a/www-plugins/noscript/metadata.xml b/www-plugins/noscript/metadata.xml
new file mode 100644
index 00000000..918a3283
--- /dev/null
+++ b/www-plugins/noscript/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>no-herd</herd>
+ <maintainer>
+ <email>martin@mvath.de</email>
+ <name>Martin Väth</name>
+ </maintainer>
+</pkgmetadata>
+<longdescription lang="en">Noscript is a plugin for firefox that handles
+javascript in webpages. Giving you full control over their ability to run.
+</longdescription>
+</pkgmetadata>
+
diff --git a/www-plugins/noscript/noscript-1.9.9.57.ebuild b/www-plugins/noscript/noscript-1.9.9.57.ebuild
new file mode 100644
index 00000000..1c6ed319
--- /dev/null
+++ b/www-plugins/noscript/noscript-1.9.9.57.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-plugins/noscript/noscript-1.9.8.86.ebuild,v 1.3 2010/01/01 18:03:23 scarabeus Exp $
+
+inherit mozextension multilib
+
+DESCRIPTION="Restrict active contents in your web browser"
+HOMEPAGE="http://noscript.net/"
+SRC_URI="http://software.informaction.com/data/releases/${P}.xpi"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ || (
+ >=www-client/mozilla-firefox-1.5
+ >=www-client/firefox-bin-1.5
+ >=www-client/seamonkey-1.1
+ >=www-client/seamonkey-bin-1.1
+ >=www-client/icecat-3.5
+ )"
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}
+
+# NOTES:
+# can also be used for Flock, MidBrowser, eMusic, Toolkit, Songbird, Fennec
+
+src_unpack() {
+ xpi_unpack "${P}".xpi
+}
+
+src_install() {
+ local MOZILLA_FIVE_HOME
+ mozillas=""
+
+ if has_version '>=www-client/mozilla-firefox-1.5'; then
+ MOZILLA_FIVE_HOME="/usr/$(get_libdir)/mozilla-firefox"
+ xpi_install "${WORKDIR}/${P}"
+ mozillas="$(best_version www-client/mozilla-firefox) ${mozillas}"
+ fi
+ if has_version '>=www-client/firefox-bin-1.5'; then
+ MOZILLA_FIVE_HOME="/opt/firefox"
+ xpi_install "${WORKDIR}/${P}"
+ mozillas="$(best_version www-client/firefox-bin) ${mozillas}"
+ fi
+ if has_version '>=www-client/seamonkey-1.1'; then
+ MOZILLA_FIVE_HOME="/usr/$(get_libdir)/seamonkey"
+ xpi_install "${WORKDIR}/${P}"
+ mozillas="$(best_version www-client/seamonkey) ${mozillas}"
+ fi
+ if has_version '>=www-client/seamonkey-bin-1.1'; then
+ MOZILLA_FIVE_HOME="/opt/seamonkey"
+ xpi_install "${WORKDIR}/${P}"
+ mozillas="$(best_version www-client/seamonkey-bin) ${mozillas}"
+ fi
+ if has_version '>=www-client/icecat-3.5'; then
+ MOZILLA_FIVE_HOME="/usr/$(get_libdir)/icecat"
+ xpi_install "${WORKDIR}/${P}"
+ mozillas="$(best_version www-client/icecat) ${mozillas}"
+ fi
+
+}
+
+pkg_postinst() {
+ elog "NoScript has been installed for the following packages:"
+ for i in ${mozillas}; do
+ elog " $i"
+ done
+ elog
+ elog "After installing other mozilla ebuilds, if you want to use noscript with them"
+ elog "reinstall www-plugins/noscript"
+}