summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Väth <martin@mvath.de>2010-03-28 12:13:38 +0200
committerMartin Väth <vaeth@mathematik.uni-wuerzburg.de>2010-03-28 12:13:38 +0200
commit3c20a4557767ea27aef7df1f4443dada90d06138 (patch)
treeb8bf2e2934314313ed99330577d4906b79d8f5aa /www-plugins/stylish
downloadmv-3c20a4557767ea27aef7df1f4443dada90d06138.tar.gz
mv-3c20a4557767ea27aef7df1f4443dada90d06138.tar.bz2
mv-3c20a4557767ea27aef7df1f4443dada90d06138.zip
Import of the mv overlay
Diffstat (limited to 'www-plugins/stylish')
-rw-r--r--www-plugins/stylish/ChangeLog7
-rw-r--r--www-plugins/stylish/Manifest4
-rw-r--r--www-plugins/stylish/metadata.xml9
-rw-r--r--www-plugins/stylish/stylish-1.0.7.ebuild50
4 files changed, 70 insertions, 0 deletions
diff --git a/www-plugins/stylish/ChangeLog b/www-plugins/stylish/ChangeLog
new file mode 100644
index 00000000..05d9a920
--- /dev/null
+++ b/www-plugins/stylish/ChangeLog
@@ -0,0 +1,7 @@
+# ChangeLog for www-plugins/stylish
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header $
+
+ 28 Mar 2010; Martin Väth <martin@mvath.de>
+ stylish-1.0.7.ebuild:
+ import with minor changes from a personal overlay.
diff --git a/www-plugins/stylish/Manifest b/www-plugins/stylish/Manifest
new file mode 100644
index 00000000..7f2394c2
--- /dev/null
+++ b/www-plugins/stylish/Manifest
@@ -0,0 +1,4 @@
+DIST stylish-1.0.7-fx+tb+sm.xpi 139048 RMD160 1721e9bea591f683c6b6c5555f9d93d8098c692a SHA1 000803899a6c690907ca20064c9845b20a4878f5 SHA256 18dcbf5e13f4b4d0db03b4b033dc181b4f2daef116ed68864c831ab9fae96ae2
+EBUILD stylish-1.0.7.ebuild 1412 RMD160 a72337e99bc8c1e1eb12056851166f15b226aa0c SHA1 6b15ee748fe5ab357c74e4899f7feb1f6c0a0a88 SHA256 c092281c504e8726dd4897781df04a0eda4d5026de39754cc46bb852bce3a3c3
+MISC ChangeLog 260 RMD160 ca82572e6b200d6a8a218292746f40045541ccec SHA1 a77050f5e5a0a3327a567dc49277eecefb2ea039 SHA256 3b42c54cdb7cff00049b3ff25f59846d2922462df30617314a112c73e5a9bfd6
+MISC metadata.xml 274 RMD160 a46806846cb114b1d2889ac05c409164bc276800 SHA1 ec26b2018eda8c918c3d1b2ef99d7a8ba4b70dfe SHA256 b0e2d9479aa7d1b3025efa320ddc30ee2e2df365c159b0bfec02b8019d2628d8
diff --git a/www-plugins/stylish/metadata.xml b/www-plugins/stylish/metadata.xml
new file mode 100644
index 00000000..0366721c
--- /dev/null
+++ b/www-plugins/stylish/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>no-herd</herd>
+ <maintainer>
+ <email>martin@mvath.de</email>
+ <name>Martin Väth</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/www-plugins/stylish/stylish-1.0.7.ebuild b/www-plugins/stylish/stylish-1.0.7.ebuild
new file mode 100644
index 00000000..0e9d4a66
--- /dev/null
+++ b/www-plugins/stylish/stylish-1.0.7.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header $
+
+EAPI="1"
+inherit mozextension multilib
+RESTRICT="mirror"
+
+DESCRIPTION="Firefox plugin to modify style of certain web pages, in particular of gentoo forums"
+HOMEPAGE="https://addons.mozilla.org/firefox/addon/2108"
+MY_P="${P}-fx+tb+sm"
+FILENAME="${MY_P}.xpi"
+SRC_URI="https://addons.mozilla.org/de/firefox/downloads/latest/2108/${FILENAME}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="|| (
+ >=www-client/mozilla-firefox-bin-1.5.0.7
+ >=www-client/mozilla-firefox-1.5.0.7
+)"
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}
+
+src_unpack() {
+ xpi_unpack "${FILENAME}"
+}
+
+src_install() {
+ declare MOZILLA_FIVE_HOME
+ if has_version '>=www-client/mozilla-firefox-1.5.0.7'; then
+ MOZILLA_FIVE_HOME="/usr/$(get_libdir)/mozilla-firefox"
+ xpi_install "${S}"/"${MY_P}"
+ fi
+ if has_version '>=www-client/mozilla-firefox-bin-1.5.0.7'; then
+ MOZILLA_FIVE_HOME="/opt/firefox"
+ xpi_install "${S}"/"${MY_P}"
+ fi
+}
+
+src_postinstall() {
+ einfo "You will probably want to setup the \"Darker forum\" style."
+ einfo "The old version could be found at"
+ einfo " http://jesgue.homelinux.org/other-files/dark-gentoo-forums.css"
+ einfo "but now it is easier to serve with javascript activated to"
+ einfo " http://userstyles.org/users/8172"
+ einfo "Note that you have to temporarily disable noscript for that site."
+}