summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Väth <martin@mvath.de>2016-09-03 13:46:16 +0200
committerMartin Väth <martin@mvath.de>2016-09-03 13:46:16 +0200
commitcde67cc1cdfed91c233555b03a4231e24b5462cb (patch)
tree80bbb99f14e8d25e06c1d58c0fd706257e832e7e /x11-misc/redshift/redshift-1.8.ebuild
parentapp-admin/flexlm: Copy from gentoo repository to save from removal (diff)
downloadmv-cde67cc1cdfed91c233555b03a4231e24b5462cb.tar.gz
mv-cde67cc1cdfed91c233555b03a4231e24b5462cb.tar.bz2
mv-cde67cc1cdfed91c233555b03a4231e24b5462cb.zip
x11-misc/redshift: Copy old from gentoo repo to aovid gtk+3/introspection dep
Diffstat (limited to 'x11-misc/redshift/redshift-1.8.ebuild')
-rw-r--r--x11-misc/redshift/redshift-1.8.ebuild78
1 files changed, 78 insertions, 0 deletions
diff --git a/x11-misc/redshift/redshift-1.8.ebuild b/x11-misc/redshift/redshift-1.8.ebuild
new file mode 100644
index 00000000..1c5bb3b7
--- /dev/null
+++ b/x11-misc/redshift/redshift-1.8.ebuild
@@ -0,0 +1,78 @@
+# Copyright 2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+RESTRICT="mirror"
+PYTHON_COMPAT=( python{2_6,2_7} )
+
+inherit autotools gnome2-utils python-r1
+
+DESCRIPTION="A screen color temperature adjusting software"
+HOMEPAGE="http://jonls.dk/redshift/"
+SRC_URI="https://github.com/jonls/redshift/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="geoclue gnome gtk nls"
+
+COMMON_DEPEND=">=x11-libs/libX11-1.4
+ x11-libs/libXxf86vm
+ x11-libs/libxcb
+ geoclue? ( app-misc/geoclue:0 )
+ gnome? ( dev-libs/glib:2
+ >=gnome-base/gconf-2 )
+ gtk? ( ${PYTHON_DEPS} )"
+RDEPEND="${COMMON_DEPEND}
+ gtk? ( >=dev-python/pygtk-2[${PYTHON_USEDEP}]
+ dev-python/pyxdg[${PYTHON_USEDEP}] )"
+DEPEND="${COMMON_DEPEND}
+ nls? ( sys-devel/gettext )"
+
+src_prepare() {
+ eapply_user
+ eautoreconf
+}
+
+src_configure() {
+ python_setup
+
+ econf \
+ --disable-silent-rules \
+ $(use_enable nls) \
+ --enable-randr \
+ --enable-vidmode \
+ --disable-wingdi \
+ $(use_enable gnome gnome-clock) \
+ $(use_enable geoclue) \
+ $(use_enable gtk gui) \
+ --disable-ubuntu
+}
+
+_impl_specific_src_install() {
+ emake DESTDIR="${D}" pythondir="$(python_get_sitedir)" \
+ -C src/redshift-gtk install
+}
+
+src_install() {
+ default
+
+ if use gtk; then
+ python_foreach_impl _impl_specific_src_install
+ python_replicate_script "${D}"/usr/bin/redshift-gtk
+ fi
+
+ dosym redshift-gtk /usr/bin/gtk-redshift
+}
+
+pkg_preinst() {
+ use gtk && gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ use gtk && gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ use gtk && gnome2_icon_cache_update
+}