summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Väth <martin@mvath.de>2021-05-07 13:35:59 +0200
committerMartin Väth <martin@mvath.de>2021-05-07 13:35:59 +0200
commitcc28e9cf8703da7a20313a19a097b1458e2cafd0 (patch)
tree326cefde5d5a877de6694a9ed72d2710e950212c /x11-themes/fvwm-crystal
parentvirtual/freedesktop-icon-theme: Revision bump (diff)
downloadmv-cc28e9cf8703da7a20313a19a097b1458e2cafd0.tar.gz
mv-cc28e9cf8703da7a20313a19a097b1458e2cafd0.tar.bz2
mv-cc28e9cf8703da7a20313a19a097b1458e2cafd0.zip
python:3.9 and python:3.10
Signed-off-by: Martin Väth <martin@mvath.de>
Diffstat (limited to 'x11-themes/fvwm-crystal')
-rw-r--r--x11-themes/fvwm-crystal/Manifest1
-rw-r--r--x11-themes/fvwm-crystal/fvwm-crystal-3.6.5.ebuild82
-rw-r--r--x11-themes/fvwm-crystal/metadata.xml27
3 files changed, 110 insertions, 0 deletions
diff --git a/x11-themes/fvwm-crystal/Manifest b/x11-themes/fvwm-crystal/Manifest
new file mode 100644
index 00000000..22e9dbe5
--- /dev/null
+++ b/x11-themes/fvwm-crystal/Manifest
@@ -0,0 +1 @@
+DIST fvwm-crystal-3.6.5.tar.gz 5899049 BLAKE2B addd82dbbab9b457a94715a969a27ff6ef2be07cddd33a379dc4d5348c9565d3a19943828b068ec5ef5f6d032f51b77a1990316ee7b3e16e5dc98ddf32f98c7d SHA512 45cd99b83342e5e5f0de89edc92dbba3311efc7ef431d509490e3fd5b49420e94d1cef55865f45e731fd4c13172c6e2d26fbd10107cdb4a4f525379e17b94e6d
diff --git a/x11-themes/fvwm-crystal/fvwm-crystal-3.6.5.ebuild b/x11-themes/fvwm-crystal/fvwm-crystal-3.6.5.ebuild
new file mode 100644
index 00000000..4f8d7633
--- /dev/null
+++ b/x11-themes/fvwm-crystal/fvwm-crystal-3.6.5.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8,9,10} )
+inherit readme.gentoo-r1 python-single-r1
+
+DESCRIPTION="Configurable FVWM theme with transparency and freedesktop compatible menu"
+HOMEPAGE="http://fvwm-crystal.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="amd64 ~ppc ~ppc64 x86"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+IUSE=""
+
+case ${PV} in
+*9999)
+ inherit subversion
+ ESVN_REPO_URI="svn://svn.code.sf.net/p/fvwm-crystal/code"
+ SRC_URI=""
+ S="${WORKDIR}/${PN}"
+ src_unpack() {
+ subversion_src_unpack
+ };;
+esac
+
+RDEPEND="${PYTHON_DEPS}
+ acct-group/fvwm-crystal
+ >=x11-wm/fvwm-2.6.9[png]
+ virtual/imagemagick-tools
+ || ( >=x11-misc/stalonetray-0.6.2-r2 x11-misc/trayer )
+ || ( x11-misc/hsetroot media-gfx/feh )
+ sys-apps/sed
+ sys-devel/bc
+ virtual/awk
+ x11-apps/xwd
+ media-sound/alsa-utils"
+
+DISABLE_AUTOFORMATTING="true"
+DOC_CONTENTS="After a first time installation, execute the following commands:
+ $ cp -r "${EROOT}"/usr/share/doc/"${PF}"/addons/Xresources ~/.Xresources
+ $ cp -r "${EROOT}"/usr/share/doc/"${PF}"/addons/Xsession ~/.xinitrc
+You can edit these files at your convenience.
+
+Many applications can extend functionality of fvwm-crystal.
+They are listed in "${EROOT}"/usr/share/doc/"${PF}"/INSTALL.*
+
+To be able to use the exit menu, each user using ${PN}
+must be in the group fvwm-crystal.
+You can do that as root with:
+ $ useradd -G fvwm-crystal <user_name>
+and log out and in again.
+"
+
+src_install() {
+ emake DESTDIR="${ED}" \
+ docdir="${EPREFIX}/usr/share/doc/${PF}" \
+ prefix="${EPREFIX}/usr" \
+ install
+ # GNU License is globally in the portage tree
+ rm -vf "${ED}/usr/share/doc/${PF}"/LICENSE
+
+ python_doscript "${ED}/usr/bin/${PN}".{apps,wallpaper}
+ python_scriptinto "/usr/share/${PN}"/fvwm/scripts/FvwmMPD
+ python_doscript "${ED}/usr/share/${PN}"/fvwm/scripts/FvwmMPD/*.py
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ readme.gentoo_print_elog
+ elog "Many applications can extend functionality of fvwm-crystal."
+ elog "They are listed in ${EROOT}/usr/share/doc/${PF}/INSTALL.bz2"
+ elog "Popular supported softwares are:"
+ elog "- x11-misc/xdg-user-dirs (the gtk USE is not needed) to"
+ elog " get localized XDG user directories support"
+ elog "- sys-apps/systemd for hibernate/resume support"
+ elog "- media-sound/jack-audio-connection-kit for a professional sound server"
+ elog "- several media players"
+}
diff --git a/x11-themes/fvwm-crystal/metadata.xml b/x11-themes/fvwm-crystal/metadata.xml
new file mode 100644
index 00000000..c77a6de3
--- /dev/null
+++ b/x11-themes/fvwm-crystal/metadata.xml
@@ -0,0 +1,27 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person" proxied="yes">
+ <email>dominique.c.michel@gmail.com</email>
+ <name>Dominique Michel</name>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <longdescription>
+FVWM-Crystal is a set of configuration files for FVWM window manager,
+with additional programs and scripts. Some of it's features are:
+ * quick launching of a terminal with just one click on a desktop
+ * a specially configured terminal window, similar to a console from FPP games
+ * builtin control over XMMS player and over aumix mixer from the keyboard and
+ buttons on the screen
+ * very good ability to control the desktop from the keyboard, including window
+ switching, moving, shading/unshading, maximizing, resizing, moving between
+ desktop pages
+ * transparent window titlebars, menus and panels on the desktop
+</longdescription>
+ <upstream>
+ <remote-id type="sourceforge">fvwm-crystal</remote-id>
+ </upstream>
+</pkgmetadata>