summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-emacs/mv_emacs/ChangeLog5
-rw-r--r--app-emacs/mv_emacs/Manifest2
-rw-r--r--app-emacs/mv_emacs/mv_emacs-1.1-r1.ebuild52
-rw-r--r--app-emacs/mv_emacs/mv_emacs-1.1.ebuild28
-rw-r--r--app-portage/eix/eix-99999999.ebuild2
-rw-r--r--dev-cpp/cpplint/Manifest4
-rw-r--r--dev-cpp/cpplint/cpplint-3.199.ebuild74
7 files changed, 137 insertions, 30 deletions
diff --git a/app-emacs/mv_emacs/ChangeLog b/app-emacs/mv_emacs/ChangeLog
index 3d551b58..9374a4c9 100644
--- a/app-emacs/mv_emacs/ChangeLog
+++ b/app-emacs/mv_emacs/ChangeLog
@@ -2,6 +2,11 @@
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+*mv_emacs-1.1-r1 (24 Jul 2012)
+
+ 24 Jul 2012; Martin Väth <martin@mvath.de>
+ Add site file
+
*mv_emacs-1.1 (29 Jun 2012)
29 Jun 2012; Martin Väth <martin@mvath.de>
diff --git a/app-emacs/mv_emacs/Manifest b/app-emacs/mv_emacs/Manifest
index 48224efe..ee84dbcc 100644
--- a/app-emacs/mv_emacs/Manifest
+++ b/app-emacs/mv_emacs/Manifest
@@ -1 +1 @@
-DIST mv_emacs-1.1.tar.gz 17887 RMD160 580d1cd9137f166914284cb1546a88f38b0e73fc SHA1 229928ea33ca7ef029c35dc82a686fce2f38bbd0 SHA256 d722279743c77ee2e6ded5ac9e7f7e2e4d173a41a469559b9daf31828e1f2617
+DIST mv_emacs-1.1.tar.gz 17887 SHA256 d722279743c77ee2e6ded5ac9e7f7e2e4d173a41a469559b9daf31828e1f2617 SHA512 22e97ce8bf40cea7e8946facfb607185c64d06e318ff3dd8fe49dd2c73e65bc315880e8b34edb0ae731d9348ae16d66781ec5cd58fa3f835899e3d888eec4f1c WHIRLPOOL c0e80b1e6f8247e6a4889f49aa0274c4604c89354cfc336289b1fb80085e947edafc63693a6b68f3907294a5863b207a6854ee0b8f74856aa62e62da34160c48
diff --git a/app-emacs/mv_emacs/mv_emacs-1.1-r1.ebuild b/app-emacs/mv_emacs/mv_emacs-1.1-r1.ebuild
new file mode 100644
index 00000000..48d5d427
--- /dev/null
+++ b/app-emacs/mv_emacs/mv_emacs-1.1-r1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="4"
+RESTRICT="mirror"
+inherit elisp-common eutils vcs-snapshot
+
+DESCRIPTION="A collection of perl scripts (replacement in files, syncing dirs etc)"
+HOMEPAGE="https://github.com/vaeth/mv_emacs/"
+SRC_URI="http://github.com/vaeth/${PN}/tarball/release-${PV} -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="virtual/emacs"
+RDEPEND=${DEPEND}
+
+src_unpack() {
+ vcs-snapshot_src_unpack
+ cd "${S}"
+ mkdir sitefile
+ cat >"sitefile/50${PN}-gentoo.el" <<EOF
+(add-to-list 'load-path "@SITELISP@")
+(load "mv_emacs-autoloads")
+EOF
+}
+
+src_prepare() {
+ epatch_user
+}
+
+src_compile() {
+ elisp-make-autoload-file || die
+ elisp-compile *.el || die
+}
+
+src_install() {
+ dodoc README
+ elisp-install "${PN}" *.el *.elc || die
+ elisp-site-file-install "sitefile/50${PN}-gentoo.el" || die
+}
+
+pkg_postinst() {
+ elisp-site-regen
+}
+
+pkg_postrm() {
+ elisp-site-regen
+}
diff --git a/app-emacs/mv_emacs/mv_emacs-1.1.ebuild b/app-emacs/mv_emacs/mv_emacs-1.1.ebuild
deleted file mode 100644
index 5912133d..00000000
--- a/app-emacs/mv_emacs/mv_emacs-1.1.ebuild
+++ /dev/null
@@ -1,28 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: $
-
-EAPI="4"
-RESTRICT="mirror"
-inherit eutils elisp-common vcs-snapshot
-
-DESCRIPTION="A collection of perl scripts (replacement in files, syncing dirs etc)"
-HOMEPAGE="https://github.com/vaeth/mv_emacs/"
-SRC_URI="http://github.com/vaeth/${PN}/tarball/release-${PV} -> ${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-PDEPEND="virtual/emacs"
-
-src_prepare() {
- epatch_user
-}
-
-src_install() {
- insinto "${SITELISP}/mv_emacs"
- doins *.el
- dodoc README
-}
diff --git a/app-portage/eix/eix-99999999.ebuild b/app-portage/eix/eix-99999999.ebuild
index 0aea6943..62a924e0 100644
--- a/app-portage/eix/eix-99999999.ebuild
+++ b/app-portage/eix/eix-99999999.ebuild
@@ -9,7 +9,7 @@ EGIT_PROJECT="${PN}.git"
[ -n "${EVCS_OFFLINE}" ] || EGIT_REPACK=true
WANT_LIBTOOL=none
PLOCALES="de ru"
-inherit eutils git-2 autotools multilib bash-completion-r1 l10n
+inherit autotools bash-completion-r1 eutils git-2 l10n multilib
DESCRIPTION="Search and query ebuilds, portage incl. local settings, ext. overlays, version changes, and more"
HOMEPAGE="http://eix.berlios.de"
diff --git a/dev-cpp/cpplint/Manifest b/dev-cpp/cpplint/Manifest
new file mode 100644
index 00000000..b6dad05f
--- /dev/null
+++ b/dev-cpp/cpplint/Manifest
@@ -0,0 +1,4 @@
+DIST cpplint-3.199.el 5800 SHA256 4ca96554c60501ddc1c9d6759ae8cb16e24019f8a74354590ea042dfb7a543be SHA512 7cbb2f587384cd7b371e8b761e937b1975924bfd23fdaaf27d1816effc9a8def2e1961a40a96d01ae16a431726f91c3a93887bccfe75440a9dde2f4ab895f8b6 WHIRLPOOL 599b8e3346037085b1b869b8cd59ca9b95afb82b79946fe0b875f2710af543239ae45995a451ea10fa62abaef4bd1f384ecfee093856ddce2936791545b83d2b
+DIST cpplint-3.199.py 133876 SHA256 90b33b3dc7aa9e5ed4a73418be83f0bb1c13e2a47ae977ee81560d5b11d799b5 SHA512 1d27b0352f6d0db084c7da28de1b647871c6eab5a442db9c55592fed758a56a11a3077c0e89ef5c03b94a4c235981d3fbfacc1a8180e9de8100c13a4f3223557 WHIRLPOOL 2d734ac2424129b068eaebe756b0a2450ab95a4edea6afff4e3f3737225a16e459cdbfbd980b7745dee8bf07e751c110671f0a470e27dbf65bd99310b7f172c0
+DIST cpplint-3.199.txt 2228 SHA256 1c0500c633b2161633abffccc942f8b18dddb04a9b099d40db09b959078044c8 SHA512 29507d5a714b08027cc6d1412639e71c206a0167b7b3fae3e8ebaf48717fc93b2838d132a5f0e327b767c138e5735cc472b6f2515cce1f932507324065563687 WHIRLPOOL 1713897d18d8795121660061c58d87bc23f39a4c7de069b37cfe6de8e837adf5d1065cedc4e54894be722df8a8a9ebd306814fd769365f03343a6c897cd86cbd
+DIST cpplint-3.199.xml 175939 SHA256 70b8fcd37ad0f8d0489adc91887c9405c66fc05d0effb532878deae78fb9e758 SHA512 0d4e98b3803146faf14edbf3b57f3760a19b9a4be1af26527ab4625e462250a5e659b593828cc69d268c6aac81326214f3192968e9fc6855037ebecdf04798f6 WHIRLPOOL cc33266a60f2d558eb8c96c443fe858e5961cde1a17a379219474f738d0335388879f89056a48a50cf7d1bc59c4fb9699160a325f89a4f59017fb81d400d7879
diff --git a/dev-cpp/cpplint/cpplint-3.199.ebuild b/dev-cpp/cpplint/cpplint-3.199.ebuild
new file mode 100644
index 00000000..2feb2f3e
--- /dev/null
+++ b/dev-cpp/cpplint/cpplint-3.199.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=4
+
+inherit elisp-common eutils
+
+DESCRIPTION="The google styleguide for C++ together with a verifyer and an emacs file"
+HOMEPAGE="http://code.google.com/p/google-styleguide/"
+SRC_URI="http://google-styleguide.googlecode.com/svn/trunk/cppguide.xml -> cpplint-${PV}.xml
+ http://google-styleguide.googlecode.com/svn/trunk/cpplint/cpplint.py -> cpplint-${PV}.py
+ http://google-styleguide.googlecode.com/svn/trunk/cpplint/README -> cpplint-${PV}.txt
+ emacs? ( http://google-styleguide.googlecode.com/svn/trunk/google-c-style.el -> cpplint-${PV}.el )"
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="emacs"
+
+EMACSNAME="google-c-style"
+COMMON="emacs? ( virtual/emacs )"
+DEPEND="${COMMON}"
+RDEPEND="dev-lang/python
+ ${COMMON}"
+
+S="${WORKDIR}"
+
+src_unpack() {
+ cp -- "${DISTDIR}/cpplint-${PV}.xml" cppguide.xml || die
+ cp -- "${DISTDIR}/cpplint-${PV}.py" cpplint.py || die
+ cp -- "${DISTDIR}/cpplint-${PV}.txt" README || die
+ if use emacs
+ then cp -- "${DISTDIR}/cpplint-${PV}.el" "${EMACSNAME}.el" || die
+ mkdir sitefile
+ cat >"sitefile/50${EMACSNAME}-gentoo.el" <<EOF
+(add-to-list 'load-path "@SITELISP@")
+(autoload 'google-set-c-style "${EMACSNAME}"
+ "Set the current buffer's c-style to Google C/C++ Programming
+ Style. Meant to be added to \`c-mode-common-hook'." t)
+(add-hook 'c-mode-common-hook 'google-set-c-style)
+
+; If you want the RETURN key to go to the next line and space over
+; to the right place, uncomment the following line
+;(add-hook 'c-mode-common-hook 'google-make-newline-indent)
+EOF
+ fi
+}
+
+src_prepare() {
+ epatch_user
+}
+
+src_compile() {
+ if use emacs
+ then elisp-compile *.el || die
+ fi
+}
+
+src_install() {
+ dobin cpplint.py
+ dodoc README cppguide.xml
+ if use emacs
+ then elisp-install "${EMACSNAME}" "${EMACSNAME}".{el,elc} || die
+ elisp-site-file-install "sitefile/50${EMACSNAME}-gentoo.el" "${EMACSNAME}" || die
+ fi
+}
+
+pkg_postinst() {
+ elisp-site-regen
+}
+
+pkg_postrm() {
+ elisp-site-regen
+}