summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-portage/eix/Manifest2
-rw-r--r--app-portage/eix/eix-0.33.3_alpha20180423.ebuild (renamed from app-portage/eix/eix-0.33.3_alpha20180325.ebuild)9
-rw-r--r--app-portage/eix/eix-99999999.ebuild9
-rw-r--r--metadata/pkg_desc_index2
4 files changed, 12 insertions, 10 deletions
diff --git a/app-portage/eix/Manifest b/app-portage/eix/Manifest
index 6d815533..f52e879d 100644
--- a/app-portage/eix/Manifest
+++ b/app-portage/eix/Manifest
@@ -1,2 +1,2 @@
DIST eix-0.33.2.tar.xz 614192 SHA512 28ca4cc57e5c7ef81feb37fa90d598e681e192c442c7446c93a442908d2a9744340f7a93c71135ec3083fb85c48a65638c8929b6e1e632464132f4320225d637
-DIST eix-0.33.3_alpha20180325.tar.gz 675563 SHA512 45606d3d9aa176b78be36cd22409824928ba2cba6a6f3085debccf076ececdc0038cb6055b5ebe29a56ff1a1c51735b8305ec42e6cf774cd9432d20f28c2c128
+DIST eix-0.33.3_alpha20180423.tar.gz 675629 SHA512 024eb3a9613db9ce4ffa772c4aafc661df6ee9f1284d513e42b28d64209e2064c1bb4480299b2c6658e32e16ec712e9c245e8ac54bdc4bacc8bbcc2c6562a8a9
diff --git a/app-portage/eix/eix-0.33.3_alpha20180325.ebuild b/app-portage/eix/eix-0.33.3_alpha20180423.ebuild
index 4fd5e569..21d33212 100644
--- a/app-portage/eix/eix-0.33.3_alpha20180325.ebuild
+++ b/app-portage/eix/eix-0.33.3_alpha20180423.ebuild
@@ -7,15 +7,17 @@ AUTOTOOLS_AUTO_DEPEND=no
MESON_AUTO_DEPEND=no
inherit autotools bash-completion-r1 meson tmpfiles
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~x64-cygwin ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
case ${PV} in
99999999*)
EGIT_REPO_URI="https://github.com/vaeth/${PN}.git"
inherit git-r3
SRC_URI=""
+ KEYWORDS=""
PROPERTIES="live";;
*)
RESTRICT="mirror"
- EGIT_COMMIT="34c3d74b342c813283fe08cd55da2a33fb1a6626"
+ EGIT_COMMIT="98babf15749eaf12b72837dc99b6736668a67921"
SRC_URI="https://github.com/vaeth/${PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
S="${WORKDIR}/${PN}-${EGIT_COMMIT}";;
esac
@@ -25,7 +27,6 @@ HOMEPAGE="https://github.com/vaeth/eix/"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS=""
PLOCALES="de ru"
IUSE="debug +dep doc +jumbo-build"
for i in ${PLOCALES}; do
@@ -43,9 +44,9 @@ DEPEND="${BOTHDEPEND}
>=dev-util/meson-0.41.0
>=dev-util/ninja-1.7.2
strong-optimization? ( >=sys-devel/gcc-config-1.9.1 )
+ nls? ( sys-devel/gettext )
)
- !meson? ( ${AUTOTOOLS_DEPEND} )
- >=sys-devel/gettext-0.19.6"
+ !meson? ( ${AUTOTOOLS_DEPEND} >=sys-devel/gettext-0.19.6 )"
pkg_setup() {
# remove stale cache file to prevent collisions
diff --git a/app-portage/eix/eix-99999999.ebuild b/app-portage/eix/eix-99999999.ebuild
index 4fd5e569..21d33212 100644
--- a/app-portage/eix/eix-99999999.ebuild
+++ b/app-portage/eix/eix-99999999.ebuild
@@ -7,15 +7,17 @@ AUTOTOOLS_AUTO_DEPEND=no
MESON_AUTO_DEPEND=no
inherit autotools bash-completion-r1 meson tmpfiles
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~x64-cygwin ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
case ${PV} in
99999999*)
EGIT_REPO_URI="https://github.com/vaeth/${PN}.git"
inherit git-r3
SRC_URI=""
+ KEYWORDS=""
PROPERTIES="live";;
*)
RESTRICT="mirror"
- EGIT_COMMIT="34c3d74b342c813283fe08cd55da2a33fb1a6626"
+ EGIT_COMMIT="98babf15749eaf12b72837dc99b6736668a67921"
SRC_URI="https://github.com/vaeth/${PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
S="${WORKDIR}/${PN}-${EGIT_COMMIT}";;
esac
@@ -25,7 +27,6 @@ HOMEPAGE="https://github.com/vaeth/eix/"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS=""
PLOCALES="de ru"
IUSE="debug +dep doc +jumbo-build"
for i in ${PLOCALES}; do
@@ -43,9 +44,9 @@ DEPEND="${BOTHDEPEND}
>=dev-util/meson-0.41.0
>=dev-util/ninja-1.7.2
strong-optimization? ( >=sys-devel/gcc-config-1.9.1 )
+ nls? ( sys-devel/gettext )
)
- !meson? ( ${AUTOTOOLS_DEPEND} )
- >=sys-devel/gettext-0.19.6"
+ !meson? ( ${AUTOTOOLS_DEPEND} >=sys-devel/gettext-0.19.6 )"
pkg_setup() {
# remove stale cache file to prevent collisions
diff --git a/metadata/pkg_desc_index b/metadata/pkg_desc_index
index b4d7fd49..71e25f46 100644
--- a/metadata/pkg_desc_index
+++ b/metadata/pkg_desc_index
@@ -21,7 +21,7 @@ app-emacs/mv_emacs 1.3: (X)Emacs extensions: block support, macrorecorder, verif
app-eselect/eselect-net 0.2: eselect module for managing network open-rc service configurations
app-misc/knapsack 7.2.1: A fast solver for the 0/1-knapsack problem with multiple knapsacks
app-misc/machine-learning-mv 1.2: Some machine learning experiments
-app-portage/eix 0.33.2-r1 0.33.3_alpha20180325 99999999: Search and query ebuilds
+app-portage/eix 0.33.2-r1 0.33.3_alpha20180423 99999999: Search and query ebuilds
app-portage/etcat 1.0.1 99999999: Updated version of an old Portage information extractor
app-portage/find_cruft 5.1: find cruft files not managed by portage
app-portage/getdelta 0.7.9-r2: dynamic deltup client