summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--games-puzzle/fish-fillets/Manifest2
-rw-r--r--games-puzzle/fish-fillets/fish-fillets-1.0.1-r1.ebuild67
-rw-r--r--games-puzzle/fish-fillets/metadata.xml19
-rw-r--r--media-gfx/ipe/Manifest1
-rw-r--r--media-gfx/ipe/ipe-7.2.7.ebuild58
-rw-r--r--media-gfx/ipe/metadata.xml17
-rw-r--r--metadata/pkg_desc_index2
-rw-r--r--profiles/use.local.desc1
8 files changed, 167 insertions, 0 deletions
diff --git a/games-puzzle/fish-fillets/Manifest b/games-puzzle/fish-fillets/Manifest
new file mode 100644
index 00000000..4f3421fb
--- /dev/null
+++ b/games-puzzle/fish-fillets/Manifest
@@ -0,0 +1,2 @@
+DIST fillets-ng-1.0.1.tar.gz 380290 SHA512 fe4a5186f94e953cbc85fe8b0ce804c881c96feda385cfc36e1840e448cf094c3d815fdbe32976a6697a855038951f97a384c277a1c52a048520e8da71136718
+DIST fillets-ng-data-1.0.0.tar.gz 146418413 SHA512 61c7fe3980510a7dbd85f4c246e7e42a0f79d8e2aacd96a0c7a14189c5dee92292efb030ac92299474162995039073288283fee0f352cf08be6975a2c86703e7
diff --git a/games-puzzle/fish-fillets/fish-fillets-1.0.1-r1.ebuild b/games-puzzle/fish-fillets/fish-fillets-1.0.1-r1.ebuild
new file mode 100644
index 00000000..3e1eb588
--- /dev/null
+++ b/games-puzzle/fish-fillets/fish-fillets-1.0.1-r1.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit autotools desktop
+
+DATA_PV="1.0.0"
+DESCRIPTION="Underwater puzzle game - find a safe way out"
+HOMEPAGE="http://fillets.sourceforge.net/"
+SRC_URI="mirror://sourceforge/fillets/fillets-ng-${PV}.tar.gz
+ mirror://sourceforge/fillets/fillets-ng-data-${DATA_PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="lua-slotted"
+
+RDEPEND="
+ >=media-libs/libsdl-1.2[sound,video]
+ >=media-libs/sdl-mixer-1.2.5[vorbis]
+ >=media-libs/sdl-image-1.2.2[png]
+ media-libs/smpeg
+ x11-libs/libX11
+ media-libs/sdl-ttf
+ dev-libs/fribidi
+ lua-slotted? ( dev-lang/lua:5.1= )
+ !lua-slotted? ( dev-lang/lua:0= )
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+"
+
+S="${WORKDIR}/fillets-ng-${PV}"
+
+src_prepare() {
+ default
+ #.mod was renamed to .fmod in lua 5.1.3 - bug #223271
+ sed -i \
+ -e 's/\.mod(/.fmod(/' \
+ $(grep -rl "\.mod\>" "${WORKDIR}"/fillets-ng-data-${DATA_PV}) \
+ || die "sed failed"
+ rm -f missing
+ mv configure.in configure.ac || die
+ if use lua-slotted; then
+ sed -i \
+ -e 's/LUAPFX=/LUAPFX=1/g' \
+ -e "s'-I.LUAPFX'-I${EROOT}/usr/include/lua5.1'" \
+ -e "s'-L.LUAPFX[^\"]*'-llua5.1'" \
+ configure.ac || die
+ fi
+ eautoreconf
+}
+
+src_configure() {
+ econf --datadir="/usr/share/${PN}"
+}
+
+src_install() {
+ default
+ insinto "/usr/share/${PN}"
+ cd "${WORKDIR}"/fillets-ng-data-${DATA_PV} || die
+ rm -f COPYING
+ einstalldocs
+ doins -r *
+ newicon images/icon.png ${PN}.png
+ make_desktop_entry fillets "Fish Fillets NG"
+}
diff --git a/games-puzzle/fish-fillets/metadata.xml b/games-puzzle/fish-fillets/metadata.xml
new file mode 100644
index 00000000..40034dc8
--- /dev/null
+++ b/games-puzzle/fish-fillets/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>martin@mvath.de</email>
+ <name>Martin Väth</name>
+ <description>maintainer for USE=lua-slotted</description>
+ </maintainer>
+ <maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">fillets</remote-id>
+ </upstream>
+ <use>
+ <flag name="lua-slotted">Support slotted lua version</flag>
+ </use>
+</pkgmetadata>
diff --git a/media-gfx/ipe/Manifest b/media-gfx/ipe/Manifest
new file mode 100644
index 00000000..3b62fd01
--- /dev/null
+++ b/media-gfx/ipe/Manifest
@@ -0,0 +1 @@
+DIST ipe-7.2.7-src.tar.gz 1561350 SHA512 01c855f77814e59c56198fd9216be61ac7b9b6de827eaa18cbd9464c6c5116ca11d2d3b64a71edee94aecafe0d731352455e476657c7d2e9a2237e0cfa1f7bf5
diff --git a/media-gfx/ipe/ipe-7.2.7.ebuild b/media-gfx/ipe/ipe-7.2.7.ebuild
new file mode 100644
index 00000000..16dd7cc2
--- /dev/null
+++ b/media-gfx/ipe/ipe-7.2.7.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+RESTRICT="mirror"
+inherit desktop flag-o-matic qmake-utils toolchain-funcs
+
+DESCRIPTION="Drawing editor for creating figures in PDF or PS formats"
+HOMEPAGE="http://ipe.otfried.org/"
+SRC_URI="https://dl.bintray.com/otfried/generic/ipe/7.2/${P}-src.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ app-text/texlive-core
+ >=dev-lang/lua-5.3:=
+ media-fonts/urw-fonts
+ media-libs/freetype:2
+ x11-libs/cairo
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+S="${WORKDIR}/${P}/src"
+
+src_prepare() {
+ filter-flags -fPIE -pie '-flto*' -fwhole-program +D_GLIBCXX_ASSERTIONS
+ sed -i \
+ -e 's/fpic/fPIC/' \
+ -e 's/moc-qt4/moc/' \
+ -e "s'\$(IPEPREFIX)/lib'\$(IPEPREFIX)/$(get_libdir)'g" \
+ -e "s'\(LUA_CFLAGS.*=\).*'\1 -I${EROOT}/usr/include/lua5.3'" \
+ -e 's/\(LUA_LIBS.*=\).*/\1 -llua5.3/' \
+ config.mak || die
+ sed -i -e 's/install -s/install/' common.mak || die
+ default
+}
+
+src_compile() {
+ emake \
+ CXX=$(tc-getCXX) \
+ IPEPREFIX="${EPREFIX}/usr" \
+ IPEDOCDIR="${EPREFIX}/usr/share/doc/${PF}/html"
+}
+
+src_install() {
+ emake install \
+ IPEPREFIX="${EPREFIX}/usr" \
+ IPEDOCDIR="${EPREFIX}/usr/share/doc/${PF}/html" \
+ INSTALL_ROOT="${ED}"
+ dodoc ../{news,readme}.txt
+ doicon ipe/icons/ipe.png
+ make_desktop_entry ipe Ipe ipe
+}
diff --git a/media-gfx/ipe/metadata.xml b/media-gfx/ipe/metadata.xml
new file mode 100644
index 00000000..6446d13a
--- /dev/null
+++ b/media-gfx/ipe/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>sci@gentoo.org</email>
+ <name>Gentoo Science Project</name>
+ </maintainer>
+ <longdescription lang="en">
+ Ipe is a drawing editor for creating figures in PDF or
+ (encapsulated) Postscript format. Ipe supports making small figures
+ for inclusion into LaTeX documents as well as making multi-page PDF
+ presentations.
+</longdescription>
+ <upstream>
+ <remote-id type="sourceforge">ipe7</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/metadata/pkg_desc_index b/metadata/pkg_desc_index
index 6a4726cf..2e0ff488 100644
--- a/metadata/pkg_desc_index
+++ b/metadata/pkg_desc_index
@@ -65,10 +65,12 @@ games-emulation/sdlmame 0.174-r2: Multiple Arcade Machine Emulator + Multi Emula
games-emulation/xmame 0.106-r4: Multiple Arcade Machine Emulator for X11
games-emulation/xmess 0.106-r3: Multiple Arcade Machine Emulator for X11
games-engines/freesci 0.6.4-r1: Sierra script interpreter for your old Sierra adventures
+games-puzzle/fish-fillets 1.0.1-r1: Underwater puzzle game - find a safe way out
games-rpg/aklabeth 1.0-r1: A remake of Richard C. Garriott's Ultima prequel
games-rpg/dsa-stats 1.0: calculate stat probabalities for the role playing game DSA - Das schwarze Auge
games-rpg/m5figur-mv 3.0: LaTeX2e character sheet layout for the Midgard Role Playing Game (Edition M5)
mail-client/alpine 2.00-r7 2.21.1: alpine is an easy to use text-based based mail and news client
+media-gfx/ipe 7.2.7: Drawing editor for creating figures in PDF or PS formats
media-gfx/pqiv 2.10.2: powerful GTK based command-line image viewer with a minimal UI
media-tv/nvtv 0.4.7-r3: TV-Out for NVidia cards
media-tv/sundtek-tv 180507.101237: Sundtek MediaTV Pro III Drivers
diff --git a/profiles/use.local.desc b/profiles/use.local.desc
index 74eb2010..7b4bf4e6 100644
--- a/profiles/use.local.desc
+++ b/profiles/use.local.desc
@@ -153,6 +153,7 @@ games-emulation/xmame:bundled-libs - Use bundled version of dev-libs/expat
games-emulation/xmame:net - Add network support
games-emulation/xmess:bundled-libs - Use bundled version of dev-libs/expat
games-emulation/xmess:net - Add network support
+games-puzzle/fish-fillets:lua-slotted - Support slotted lua version
games-rpg/m5figur-mv:examples - Compile example character sheet as PDF
mail-client/alpine:chappa - enhance alpine by applying Eduardo Chappa's patches
mail-client/alpine:onlyalpine - installs only the alpine binary, so it does not collied with app-editors/pico and/or mail-client/pine