summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-libs/osformat/Manifest1
-rw-r--r--dev-libs/osformat/metadata.xml16
-rw-r--r--dev-libs/osformat/osformat-1.0.0.ebuild21
-rw-r--r--dev-libs/osformat/osformat-999999999.ebuild36
4 files changed, 74 insertions, 0 deletions
diff --git a/dev-libs/osformat/Manifest b/dev-libs/osformat/Manifest
new file mode 100644
index 00000000..dd6ba769
--- /dev/null
+++ b/dev-libs/osformat/Manifest
@@ -0,0 +1 @@
+DIST osformat-1.0.0.tar.xz 246800 SHA256 1aa2c7669f3cb3e837daf542ca065d48ead374916dbc49bcce46971cef8a17f2
diff --git a/dev-libs/osformat/metadata.xml b/dev-libs/osformat/metadata.xml
new file mode 100644
index 00000000..d9944a43
--- /dev/null
+++ b/dev-libs/osformat/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>martin@mvath.de</email>
+ <name>Martin Väth</name>
+ </maintainer>
+ <upstream>
+ <maintainer>
+ <email>martin@mvath.de</email>
+ <name>Martin Väth</name>
+ </maintainer>
+ <bugs-to>mailto:martin@mvath.de</bugs-to>
+ <remote-id type="github">vaeth/osformat</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-libs/osformat/osformat-1.0.0.ebuild b/dev-libs/osformat/osformat-1.0.0.ebuild
new file mode 100644
index 00000000..e040b0b2
--- /dev/null
+++ b/dev-libs/osformat/osformat-1.0.0.ebuild
@@ -0,0 +1,21 @@
+# Copyright 2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+RESTRICT="mirror"
+inherit eutils
+
+SRC_URI="https://github.com/vaeth/osformat/releases/download/v${PV}/${P}.tar.xz"
+
+DESCRIPTION="C++ library for a typesafe printf/sprintf based on << conversion"
+HOMEPAGE="https://github.com/vaeth/osformat/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x86-freebsd ~ia64-hpux ~x86-interix ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+src_install() {
+ default
+ prune_libtool_files
+}
diff --git a/dev-libs/osformat/osformat-999999999.ebuild b/dev-libs/osformat/osformat-999999999.ebuild
new file mode 100644
index 00000000..fe9ec08d
--- /dev/null
+++ b/dev-libs/osformat/osformat-999999999.ebuild
@@ -0,0 +1,36 @@
+# Copyright 2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit autotools eutils
+
+case ${PV} in
+99999999*)
+ EGIT_REPO_URI="git://github.com/vaeth/${PN}.git"
+ inherit git-r3
+ SRC_URI=""
+ PROPERTIES="live";;
+*)
+ RESTRICT="mirror"
+ EGIT_COMMIT="7ea6497698b11fa3289b223b2e2d487500dcaa10"
+ SRC_URI="https://github.com/vaeth/${PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/${PN}-${EGIT_COMMIT}";;
+esac
+
+DESCRIPTION="C++ library for a typesafe printf/sprintf based on << conversion"
+HOMEPAGE="https://github.com/vaeth/osformat/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS=""
+IUSE=""
+
+src_prepare() {
+ eapply_user
+ eautoreconf
+}
+
+src_install() {
+ default
+ prune_libtool_files
+}