summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-portage/eix/Manifest3
-rw-r--r--app-portage/eix/eix-0.33.4.ebuild (renamed from app-portage/eix/eix-0.33.3.ebuild)0
-rw-r--r--app-portage/eix/eix-0.33.4_alpha20180722.ebuild169
-rw-r--r--metadata/pkg_desc_index2
4 files changed, 2 insertions, 172 deletions
diff --git a/app-portage/eix/Manifest b/app-portage/eix/Manifest
index 99abe493..2593c931 100644
--- a/app-portage/eix/Manifest
+++ b/app-portage/eix/Manifest
@@ -1,2 +1 @@
-DIST eix-0.33.3.tar.xz 622552 SHA512 52750da030f486a0ce6b3bc089f19b36ca1c433cfd45fd711fec538e7ad73d467f9ea2b3bf7acb4d1a1d357331f733b7f8df1f96c749f584140eec6eecafce79
-DIST eix-0.33.4_alpha20180722.tar.gz 676733 SHA512 e46a4ca53cf7ca74832707eff93cf44464c5c1157a2f1dd44b8b4265fc5ead5dc97277ff1f6d060724f817d8c01be3b805585bf17a2aa9663fd2a236343aafc4
+DIST eix-0.33.4.tar.xz 622844 SHA512 bc031a8751d2b20eba5d05375250bcbd163847d4fad9c0994b01cd01304e00db745b0111127f752599d182350b4aa6de7a211fc5cd011de8d0aab0c4a539418e
diff --git a/app-portage/eix/eix-0.33.3.ebuild b/app-portage/eix/eix-0.33.4.ebuild
index 3a1b2021..3a1b2021 100644
--- a/app-portage/eix/eix-0.33.3.ebuild
+++ b/app-portage/eix/eix-0.33.4.ebuild
diff --git a/app-portage/eix/eix-0.33.4_alpha20180722.ebuild b/app-portage/eix/eix-0.33.4_alpha20180722.ebuild
deleted file mode 100644
index 350a4250..00000000
--- a/app-portage/eix/eix-0.33.4_alpha20180722.ebuild
+++ /dev/null
@@ -1,169 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-WANT_LIBTOOL=none
-AUTOTOOLS_AUTO_DEPEND=no
-MESON_AUTO_DEPEND=no
-inherit autotools bash-completion-r1 meson tmpfiles
-
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~x64-cygwin ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-case ${PV} in
-99999999*)
- EGIT_REPO_URI="https://github.com/vaeth/${PN}.git"
- inherit git-r3
- SRC_URI=""
- KEYWORDS=""
- PROPERTIES="live";;
-*)
- RESTRICT="mirror"
- EGIT_COMMIT="8dbd83120e84d5e30593e87e9212733ac2acda0b"
- SRC_URI="https://github.com/vaeth/${PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
- S="${WORKDIR}/${PN}-${EGIT_COMMIT}";;
-esac
-
-DESCRIPTION="Search and query ebuilds"
-HOMEPAGE="https://github.com/vaeth/eix/"
-
-LICENSE="GPL-2"
-SLOT="0"
-PLOCALES="de ru"
-IUSE="debug +dep doc +jumbo-build"
-for i in ${PLOCALES}; do
- IUSE+=" l10n_${i}"
-done
-IUSE+=" +meson nls optimization +required-use security strong-optimization strong-security sqlite swap-remote tools"
-
-BOTHDEPEND="nls? ( virtual/libintl )
- sqlite? ( >=dev-db/sqlite-3:= )"
-RDEPEND="${BOTHDEPEND}
- >=app-shells/push-3.1
- >=app-shells/quoter-4.1"
-DEPEND="${BOTHDEPEND}
- meson? (
- >=dev-util/meson-0.41.0
- >=dev-util/ninja-1.7.2
- strong-optimization? ( >=sys-devel/gcc-config-1.9.1 )
- nls? ( sys-devel/gettext )
- )
- !meson? ( ${AUTOTOOLS_DEPEND} >=sys-devel/gettext-0.19.6 )"
-
-pkg_setup() {
- # remove stale cache file to prevent collisions
- local old_cache="${EROOT}var/cache/${PN}"
- test -f "${old_cache}" && rm -f -- "${old_cache}"
-}
-
-src_prepare() {
- sed -i -e "s'/'${EPREFIX}/'" -- "${S}"/tmpfiles.d/eix.conf || die
- default
- use meson || {
- eautopoint
- eautoreconf
- }
-}
-
-src_configure() {
- local i
- export LINGUAS=
- for i in ${PLOCALES}; do
- use l10n_${i} && LINGUAS+=${LINGUAS:+ }${i}
- done
- if use meson; then
- local emesonargs=(
- -Ddocdir="${EPREFIX}/usr/share/doc/${P}"
- -Dhtmldir="${EPREFIX}/usr/share/doc/${P}/html"
- $(meson_use jumbo-build)
- $(meson_use sqlite)
- $(meson_use doc extra-doc)
- $(meson_use nls)
- $(meson_use tools separate-tools)
- $(meson_use security)
- $(meson_use optimization)
- $(meson_use strong-security)
- $(meson_use strong-optimization)
- $(meson_use debug debugging)
- $(meson_use swap-remote)
- $(meson_use prefix always-accept-keywords)
- $(meson_use dep dep-default)
- $(meson_use required-use required-use-default)
- -Dzsh-completion="${EPREFIX}/usr/share/zsh/site-functions"
- -Dportage-rootpath="${ROOTPATH}"
- -Deprefix-default="${EPREFIX}"
- )
- if use prefix; then
- emesonarge+=(
- -Deix-user=
- -Deix-uid=-1
- )
- fi
- meson_src_configure
- else
- local myconf=(
- $(use_with jumbo-build)
- $(use_with sqlite)
- $(use_with doc extra-doc)
- $(use_enable nls)
- $(use_enable tools separate-tools)
- $(use_enable security)
- $(use_enable optimization)
- $(use_enable strong-security)
- $(use_enable strong-optimization)
- $(use_enable debug debugging)
- $(use_enable swap-remote)
- $(use_with prefix always-accept-keywords)
- $(use_with dep dep-default)
- $(use_with required-use required-use-default)
- --with-zsh-completion
- --with-portage-rootpath="${ROOTPATH}"
- --with-eprefix-default="${EPREFIX}"
- )
- if use prefix; then
- myconf+=(
- --with-eix-user=
- --with-eix-uid=-1
- )
- fi
- econf "${myconf[@]}"
- fi
-}
-
-src_compile() {
- if use meson; then
- meson_src_compile
- else
- default
- fi
-}
-
-src_test() {
- if use meson; then
- meson_src_test
- else
- default
- fi
-}
-
-src_install() {
- if use meson; then
- meson_src_install
- else
- default
- fi
- dobashcomp bash/eix
- dotmpfiles tmpfiles.d/eix.conf
-}
-
-pkg_postinst() {
- local obs="${EROOT}var/cache/eix.previous"
- if test -f "${obs}"; then
- ewarn "Found obsolete ${obs}, please remove it"
- fi
- tmpfiles_process eix.conf
-}
-
-pkg_postrm() {
- if [ -z "${REPLACED_BY_VERSION}" ]; then
- rm -rf -- "${EROOT}var/cache/${PN}"
- fi
-}
diff --git a/metadata/pkg_desc_index b/metadata/pkg_desc_index
index 2d1ca7ea..0e7a2ce1 100644
--- a/metadata/pkg_desc_index
+++ b/metadata/pkg_desc_index
@@ -22,7 +22,7 @@ app-eselect/eselect-net 0.2: eselect module for managing network open-rc service
app-misc/knapsack 7.2.1: A fast solver for the 0/1-knapsack problem with multiple knapsacks
app-misc/machine-learning-mv 1.2: Some machine learning experiments
app-portage/changelog-gitrepo 1.0: Create ChangeLog data for gentoo repositories from git
-app-portage/eix 0.33.3 0.33.4_alpha20180722 99999999: Search and query ebuilds
+app-portage/eix 0.33.4 99999999: Search and query ebuilds
app-portage/etcat 1.0.1 99999999: Updated version of an old Portage information extractor
app-portage/find_cruft 5.1: find cruft files not managed by portage
app-portage/getdelta 0.7.9-r2: dynamic deltup client