summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--games-rpg/magus/ChangeLog6
-rw-r--r--games-rpg/magus/Manifest1
l---------games-rpg/magus/magus-1.3.1.ebuild1
-rw-r--r--games-rpg/magus/magus-99999999.ebuild21
4 files changed, 25 insertions, 4 deletions
diff --git a/games-rpg/magus/ChangeLog b/games-rpg/magus/ChangeLog
index 70805ebe..d5db177a 100644
--- a/games-rpg/magus/ChangeLog
+++ b/games-rpg/magus/ChangeLog
@@ -2,6 +2,12 @@
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+*magus-1.3.1 (28 Dec 2014)
+
+ 28 Dec 2014; Martin Väth <martin@mvath.de>:
+ Downgrade to now only public version from sourceforge.
+ Rename configure.in -> configure.ac for compatibility with current automake.
+
*magus-1.3.3 (28 May 2011)
21 Sep 2012; Martin Väth <martin@mvath.de>:
diff --git a/games-rpg/magus/Manifest b/games-rpg/magus/Manifest
index 09613c34..16800cab 100644
--- a/games-rpg/magus/Manifest
+++ b/games-rpg/magus/Manifest
@@ -1 +1,2 @@
+DIST magus-1.3.1.tar.bz2 7358580 SHA256 f7f118dff53b53a45d612d870bc2c9fb151d9c3aeea6f006b74fc6ab41dcb4d6 SHA512 b08231bb391d7f11c010afb0b881f063dbc1469d9032ba9ed9d3480e3d709709472a8e25d7104c5ee59f7e2fd222f417429233a9d730cb90a4538b089280e7c9 WHIRLPOOL 1b3dde3fc06e79ad80b4bc6ac34d5757ec81aa8a28fa9e82e46aa0ba9a3b30cb83d2c9ab8d8ca6f23cb51f00e978134b0646c839c0da4fa221b0fbbe4c10d522
DIST magus-1.3.3.tar.bz2 7417528 SHA256 14d75aba616149e52252fe0f1d0bae796936295aacfb82f1f620d1efd20a8e86
diff --git a/games-rpg/magus/magus-1.3.1.ebuild b/games-rpg/magus/magus-1.3.1.ebuild
new file mode 120000
index 00000000..d6487128
--- /dev/null
+++ b/games-rpg/magus/magus-1.3.1.ebuild
@@ -0,0 +1 @@
+magus-99999999.ebuild \ No newline at end of file
diff --git a/games-rpg/magus/magus-99999999.ebuild b/games-rpg/magus/magus-99999999.ebuild
index 03a8e5a1..fed20ffb 100644
--- a/games-rpg/magus/magus-99999999.ebuild
+++ b/games-rpg/magus/magus-99999999.ebuild
@@ -6,24 +6,32 @@ EAPI=5
inherit autotools eutils flag-o-matic multiprocessing
RESTRICT="mirror"
+FETCH_RESTRICT=false
+LIVE_VERSION=false
case ${PV} in
9999*)
LIVE_VERSION=:;;
-*)
- LIVE_VERSION=false;;
+1.3.3*)
+ FETCH_RESTRICT=:;;
esac
${LIVE_VERSION} && inherit monotone
DESCRIPTION="A character generator for the popular German role playing game Midgard"
-HOMEPAGE="http://midgard.berlios.de"
-SRC_URI="ftp://ftp.berlios.de/pub/midgard/Source/${P}.tar.bz2"
+HOMEPAGE="http://sourceforge.net/projects/midgard.berlios/"
+SRC_URI="mirror://sourceforge/midgard.berlios/${P}.tar.bz2"
KEYWORDS="~amd64 ~x86"
if ${LIVE_VERSION}
then PROPERTIES="live"
SRC_URI=""
EMTN_REPO_URI="petig-baender.dyndns.org"
KEYWORDS=""
+elif ${FETCH_RESTRICT}
+then SRC_URI="ftp://ftp.berlios.de/pub/midgard/Source/${P}.tar.bz2"
+# Unfortunately, the URL is down forever:
+# You can only use it, if you already downloaded the tarball earlier
+ RESTRICT="${RESTRICT} fetch"
+ KEYWORDS=""
fi
LICENSE="GPL-2"
SLOT="0"
@@ -157,6 +165,9 @@ src_patch() {
multijob_child_init src_sed midgard/src/table_lernschema.cc \
-e '/case .*:$/{n;s/^[[:space:]]*\}/break;}/}'
multijob_finish || die "basic patching failed"
+ find . -name configure.in -exec sh -c 'for i
+ do mv -- "${i}" "${i%in}ac"
+ done' sh '{}' +
}
my_cd() {
@@ -219,6 +230,8 @@ my_confmake() {
src_configure() {
filter-flags \
+ -pie \
+ -fPIE \
-flto \
-fwhole-program \
-fuse-linker-plugin \