summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--profiles/use.local.desc2
-rw-r--r--sys-process/systemd-cron/ChangeLog7
-rw-r--r--sys-process/systemd-cron/Manifest1
-rw-r--r--sys-process/systemd-cron/metadata.xml20
-rw-r--r--sys-process/systemd-cron/systemd-cron-1.2.1.ebuild47
5 files changed, 77 insertions, 0 deletions
diff --git a/profiles/use.local.desc b/profiles/use.local.desc
index 3bd4feca..9f3660ca 100644
--- a/profiles/use.local.desc
+++ b/profiles/use.local.desc
@@ -116,3 +116,5 @@ sys-fs/squash_dir:unionfs-fuse - Prefer unionfs-fuse
sys-fs/squashfs-tools:lz4 - Enable support for LZ4 compression using app-arch/lz4
sys-fs/squashfs-tools:progress-redirect - Redirect printing of progress bar to stderr. This gives a nicer output if used from scripts like sys-fs/squash_dir
sys-fs/squashfs-tools:xz - Enable support for XZ ("LZMA2") compression using app-arch/xz-utils
+sys-process/systemd-cron:cron-boot - Enable systemd boot cron target
+sys-process/systemd-cron:yearly - Enable systemd yearly cron target
diff --git a/sys-process/systemd-cron/ChangeLog b/sys-process/systemd-cron/ChangeLog
new file mode 100644
index 00000000..e12d07f4
--- /dev/null
+++ b/sys-process/systemd-cron/ChangeLog
@@ -0,0 +1,7 @@
+# ChangeLog for sys-process/systemd-cron
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+*systemd-cron-1.2.1 (05 Jun 2014)
+ 05 Jun 2014; Martin Väth <martin@mvath.de>:
+ New ebuild from scratch
diff --git a/sys-process/systemd-cron/Manifest b/sys-process/systemd-cron/Manifest
new file mode 100644
index 00000000..7e99a5ee
--- /dev/null
+++ b/sys-process/systemd-cron/Manifest
@@ -0,0 +1 @@
+DIST systemd-cron-1.2.1.tar.gz 5351 SHA256 2685b648fd75dfbbb463d954b738a3c087f4c3a14fcd08dfccd57de43086bf69 SHA512 9b9b3bc97c8e7ff08b3eb9ef3cbac40c3bbf6980ff10be1da54410b2cf96ff4fe3087006579cef1c4a7c5050e388ebd4da242c2600a166d71c84a88c22c3a549 WHIRLPOOL aff2c733583b860e066ac79a4d9cd16cc0e1d29a6cc7a957703c95ff2631f2cf73aaa137cdfb2d5e58d26ea61b51e861a056bbbc6f93edf181f0c6ed0612b895
diff --git a/sys-process/systemd-cron/metadata.xml b/sys-process/systemd-cron/metadata.xml
new file mode 100644
index 00000000..ef4e4c09
--- /dev/null
+++ b/sys-process/systemd-cron/metadata.xml
@@ -0,0 +1,20 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>martin@mvath.de</email>
+ <name>Martin Väth</name>
+ </maintainer>
+ <upstream>
+ <maintainer>
+ <email>dbb@dbb.io</email>
+ <name>Dwayne Bent</name>
+ </maintainer>
+ <bugs-to>https://github.com/dbent/systemd-cron/issues</bugs-to>
+ <remote-id type="github">dbent/systemd-cron</remote-id>
+ </upstream>
+ <use>
+ <flag name="cron-boot">Enable systemd boot cron target</flag>
+ <flag name="yearly">Enable systemd yearly cron target</flag>
+ </use>
+</pkgmetadata>
diff --git a/sys-process/systemd-cron/systemd-cron-1.2.1.ebuild b/sys-process/systemd-cron/systemd-cron-1.2.1.ebuild
new file mode 100644
index 00000000..01030566
--- /dev/null
+++ b/sys-process/systemd-cron/systemd-cron-1.2.1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+RESTRICT="mirror"
+inherit eutils systemd vcs-snapshot
+
+DESCRIPTION="systemd units to provide minimal cron daemon functionality by running scripts in cron directories"
+HOMEPAGE="https://github.com/dbent/systemd-cron/"
+SRC_URI="https://github.com/dbent/${PN}/tarball/v${PV} -> ${P}.tar.gz"
+
+LICENSE="HPND"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="cron-boot yearly"
+
+RDEPEND=">=sys-apps/systemd-212
+ sys-apps/debianutils"
+DEPEND=""
+
+src_prepare() {
+ epatch_user
+}
+
+my_use_enable() {
+ if use ${1}
+ then echo --enable-${2:-${1}}=yes
+ else echo --enable-${2:-${1}}=no
+ fi
+}
+
+src_configure() {
+ ./configure \
+ --prefix="${EPREFIX}" \
+ --runparts="${EPREFIX}/bin/run-parts" \
+ --mandir="${EPREFIX}/usr/share/man" \
+ --unitdir="$(systemd_get_unitdir)" \
+ $(my_use_enable cron-boot boot) \
+ $(my_use_enable yearly) \
+ --enable-persistent=yes
+}
+
+src_install() {
+ emake DESTDIR="${ED}" install
+ dodoc LICENSE
+}