summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-text/djview/Manifest1
-rw-r--r--app-text/djview/djview-4.10.6-r1.ebuild86
-rw-r--r--app-text/djview/metadata.xml16
-rw-r--r--metadata/pkg_desc_index1
4 files changed, 104 insertions, 0 deletions
diff --git a/app-text/djview/Manifest b/app-text/djview/Manifest
new file mode 100644
index 00000000..302152d1
--- /dev/null
+++ b/app-text/djview/Manifest
@@ -0,0 +1 @@
+DIST djview-4.10.6.tar.gz 1113072 SHA512 c06b9c4c7addd9dededdc9d441094bca685c4d23744e3d1208eab33d9d341a85f120176bf9f1b879ac6620f591eefe05ac774870b1ba3215c43baf1eaf9d14f8
diff --git a/app-text/djview/djview-4.10.6-r1.ebuild b/app-text/djview/djview-4.10.6-r1.ebuild
new file mode 100644
index 00000000..81a33b7a
--- /dev/null
+++ b/app-text/djview/djview-4.10.6-r1.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools gnome2-utils fdo-mime flag-o-matic versionator toolchain-funcs multilib nsplugins qmake-utils
+
+DESCRIPTION="Portable DjVu viewer using Qt4"
+HOMEPAGE="http://djvu.sourceforge.net/djview4.html"
+SRC_URI="mirror://sourceforge/djvu/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~x86"
+IUSE="debug nsplugin"
+
+RDEPEND="
+ >=app-text/djvu-3.5.22-r1
+ dev-qt/qtdbus:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtopengl:5
+ dev-qt/qtprintsupport:5
+ dev-qt/qtwidgets:5"
+DEPEND="${RDEPEND}
+ >=sys-devel/autoconf-2.67
+ virtual/pkgconfig
+ nsplugin? ( dev-libs/glib:2 )"
+
+src_prepare() {
+ # Force XEmbed instead of Xt-based mainloop (disable Xt autodep)
+ sed -e 's:\(ac_xt=\)yes:\1no:' -i configure* || die
+ sed 's/AC_CXX_OPTIMIZE/OPTS=;AC_SUBST(OPTS)/' -i configure.ac || die #263688
+ rm aclocal.m4 config/{libtool.m4,install-sh,ltmain.sh,lt*.m4}
+ AT_M4DIR="config" eautoreconf
+ default
+}
+
+src_configure() {
+ # See config/acinclude.m4
+ use debug || append-cppflags "-DNDEBUG"
+
+ # QTDIR is needed because of kde3
+ QTDIR=/usr \
+ QMAKE="$(qt5_get_bindir)"/qmake \
+ econf \
+ --with-x \
+ $(use_enable nsplugin nsdejavu) \
+ --disable-desktopfiles
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" CXX="$(tc-getCXX)"
+}
+
+src_install() {
+ emake DESTDIR="${D}" \
+ plugindir=/usr/$(get_libdir)/${PLUGINS_DIR} \
+ install
+
+ dodoc README NEWS
+
+ cd desktopfiles
+ insinto /usr/share/icons/hicolor/32x32/apps
+ newins prebuilt-hi32-djview4.png djvulibre-djview4.png
+ insinto /usr/share/icons/hicolor/64x64/apps
+ newins prebuilt-hi64-djview4.png djvulibre-djview4.png
+ insinto /usr/share/icons/hicolor/scalable/apps
+ newins djview.svg djvulibre-djview4.svg
+ sed -i -e 's/Exec=djview4/Exec=djview/' djvulibre-djview4.desktop
+ domenu djvulibre-djview4.desktop
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ fdo-mime_desktop_database_update
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ fdo-mime_desktop_database_update
+ gnome2_icon_cache_update
+}
diff --git a/app-text/djview/metadata.xml b/app-text/djview/metadata.xml
new file mode 100644
index 00000000..26ab3a1c
--- /dev/null
+++ b/app-text/djview/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>martin@mvath.de</email>
+ <name>Martin Väth</name>
+ <description>maintainer of the updates in the mv overlay</description>
+ </maintainer>
+ <maintainer type="project">
+ <email>tex@gentoo.org</email>
+ <name>Gentoo TeX Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">djvu</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/metadata/pkg_desc_index b/metadata/pkg_desc_index
index f6aee8c5..d1ccbe7e 100644
--- a/metadata/pkg_desc_index
+++ b/metadata/pkg_desc_index
@@ -47,6 +47,7 @@ app-shells/set_prompt 3.0.0: An intelligent prompt for zsh or bash with status l
app-shells/termcolors-mv 4.6: 256colors sample script and dircolors configuration for standard or 256 colors
app-shells/zsh-syntax-highlighting 0.6.0 99999999: Fish shell like syntax highlighting for zsh
app-shells/zshrc-mv 3.10: A zshrc file initializing zsh specific interactive features
+app-text/djview 4.10.6-r1: Portable DjVu viewer using Qt4
app-text/ispell 3.3.02-r1 3.4.00: fast screen-oriented spelling checker
app-text/lesspipe 1.83 1.84_alpha20170925 99999999: Wolfgang Friebel's preprocessor for sys-apps/less. Disable by appending colon
app-text/mbtpdfasm 1.0.28-r1: Tool to assemble/merge, extract information from, and update the metadata in PDF