summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--metadata/pkg_desc_index2
-rw-r--r--x11-libs/gtk+/Manifest3
-rw-r--r--x11-libs/gtk+/gtk+-3.24.9.ebuild (renamed from x11-libs/gtk+/gtk+-3.24.8.ebuild)78
3 files changed, 47 insertions, 36 deletions
diff --git a/metadata/pkg_desc_index b/metadata/pkg_desc_index
index 34ba87ba..d685bc74 100644
--- a/metadata/pkg_desc_index
+++ b/metadata/pkg_desc_index
@@ -130,5 +130,5 @@ www-plugins/noscript 10.6.3: Firefox webextension: restrict active contents like
www-plugins/skip-redirect 2.2.1: Firefox webextension: skip intermediary pages before redirecting
www-plugins/translate-to-me 1.1: Firefox webextension: translate the selected text with www.linguee.com
www-plugins/ublock-origin 1.17.2: Firefox webextension: An efficient list-based blocker
-x11-libs/gtk+ 2.24.32-r1 3.24.8: Gimp ToolKit +
+x11-libs/gtk+ 2.24.32-r1 3.24.9: Gimp ToolKit +
x11-libs/motif 2.3.8-r1: The Motif user interface component toolkit
diff --git a/x11-libs/gtk+/Manifest b/x11-libs/gtk+/Manifest
index a91d26aa..d3d0c749 100644
--- a/x11-libs/gtk+/Manifest
+++ b/x11-libs/gtk+/Manifest
@@ -1,4 +1,3 @@
DIST gtk+-2.24.32-patchset.tar.xz 6392 SHA512 6c8763826b479c9c122bb991ae42b0ce0e754d460be5c6ea8d1bba28f7318c014822eccaae0b39c3b7c16804991c8c46c53cd8ded3ad6212830a2f5746567543
DIST gtk+-2.24.32.tar.xz 12620860 SHA512 8e8fd9ae32f1d6fb544da260f00599f0f05090d910d767b06ef086ab4f1f8373a29bb0da9767761c9b5f4cfd51b5c45d0fa5d39b0428c839ddf0a579df806696
-DIST gtk+-3.24.8-patchset.tar.xz 3684 SHA512 31f9b982592a81095afad91f16ad96e72a7a2b0e2bf812f0b719da56d70235bc06bc991b5f619fefded3e1634efc5b7e8ef00053929c89e967351d8625518428
-DIST gtk+-3.24.8.tar.xz 22419364 SHA512 a988ca2e25f0f32e55b2931f16c72f9649ed98405579d217e8a5e7f0ac10bcd1969090c622c5d9eb7d75235813ff7ccb90e30e252afd71ba283c6172ee459fe5
+DIST gtk+-3.24.9.tar.xz 20983908 SHA512 b303db40d5e277841738982a97edd67076febe41b3a455344aeff05c6a5b149c6d3b953cc5db1a792b63cdcc44c2d28f955d81065cb2c6b3f00d0b133a555d7a
diff --git a/x11-libs/gtk+/gtk+-3.24.8.ebuild b/x11-libs/gtk+/gtk+-3.24.9.ebuild
index 56653b38..6172680c 100644
--- a/x11-libs/gtk+/gtk+-3.24.8.ebuild
+++ b/x11-libs/gtk+/gtk+-3.24.9.ebuild
@@ -9,7 +9,7 @@ inherit flag-o-matic gnome2 multilib virtualx multilib-minimal
DESCRIPTION="Gimp ToolKit +"
HOMEPAGE="https://www.gtk.org/"
-SRC_URI=${SRC_URI}" https://dev.gentoo.org/~leio/distfiles/${P}-patchset.tar.xz"
+SRC_URI=${SRC_URI}
LICENSE="LGPL-2+"
SLOT="3"
@@ -43,7 +43,7 @@ COMMON_DEPEND="
>=net-libs/rest-0.7[${MULTILIB_USEDEP}]
>=dev-libs/json-glib-1.0[${MULTILIB_USEDEP}] )
colord? ( >=x11-misc/colord-0.1.9:0=[${MULTILIB_USEDEP}] )
- cups? ( >=net-print/cups-1.2[${MULTILIB_USEDEP}] )
+ cups? ( >=net-print/cups-2.0[${MULTILIB_USEDEP}] )
introspection? ( >=dev-libs/gobject-introspection-1.39:= )
wayland? (
>=dev-libs/wayland-1.9.91[${MULTILIB_USEDEP}]
@@ -124,11 +124,8 @@ src_prepare() {
strip_builddir SRC_SUBDIRS examples Makefile.{am,in}
fi
- # Select patches from origin/gtk-3-24 on 2019-04-20
- eapply "${WORKDIR}"/patches
-
# gtk-update-icon-cache is installed by dev-util/gtk-update-icon-cache
- eapply "${FILESDIR}"/${P}-update-icon-cache.patch
+ eapply "${FILESDIR}"/${PN}-3.24.8-update-icon-cache.patch
# Fix broken autotools logic
eapply "${FILESDIR}"/${PN}-3.22.20-libcloudproviders-automagic.patch
@@ -145,34 +142,49 @@ src_prepare() {
}
multilib_src_configure() {
- # need libdir here to avoid a double slash in a path that libtool doesn't
- # grok so well during install (// between $EPREFIX and usr ...)
- # cloudprovider is not packaged in Gentoo
- ECONF_SOURCE=${S} \
- gnome2_src_configure \
- $(use_enable aqua quartz-backend) \
- $(use_enable broadway broadway-backend) \
- $(use_enable cloudprint) \
- $(use_enable colord) \
- $(use_enable cups cups auto) \
- $(multilib_native_use_enable gtk-doc) \
- $(multilib_native_use_enable introspection) \
- $(use_enable wayland wayland-backend) \
- $(use_enable X x11-backend) \
- $(use_enable X xcomposite) \
- $(use_enable X xdamage) \
- $(use_enable X xfixes) \
- $(use_enable X xkb) \
- $(use_enable X xrandr) \
- $(use_enable xinerama) \
- $(use_with atk-bridge) \
- --disable-cloudproviders \
- --disable-mir-backend \
- --disable-papi \
- --enable-man \
- --with-xml-catalog="${EPREFIX}"/etc/xml/catalog \
- --libdir="${EPREFIX}"/usr/$(get_libdir) \
+ local myconf=(
+ $(use_enable aqua quartz-backend)
+ $(use_enable broadway broadway-backend)
+ $(use_enable cloudprint)
+ $(use_enable colord)
+ $(use_enable cups cups auto)
+ $(multilib_native_use_enable gtk-doc)
+ $(multilib_native_use_enable introspection)
+ $(use_enable wayland wayland-backend)
+ $(use_enable X x11-backend)
+ $(use_enable X xcomposite)
+ $(use_enable X xdamage)
+ $(use_enable X xfixes)
+ $(use_enable X xkb)
+ $(use_enable X xrandr)
+ $(use_enable xinerama)
+ $(use_with atk-bridge)
+ # cloudprovider is not packaged in Gentoo yet
+ --disable-cloudproviders
+ --disable-mir-backend
+ --disable-papi
+ # sysprof integration needs >=sysprof-3.33.2 and passing --disable-profiler
+ # would force enable it - https://gitlab.gnome.org/GNOME/gtk/issues/1965
+ # --disable-profiler
+ --enable-man
+ --with-xml-catalog="${EPREFIX}"/etc/xml/catalog
+ # need libdir here to avoid a double slash in a path that libtool doesn't
+ # grok so well during install (// between $EPREFIX and usr ...)
+ # TODO: Is this still the case?
+ --libdir="${EPREFIX}"/usr/$(get_libdir)
CUPS_CONFIG="${EPREFIX}/usr/bin/${CHOST}-cups-config"
+ )
+
+ if use wayland; then
+ myconf+=(
+ # Include wayland immodule into gtk itself, to avoid problems like
+ # https://gitlab.gnome.org/GNOME/gnome-shell/issues/109 from a
+ # user overridden GTK_IM_MODULE envvar
+ --with-included-immodules=wayland
+ )
+ fi;
+
+ ECONF_SOURCE=${S} gnome2_src_configure "${myconf[@]}"
# work-around gtk-doc out-of-source brokedness
if multilib_is_native_abi; then